summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-10 11:40:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-10 11:40:01 +0000
commita11a3e34da30231375c22c568f11bcac5758932b (patch)
tree03f50c44d9188afb725ef9b49dff69f22c3e9df5 /gnome-extra/libgtkhtml
parentAdded patch for FreeBSD compatibility (missing include). (diff)
downloadgentoo-2-a11a3e34da30231375c22c568f11bcac5758932b.tar.gz
gentoo-2-a11a3e34da30231375c22c568f11bcac5758932b.tar.bz2
gentoo-2-a11a3e34da30231375c22c568f11bcac5758932b.zip
Added patch to build on non-GNU userland. Bug #103415.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'gnome-extra/libgtkhtml')
-rw-r--r--gnome-extra/libgtkhtml/ChangeLog6
-rw-r--r--gnome-extra/libgtkhtml/files/libgtkhtml-3.6.2-fbsd.patch10
-rw-r--r--gnome-extra/libgtkhtml/libgtkhtml-3.6.2.ebuild12
3 files changed, 25 insertions, 3 deletions
diff --git a/gnome-extra/libgtkhtml/ChangeLog b/gnome-extra/libgtkhtml/ChangeLog
index 9c316c82c3bf..356050610c86 100644
--- a/gnome-extra/libgtkhtml/ChangeLog
+++ b/gnome-extra/libgtkhtml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/libgtkhtml
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/ChangeLog,v 1.148 2005/10/10 07:54:17 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/ChangeLog,v 1.149 2005/10/10 11:40:01 flameeyes Exp $
+
+ 10 Oct 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libgtkhtml-3.6.2-fbsd.patch, libgtkhtml-3.6.2.ebuild:
+ Added patch to build on non-GNU userland. Bug #103415.
10 Oct 2005; Hardave Riar <hardave@gentoo.org> libgtkhtml-3.6.2.ebuild:
Stable on mips.
diff --git a/gnome-extra/libgtkhtml/files/libgtkhtml-3.6.2-fbsd.patch b/gnome-extra/libgtkhtml/files/libgtkhtml-3.6.2-fbsd.patch
new file mode 100644
index 000000000000..df4fac948548
--- /dev/null
+++ b/gnome-extra/libgtkhtml/files/libgtkhtml-3.6.2-fbsd.patch
@@ -0,0 +1,10 @@
+--- po/Makefile.in.in.orig Tue Nov 23 17:53:53 2004
++++ po/Makefile.in.in Tue Nov 23 17:58:38 2004
+@@ -31,6 +31,7 @@
+ localedir = $(libdir)/locale
+ gnulocaledir = $(datadir)/locale
+ gettextsrcdir = $(datadir)/glib-2.0/gettext/po
++mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ subdir = po
+
+ INSTALL = @INSTALL@
diff --git a/gnome-extra/libgtkhtml/libgtkhtml-3.6.2.ebuild b/gnome-extra/libgtkhtml/libgtkhtml-3.6.2.ebuild
index 271bd31f9767..1a7b71ebcaa3 100644
--- a/gnome-extra/libgtkhtml/libgtkhtml-3.6.2.ebuild
+++ b/gnome-extra/libgtkhtml/libgtkhtml-3.6.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-3.6.2.ebuild,v 1.11 2005/10/10 07:54:17 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-3.6.2.ebuild,v 1.12 2005/10/10 11:40:01 flameeyes Exp $
-inherit versionator gnome2
+inherit versionator gnome2 eutils
MY_P=${P/lib/}
MY_PN=${PN/lib/}
@@ -41,3 +41,11 @@ ELTCONF="--reverse-deps"
DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
G2CONF="${G2CONF} $(use_enable static)"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-fbsd.patch
+}
+