summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-23 19:55:16 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-23 19:55:16 +0000
commitf265c7f4b47062df805e285f84c4d58ea776ed13 (patch)
tree8f85eca2c97f09beaca34738b33809b146bda1d3 /gnome-extra
parentversion bump (diff)
downloadgentoo-2-f265c7f4b47062df805e285f84c4d58ea776ed13.tar.gz
gentoo-2-f265c7f4b47062df805e285f84c4d58ea776ed13.tar.bz2
gentoo-2-f265c7f4b47062df805e285f84c4d58ea776ed13.zip
gnome-extra/zeitgeist: Version Bump
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/zeitgeist/ChangeLog8
-rw-r--r--gnome-extra/zeitgeist/files/zeitgeist-0.9.0-doc.patch16
-rw-r--r--gnome-extra/zeitgeist/files/zeitgeist-0.9.0-gobject.patch15
-rw-r--r--gnome-extra/zeitgeist/zeitgeist-0.9.0.ebuild80
4 files changed, 118 insertions, 1 deletions
diff --git a/gnome-extra/zeitgeist/ChangeLog b/gnome-extra/zeitgeist/ChangeLog
index 4aaab608ba3d..addac97a3edb 100644
--- a/gnome-extra/zeitgeist/ChangeLog
+++ b/gnome-extra/zeitgeist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/zeitgeist
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zeitgeist/ChangeLog,v 1.10 2012/03/25 15:25:41 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zeitgeist/ChangeLog,v 1.11 2012/04/23 19:55:16 jlec Exp $
+
+*zeitgeist-0.9.0 (23 Apr 2012)
+
+ 23 Apr 2012; Justin Lecher <jlec@gentoo.org> +zeitgeist-0.9.0.ebuild,
+ +files/zeitgeist-0.9.0-doc.patch, +files/zeitgeist-0.9.0-gobject.patch:
+ Version Bump
25 Mar 2012; Gilles Dartiguelongue <eva@gentoo.org>
zeitgeist-0.8.2-r1.ebuild:
diff --git a/gnome-extra/zeitgeist/files/zeitgeist-0.9.0-doc.patch b/gnome-extra/zeitgeist/files/zeitgeist-0.9.0-doc.patch
new file mode 100644
index 000000000000..016336becdaf
--- /dev/null
+++ b/gnome-extra/zeitgeist/files/zeitgeist-0.9.0-doc.patch
@@ -0,0 +1,16 @@
+ Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 824aa91..c991754 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,7 +10,7 @@ SUBDIRS = \
+ doc \
+ $(NULL)
+
+-zeitgeistdocdir = ${prefix}/doc/zeitgeist
++zeitgeistdocdir = ${docdir}
+ zeitgeistdoc_DATA = \
+ AUTHORS \
+ NEWS \
diff --git a/gnome-extra/zeitgeist/files/zeitgeist-0.9.0-gobject.patch b/gnome-extra/zeitgeist/files/zeitgeist-0.9.0-gobject.patch
new file mode 100644
index 000000000000..1099c22b3bca
--- /dev/null
+++ b/gnome-extra/zeitgeist/files/zeitgeist-0.9.0-gobject.patch
@@ -0,0 +1,15 @@
+ configure.ac | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index fc0b202..6db8686 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -33,6 +33,7 @@ SQLITE_REQUIRED=3.7
+ ZEITGEIST_REQUIRED="glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0 >= $GLIB_REQUIRED
+ gio-unix-2.0 >= $GLIB_REQUIRED
++ gmodule-2.0 >= $GLIB_REQUIRED
+ sqlite3 >= $SQLITE_REQUIRED"
+
+ PKG_CHECK_MODULES(ZEITGEIST, [$ZEITGEIST_REQUIRED])
diff --git a/gnome-extra/zeitgeist/zeitgeist-0.9.0.ebuild b/gnome-extra/zeitgeist/zeitgeist-0.9.0.ebuild
new file mode 100644
index 000000000000..2667c258c4cc
--- /dev/null
+++ b/gnome-extra/zeitgeist/zeitgeist-0.9.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/zeitgeist/zeitgeist-0.9.0.ebuild,v 1.1 2012/04/23 19:55:16 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils python versionator
+
+DIR_PV=$(get_version_component_range 1-2)
+EXT_VER=0.0.13
+
+DESCRIPTION="Service to log activities and present to other apps"
+HOMEPAGE="http://launchpad.net/zeitgeist/"
+SRC_URI="http://launchpad.net/zeitgeist/${DIR_PV}/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus extensions +fts +icu nls passiv plugins"
+
+RDEPEND="
+ dev-python/dbus-python
+ dev-python/pygobject:2
+ dev-python/pyxdg
+ dev-python/rdflib
+ media-libs/raptor:2
+ dev-libs/glib:2
+ dev-lang/vala:0.14
+ dev-db/sqlite:3
+ extensions? ( gnome-extra/zeitgeist-extensions )
+ icu? ( dev-libs/dee[icu?] )
+ passiv? ( gnome-extra/zeitgeist-datahub )
+ plugins? ( gnome-extra/zeitgeist-datasources )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gobject.patch
+ "${FILESDIR}"/${P}-doc.patch
+ )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ export VALAC=$(type -p valac-0.14)
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ $(use_with icu dee-icu)
+ $(use_with dbus session-bus-services-dir)
+ )
+ use nls || myeconfargs+=(--disable-nls)
+ use fts || myeconfargs+=(--disable-fts)
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ python_convert_shebangs -r 2 "${ED}"
+}
+
+pkg_postinst() {
+ python_mod_optimize zeitgeist
+}
+
+pkg_postrm() {
+ python_mod_cleanup zeitgeist
+}