summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-09-03 15:05:06 +0000
committerFabian Groffen <grobian@gentoo.org>2006-09-03 15:05:06 +0000
commit044bce05279916dfdeaa3946ac117fabec427f93 (patch)
tree2b1d18ad940526840334a8dbaacb6c750ed316b4 /gnustep-base
parentStable on ia64. (diff)
downloadgentoo-2-044bce05279916dfdeaa3946ac117fabec427f93.tar.gz
gentoo-2-044bce05279916dfdeaa3946ac117fabec427f93.tar.bz2
gentoo-2-044bce05279916dfdeaa3946ac117fabec427f93.zip
Upstream version bump to 1.13.0, thanks to Dmitry S. Kulyabov in bug #145563
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog8
-rw-r--r--gnustep-base/gnustep-make/files/digest-gnustep-make-1.13.03
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-1.13.0.ebuild175
3 files changed, 185 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index fdebe7717a21..3e5d627449f7 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.36 2006/08/21 02:06:35 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.37 2006/09/03 15:05:05 grobian Exp $
+
+*gnustep-make-1.13.0 (03 Sep 2006)
+
+ 03 Sep 2006; Fabian Groffen <grobian@gentoo.org>
+ +gnustep-make-1.13.0.ebuild:
+ Upstream version bump to 1.13.0, thanks to Dmitry S. Kulyabov in bug #145563
20 Aug 2006; Tom Gall <tgall@gentoo.org> gnustep-make-1.12.0-r1.ebuild:
added ~ppc64
diff --git a/gnustep-base/gnustep-make/files/digest-gnustep-make-1.13.0 b/gnustep-base/gnustep-make/files/digest-gnustep-make-1.13.0
new file mode 100644
index 000000000000..c73dc4f444ff
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/digest-gnustep-make-1.13.0
@@ -0,0 +1,3 @@
+MD5 1d7a434e751c58c6390055c14ada302b gnustep-make-1.13.0.tar.gz 400157
+RMD160 b1d619d7c677463bf1a4adae82a412ad95157dc2 gnustep-make-1.13.0.tar.gz 400157
+SHA256 d79c11bada9ccd32d0ab08a0dfbd776731b02103975a22b6b95284046b740e8f gnustep-make-1.13.0.tar.gz 400157
diff --git a/gnustep-base/gnustep-make/gnustep-make-1.13.0.ebuild b/gnustep-base/gnustep-make/gnustep-make-1.13.0.ebuild
new file mode 100644
index 000000000000..56c03cf6fbb0
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-1.13.0.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-1.13.0.ebuild,v 1.1 2006/09/03 15:05:05 grobian Exp $
+
+inherit gnustep
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE="${IUSE} doc non-flattened layout-osx-like layout-from-conf-file"
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}
+ ${DOC_RDEPEND}"
+
+egnustep_install_domain "System"
+
+pkg_setup() {
+ gnustep_pkg_setup
+
+ if [ "$(objc_available)" == "no" ]; then
+ objc_not_available_info
+ die "ObjC support not available"
+ fi
+
+ if use layout-from-conf-file && use layout-osx-like ; then
+ eerror "layout-from-conf-file and layout-osx-like are mutually exclusive use flags."
+ die "USE flag misconfiguration -- please correct"
+ fi
+
+ if use layout-from-conf-file || use layout-osx-like ; then
+ ewarn "USE layout-from-conf-file || layout-osx-like"
+ ewarn "Utilizing these USE flags allows one to install files in non standard"
+ ewarn " locations vis a vis the Linux FHS -- please fully comprehend what you"
+ ewarn " are doing when setting this USE flag."
+ fi
+
+ if use layout-from-conf-file; then
+ if [ ! -f /etc/conf.d/gnustep.env ]; then
+ eerror "There is no /etc/conf.d/gnustep.env file!"
+ eerror "Did you read the USE flag description?"
+ die "USE flag misconfiguration -- please correct"
+ else
+ unset GNUSTEP_SYSTEM_ROOT
+ unset GNUSTEP_LOCAL_ROOT
+ unset GNUSTEP_NETWORK_ROOT
+ unset GNUSTEP_USER_ROOT
+ . /etc/conf.d/gnustep.env
+ if [ -z "${GNUSTEP_SYSTEM_ROOT}" ] || [ "/" != "${GNUSTEP_SYSTEM_ROOT:0:1}" ]; then
+ eerror "GNUSTEP_SYSTEM_ROOT is missing or misconfigured in /etc/conf.d/gnustep.env"
+ eerror "GNUSTEP_SYSTEM_ROOT=${GNUSTEP_SYSTEM_ROOT}"
+ die "USE flag misconfiguration -- please correct"
+ fi
+ if [ "/System" != ${GNUSTEP_SYSTEM_ROOT:$((${#GNUSTEP_SYSTEM_ROOT}-7)):7} ]; then
+ eerror "GNUSTEP_SYSTEM_ROOT must end with \"System\" -- read the USE flag directions!!!"
+ die "USE flag misconfiguration -- please correct"
+ fi
+ if [ "${GNUSTEP_LOCAL_ROOT}" ] && [ "/" != "${GNUSTEP_LOCAL_ROOT:0:1}" ]; then
+ eerror "GNUSTEP_LOCAL_ROOT is misconfigured in /etc/conf.d/gnustep.env"
+ eerror "GNUSTEP_LOCAL_ROOT=${GNUSTEP_LOCAL_ROOT}"
+ die "USE flag misconfiguration -- please correct"
+ elif [ -z "${GNUSTEP_LOCAL_ROOT}" ]; then
+ GNUSTEP_LOCAL_ROOT="$(dirname ${GNUSTEP_SYSTEM_ROOT})/Local"
+ fi
+ if [ "${GNUSTEP_NETWORK_ROOT}" ] && [ "/" != "${GNUSTEP_NETWORK_ROOT:0:1}" ]; then
+ eerror "GNUSTEP_NETWORK_ROOT is misconfigured in /etc/conf.d/gnustep.env"
+ eerror "GNUSTEP_NETWORK_ROOT=${GNUSTEP_NETWORK_ROOT}"
+ die "USE flag misconfiguration -- please correct"
+ elif [ -z "${GNUSTEP_NETWORK_ROOT}" ]; then
+ GNUSTEP_NETWORK_ROOT="$(dirname ${GNUSTEP_SYSTEM_ROOT})/Network"
+ fi
+ if [ "${GNUSTEP_USER_ROOT}" ] && [ '~' != "${GNUSTEP_USER_ROOT:0:1}" ]; then
+ eerror "GNUSTEP_USER_ROOT is misconfigured in /etc/conf.d/gnustep.env"
+ eerror "GNUSTEP_USER_ROOT=${GNUSTEP_USER_ROOT}"
+ die "USE flag misconfiguration -- please correct"
+ elif [ -z "${GNUSTEP_USER_ROOT}" ]; then
+ GNUSTEP_USER_ROOT='~/GNUstep'
+ fi
+
+ egnustep_prefix "$(dirname ${GNUSTEP_SYSTEM_ROOT})"
+ egnustep_system_root "${GNUSTEP_SYSTEM_ROOT}"
+ egnustep_local_root "${GNUSTEP_LOCAL_ROOT}"
+ egnustep_network_root "${GNUSTEP_NETWORK_ROOT}"
+ egnustep_user_root "${GNUSTEP_USER_ROOT}"
+ fi
+ elif use layout-osx-like; then
+ egnustep_prefix "/"
+ egnustep_system_root "/System"
+ egnustep_local_root "/"
+ egnustep_network_root "/Network"
+ egnustep_user_root '~'
+ else
+ # setup defaults here
+ egnustep_prefix "/usr/GNUstep"
+ egnustep_system_root "/usr/GNUstep/System"
+ egnustep_local_root "/usr/GNUstep/Local"
+ egnustep_network_root "/usr/GNUstep/Network"
+ egnustep_user_root '~/GNUstep'
+ fi
+
+ einfo "GNUstep installation will be laid out as follows:"
+ einfo "\tGNUSTEP_SYSTEM_ROOT=`egnustep_system_root`"
+ einfo "\tGNUSTEP_LOCAL_ROOT=`egnustep_local_root`"
+ einfo "\tGNUSTEP_NETWORK_ROOT=`egnustep_network_root`"
+ einfo "\tGNUSTEP_USER_ROOT=`egnustep_user_root`"
+}
+
+src_compile() {
+ cd ${S}
+
+ # gnustep-make ./configure : "prefix" here is going to be where
+ # "System" is installed -- other correct paths should be set
+ # by econf
+ local myconf
+ myconf="--prefix=`egnustep_prefix`"
+ use non-flattened && myconf="$myconf --disable-flattened --enable-multi-platform"
+ myconf="$myconf --with-tar=/bin/tar"
+ myconf="$myconf --with-local-root=`egnustep_local_root`"
+ myconf="$myconf --with-network-root=`egnustep_network_root`"
+ myconf="$myconf --with-user-root=`egnustep_user_root`"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}
+
+src_install() {
+ . ${S}/GNUstep.sh
+
+ local make_eval="INSTALL_ROOT=${D} \
+ GNUSTEP_SYSTEM_ROOT=${D}$(egnustep_system_root) \
+ GNUSTEP_NETWORK_ROOT=${D}$(egnustep_network_root) \
+ GNUSTEP_LOCAL_ROOT=${D}$(egnustep_local_root) \
+ GNUSTEP_MAKEFILES=${D}$(egnustep_system_root)/Library/Makefiles \
+ GNUSTEP_USER_ROOT=${TMP} \
+ GNUSTEP_DEFAULTS_ROOT=${TMP}/${__GS_USER_ROOT_POSTFIX} \
+ -j1"
+
+ local docinstall="GNUSTEP_INSTALLATION_DIR=${D}$(egnustep_system_root)"
+
+ make_eval="${make_eval} GNUSTEP_INSTALLATION_DIR=${D}$(egnustep_system_root)"
+
+ use debug && make_eval="${make_eval} debug=yes"
+ use verbose && make_eval="${make_eval} verbose=yes"
+
+ make ${make_eval} special_prefix=${D} install \
+ || die "install has failed"
+
+ if use doc ; then
+ cd Documentation
+ emake ${make_eval} all \
+ || die "doc make has failed"
+ emake ${make_eval} ${docinstall} install \
+ || die "doc install has failed"
+ cd ..
+ fi
+
+ dodir /etc/conf.d
+ echo "GNUSTEP_SYSTEM_ROOT=$(egnustep_system_root)" > ${D}/etc/conf.d/gnustep.env
+ echo "GNUSTEP_LOCAL_ROOT=$(egnustep_local_root)" >> ${D}/etc/conf.d/gnustep.env
+ echo "GNUSTEP_NETWORK_ROOT=$(egnustep_network_root)" >> ${D}/etc/conf.d/gnustep.env
+ echo "GNUSTEP_USER_ROOT='$(egnustep_user_root)'" >> ${D}/etc/conf.d/gnustep.env
+
+ insinto /etc/GNUstep
+ doins ${S}/GNUstep.conf
+
+ exeinto /etc/profile.d
+ doexe ${FILESDIR}/gnustep.sh
+ doexe ${FILESDIR}/gnustep.csh
+}
+