summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-04-03 18:14:07 +0000
committerDan Armak <danarmak@gentoo.org>2002-04-03 18:14:07 +0000
commita861af5b16e4029beaf86cac2cabcf9fb0df7280 (patch)
tree65bc96dfbec68d9a38e1e9193841b1aefd37a4ca /kde-base/kdebase
parentunmasked gcc3 fixed version of pam (diff)
downloadgentoo-2-a861af5b16e4029beaf86cac2cabcf9fb0df7280.tar.gz
gentoo-2-a861af5b16e4029beaf86cac2cabcf9fb0df7280.tar.bz2
gentoo-2-a861af5b16e4029beaf86cac2cabcf9fb0df7280.zip
new (masked) kde3 ebuilds
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/files/startkde-3.0-gentoo.diff23
-rw-r--r--kde-base/kdebase/kdebase-3.0.ebuild86
2 files changed, 109 insertions, 0 deletions
diff --git a/kde-base/kdebase/files/startkde-3.0-gentoo.diff b/kde-base/kdebase/files/startkde-3.0-gentoo.diff
new file mode 100644
index 000000000000..5a95e70e7396
--- /dev/null
+++ b/kde-base/kdebase/files/startkde-3.0-gentoo.diff
@@ -0,0 +1,23 @@
+--- startkde Sun Mar 17 13:07:07 2002
++++ startkde Mon Mar 18 10:46:34 2002
+@@ -1,8 +1,18 @@
+-#!/bin/sh
++#!/bin/sh --login
+ #
+-# DEFAULT KDE STARTUP SCRIPT ( KDE-3.0 )
++# Gentoo KDE STARTUP SCRIPT ( KDE-3.0 )
+ #
+
++# Gentoo part:
++export PATH="_KDEDIR_/bin:${PATH}"
++export KDEDIR="_KDEDIR_"
++rm -rf ~/.kde
++ln -fs ~/.kde3 ~/.kde
++[ -e "~/.kde3" ] || mkdir ~/.kde3
++
++
++# Original KDE part:
++
+ # Boot sequence:
+ #
+ # kdeinit is used to fork off processes which improves memory usage
diff --git a/kde-base/kdebase/kdebase-3.0.ebuild b/kde-base/kdebase/kdebase-3.0.ebuild
new file mode 100644
index 000000000000..e71f4d1d155d
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.0.ebuild,v 1.1 2002/04/03 18:14:06 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist
+
+DESCRIPTION="${DESCRIPTION}Base"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ lame? ( >=media-sound/lame-3.89b )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ media-sound/cdparanoia
+ opengl? ( virtual/opengl )" #this last for opengl screensavers
+# samba? ( net-fs/samba ) #use flag doesn't exist yet and we don't want such a heavy dep by deafult
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+src_unpack() {
+
+ kde_src_unpack
+ kde_sandbox_patch ${S}/konsole ${S}/konsole/konsole
+
+}
+
+src_compile() {
+
+ kde_src_compile myconf
+
+ use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+ use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+ use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+ use lame && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+ use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+ use vorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+ use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+ use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+ use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+ myconf="$myconf --with-dpms --with-cdparanoia"
+
+ kde_src_compile configure make
+
+}
+
+
+src_install() {
+
+ kde_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins kde.pamd kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/startkde-3.0-gentoo.diff
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ # old scheme - compatibility
+ exeinto /usr/X11R6/bin/wm
+ doexe kde-${PV}
+ # new scheme - for now >=xfree-4.2-r3 only
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ dodir ${KDEDIR}/share/templates/.source/emptydir
+
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e 's:SessionTypes=:SessionTypes=kde-3.0,kde-2.2.2,:' kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+}
+