summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 20:21:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-11 20:21:38 +0000
commit2d47c3681ae00cf67abf0f5278b2eab0d2f1f0e2 (patch)
treeaafb82ae35777c0cca32ae7f1673bd12071bc9ef /kde-base/kicker
parentAdd xcomposite useflag for kicker, too. (diff)
downloadgentoo-2-2d47c3681ae00cf67abf0f5278b2eab0d2f1f0e2.tar.gz
gentoo-2-2d47c3681ae00cf67abf0f5278b2eab0d2f1f0e2.tar.bz2
gentoo-2-2d47c3681ae00cf67abf0f5278b2eab0d2f1f0e2.zip
Add patch to disable xcomposite support and xcomposite useflag to enable/disable it.
(Portage version: 2529-svn)
Diffstat (limited to 'kde-base/kicker')
-rw-r--r--kde-base/kicker/ChangeLog9
-rw-r--r--kde-base/kicker/files/kicker-3.5.0-composite.patch43
-rw-r--r--kde-base/kicker/kicker-3.5.0.ebuild27
3 files changed, 72 insertions, 7 deletions
diff --git a/kde-base/kicker/ChangeLog b/kde-base/kicker/ChangeLog
index e8bf09083ed5..ad6f44c5a62b 100644
--- a/kde-base/kicker/ChangeLog
+++ b/kde-base/kicker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kicker
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/ChangeLog,v 1.35 2005/12/17 09:32:46 corsair Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/ChangeLog,v 1.36 2006/01/11 20:21:38 flameeyes Exp $
+
+ 11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kicker-3.5.0-composite.patch, kicker-3.5.0.ebuild:
+ Add patch to disable xcomposite support and xcomposite useflag to
+ enable/disable it.
17 Dec 2005; Markus Rothe <corsair@gentoo.org> kicker-3.5.0.ebuild:
Added ~ppc64
diff --git a/kde-base/kicker/files/kicker-3.5.0-composite.patch b/kde-base/kicker/files/kicker-3.5.0-composite.patch
new file mode 100644
index 000000000000..fb8543d9c6b6
--- /dev/null
+++ b/kde-base/kicker/files/kicker-3.5.0-composite.patch
@@ -0,0 +1,43 @@
+Index: kicker/taskmanager/configure.in.in
+===================================================================
+--- kicker/taskmanager/configure.in.in (revision 492938)
++++ kicker/taskmanager/configure.in.in (working copy)
+@@ -1,14 +1,16 @@
+-dnl XComposite check
+-KDE_CHECK_HEADER(X11/extensions/Xcomposite.h, [xcomposite_h=yes], [xcomposite_h=no], [#include <X11/Xlib.h>])
+-if test "$xcomposite_h" = yes; then
+- KDE_CHECK_LIB(Xcomposite, XCompositeQueryExtension, [
+- LIB_XCOMPOSITE=-lXcomposite
+- AC_DEFINE_UNQUOTED(HAVE_XCOMPOSITE, 1, [Define if you have the XComposite extension])
+- ], [], -lXext -X11 $X_EXTRA_LIBS)
+-else
+- LIB_XCOMPOSITE=
++if test "x$with_composite" != "xno"; then
++ dnl XComposite check
++ KDE_CHECK_HEADER(X11/extensions/Xcomposite.h, [xcomposite_h=yes], [xcomposite_h=no], [#include <X11/Xlib.h>])
++ if test "$xcomposite_h" = yes; then
++ KDE_CHECK_LIB(Xcomposite, XCompositeQueryExtension, [
++ LIB_XCOMPOSITE=-lXcomposite
++ AC_DEFINE_UNQUOTED(HAVE_XCOMPOSITE, 1, [Define if you have the XComposite extension])
++ ], [], -lXext -X11 $X_EXTRA_LIBS)
++ else
++ LIB_XCOMPOSITE=
++ fi
++ AC_SUBST(LIB_XCOMPOSITE)
+ fi
+-AC_SUBST(LIB_XCOMPOSITE)
+
+ dnl XFixes check
+ KDE_CHECK_HEADER(X11/extensions/Xfixes.h, [xfixes_h=yes], [xfixes_h=no], [#include <X11/Xlib.h>])
+Index: configure.in.in
+===================================================================
+--- configure.in.in (revision 492938)
++++ configure.in.in (working copy)
+@@ -275,3 +275,7 @@
+ AC_SUBST(LIBART_LIBS)
+ AC_SUBST(LIBART_CFLAGS)
+ AC_SUBST(LIBART_RPATH)
++
++AC_ARG_WITH([composite],
++ AS_HELP_STRING([--without-composite], [Disable Xcomposite support (default: check)]) )
++
diff --git a/kde-base/kicker/kicker-3.5.0.ebuild b/kde-base/kicker/kicker-3.5.0.ebuild
index 698086dba48c..a8311822421e 100644
--- a/kde-base/kicker/kicker-3.5.0.ebuild
+++ b/kde-base/kicker/kicker-3.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/kicker-3.5.0.ebuild,v 1.4 2005/12/17 09:32:46 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/kicker-3.5.0.ebuild,v 1.5 2006/01/11 20:21:38 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -9,14 +9,31 @@ inherit kde-meta eutils
DESCRIPTION="KDE panel housing varous applets"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="xcomposite"
PATCHES="$FILESDIR/applets-configure.in.in.diff"
-DEPEND="
+RDEPEND="
$(deprange $PV $MAXKDEVER kde-base/libkonq)
-$(deprange $PV $MAXKDEVER kde-base/kdebase-data)"
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
+ xcomposite? ( || ( (
+ x11-libs/libXcomposite
+ ) <=x11-base/xorg-x11-6.9 )
+ )"
+
+DEPEND="${RDEPEND}
+ xcomposite? ( || ( (
+ x11-proto/compositeproto
+ ) <=x11-base/xorg-x11-6.9 )
+ )"
KMCOPYLIB="libkonq libkonq"
KMEXTRACTONLY="libkonq
kdm/kfrontend/themer/"
KMCOMPILEONLY="kdmlib/"
+
+PATCHES="${FILESDIR}/${P}-composite.patch"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}