summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
commitb0b482a63f92c732c21a7a05f6e91ed9d13d91e6 (patch)
tree5874d7078782459c535f58fd83e3acaff5ea7f72 /kde-base/ksysguard
parentMask KDE SC 4.5 due to missing deps on ppc ppc64 and x86-fbsd. bug #336158 (diff)
downloadgentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.gz
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.tar.bz2
gentoo-2-b0b482a63f92c732c21a7a05f6e91ed9d13d91e6.zip
[kde-base] Add KDE SC 4.5.4
(Portage version: 2.2.0_alpha6_p10/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.5.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index c109d21da74c..8af13b3d2056 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.190 2010/11/13 22:33:59 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.191 2010/12/02 21:15:21 alexxy Exp $
+
+*ksysguard-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> +ksysguard-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
13 Nov 2010; Andreas K. Huettel <dilfridge@gentoo.org>
ksysguard-4.5.3.ebuild:
diff --git a/kde-base/ksysguard/ksysguard-4.5.4.ebuild b/kde-base/ksysguard/ksysguard-4.5.4.ebuild
new file mode 100644
index 000000000000..bf9671648b32
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.5.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.5.4.ebuild,v 1.1 2010/12/02 21:15:23 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="optional"
+inherit virtualx kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}