summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:33:40 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:33:40 +0000
commitfe03367a24c1aa3c0e15781cf0e826a3d6a893dd (patch)
tree6eeb55134be61141d8a295dd2a184ad76fa36b9d /kde-base/kwin
parentAdded the KDE 4.0.5 version of kweather. (diff)
downloadgentoo-2-fe03367a24c1aa3c0e15781cf0e826a3d6a893dd.tar.gz
gentoo-2-fe03367a24c1aa3c0e15781cf0e826a3d6a893dd.tar.bz2
gentoo-2-fe03367a24c1aa3c0e15781cf0e826a3d6a893dd.zip
Added the KDE 4.0.5 version of kwin.
(Portage version: 2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.0.5.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index e7e84e94138d..60d1f79e9dbf 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.127 2008/05/18 14:43:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.128 2008/06/05 22:33:40 keytoaster Exp $
+
+*kwin-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org> +kwin-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of kwin.
18 May 2008; Markus Meier <maekke@gentoo.org> kwin-3.5.9-r1.ebuild:
amd64/x86 stable, bug #221063
diff --git a/kde-base/kwin/kwin-4.0.5.ebuild b/kde-base/kwin/kwin-4.0.5.ebuild
new file mode 100644
index 000000000000..93ab75daee33
--- /dev/null
+++ b/kde-base/kwin/kwin-4.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.0.5.ebuild,v 1.1 2008/06/05 22:33:40 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="captury debug opengl xcomposite xinerama"
+
+COMMONDEPEND="
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+src_compile() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xcomposite X11_Xcomposite)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}