summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
commit3d71d92c727066f449accc1c2b7461faade152ef (patch)
tree76c3626fcc383e0dea8d20c1bf208a6e28044206 /kde-base/perlqt
parentupdated HOMEPAGE to http://www.ugetdm.com (diff)
downloadgentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.gz
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.bz2
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.zip
Version bump KDE SC 4.11.3
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.11.3.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 0973d91675f1..b47c1c443276 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.102 2013/10/10 03:56:23 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.103 2013/11/05 22:23:21 dilfridge Exp $
+
+*perlqt-4.11.3 (05 Nov 2013)
+
+ 05 Nov 2013; Andreas K. Huettel <dilfridge@gentoo.org> +perlqt-4.11.3.ebuild:
+ Version bump KDE SC 4.11.3
10 Oct 2013; Chris Reffett <creffett@gentoo.org>
files/perlqt-4.10.80-vendor.patch:
diff --git a/kde-base/perlqt/perlqt-4.11.3.ebuild b/kde-base/perlqt/perlqt-4.11.3.ebuild
new file mode 100644
index 000000000000..63ae41f3aa1e
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.11.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.11.3.ebuild,v 1.1 2013/11/05 22:23:21 dilfridge Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.10.80-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${BUILD_DIR}/blib/arch:${BUILD_DIR}/blib/lib" kde4-base_src_test
+}