summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-05 20:19:14 +0000
commit461c1af9ab4c8cfbdc911a491f7c86af2ef043dd (patch)
tree05608ce8b58bb6826c888fa542fb8c351b8e650b /kde-base/perlqt
parentUse QA_PREBUILT, fix minor QA issues, wrt bug #430026 (diff)
downloadgentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.gz
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.tar.bz2
gentoo-2-461c1af9ab4c8cfbdc911a491f7c86af2ef043dd.zip
Version bump KDE SC 4.9.5
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog9
-rw-r--r--kde-base/perlqt/perlqt-4.9.5.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 84400937cc0e..5e3177c841fb 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.56 2012/12/26 10:53:02 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.57 2013/01/05 20:19:12 creffett Exp $
+
+*perlqt-4.9.5 (05 Jan 2013)
+
+ 05 Jan 2013; <creffett@gentoo.org> +perlqt-4.9.5.ebuild:
+ Version bump KDE SC 4.9.5
26 Dec 2012; Markus Meier <maekke@gentoo.org> perlqt-4.9.4.ebuild:
add ~arm
diff --git a/kde-base/perlqt/perlqt-4.9.5.ebuild b/kde-base/perlqt/perlqt-4.9.5.ebuild
new file mode 100644
index 000000000000..184a6a594d6b
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.9.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.9.5.ebuild,v 1.1 2013/01/05 20:19:12 creffett Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.2-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${CMAKE_BUILD_DIR}/blib/arch:${CMAKE_BUILD_DIR}/blib/lib" kde4-base_src_test
+}