summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-16 18:26:42 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-16 18:26:42 +0000
commit48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3 (patch)
tree8fa78b82fe5cd62ff7393c94992cbc8552cf9c4b /kde-base/perlqt
parentversion bump (diff)
downloadgentoo-2-48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3.tar.gz
gentoo-2-48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3.tar.bz2
gentoo-2-48fd1cf98b6cf6b82f22f80b18cbdc369676d1c3.zip
Version bump KDE SC 4.13.0
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.13.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index c308fc699109..2f5b53876ddd 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.130 2014/04/01 18:24:17 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.131 2014/04/16 18:26:01 johu Exp $
+
+*perlqt-4.13.0 (16 Apr 2014)
+
+ 16 Apr 2014; Johannes Huber <johu@gentoo.org> +perlqt-4.13.0.ebuild:
+ Version bump KDE SC 4.13.0
01 Apr 2014; Johannes Huber <johu@gentoo.org>
files/perlqt-4.10.80-vendor.patch:
diff --git a/kde-base/perlqt/perlqt-4.13.0.ebuild b/kde-base/perlqt/perlqt-4.13.0.ebuild
new file mode 100644
index 000000000000..7328775c0f3c
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.13.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.13.0.ebuild,v 1.1 2014/04/16 18:26:01 johu Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ dev-perl/List-MoreUtils
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND=${RDEPEND}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.10.80-vendor.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}
+
+src_test() {
+ PERL5LIB="${BUILD_DIR}/blib/arch:${BUILD_DIR}/blib/lib" kde4-base_src_test
+}