summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:19:18 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:19:18 +0000
commit10b757f0640a75e476a166b08de7ace73dd2add9 (patch)
tree56133713cde2ca09c40a482cac332af6ad34f94e /kde-base/phonon-kde
parent[kde-base/kdesu] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-10b757f0640a75e476a166b08de7ace73dd2add9.tar.gz
gentoo-2-10b757f0640a75e476a166b08de7ace73dd2add9.tar.bz2
gentoo-2-10b757f0640a75e476a166b08de7ace73dd2add9.zip
[kde-base/phonon-kde] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog7
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.4.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index ac63af6619ed..ce28c1b58ccb 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.44 2010/01/25 17:31:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.45 2010/02/09 00:19:18 alexxy Exp $
+
+*phonon-kde-4.4.0 (09 Feb 2010)
+
+ 09 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +phonon-kde-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*phonon-kde-4.3.5 (25 Jan 2010)
diff --git a/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild b/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild
new file mode 100644
index 000000000000..1b7a7a8198da
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild,v 1.1 2010/02/09 00:19:18 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug +xine"
+
+DEPEND="
+ >=media-sound/phonon-4.3.80[xine?]
+ alsa? ( media-libs/alsa-lib )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.4-optional-alsa.patch
+)
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ # Don't build tests - they require OpenGL
+ sed -e 's/add_subdirectory(tests)//' \
+ -i phonon/CMakeLists.txt || die "Failed to disable tests"
+
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with xine)
+ )
+
+ kde4-meta_src_configure
+}