summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-06-22 12:35:41 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-06-22 12:35:41 +0000
commitb3009bcfbca245b8173d8ed512fa229cda97fe43 (patch)
tree9599fbb3a28afead7b7f542083ebdd27df9c8155 /kde-base
parentAdd support for intel cards, by emil karlson <jkarlson@cc.hut.fi>, bug #32... (diff)
downloadgentoo-2-b3009bcfbca245b8173d8ed512fa229cda97fe43.tar.gz
gentoo-2-b3009bcfbca245b8173d8ed512fa229cda97fe43.tar.bz2
gentoo-2-b3009bcfbca245b8173d8ed512fa229cda97fe43.zip
Fix automagic, bug 323135
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/smoke/ChangeLog8
-rw-r--r--kde-base/smoke/metadata.xml1
-rw-r--r--kde-base/smoke/smoke-4.4.4-r1.ebuild (renamed from kde-base/smoke/smoke-4.4.4.ebuild)19
3 files changed, 19 insertions, 9 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 46a2cc792ba5..38637e2fa303 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.105 2010/06/21 15:53:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.106 2010/06/22 12:35:41 reavertm Exp $
+
+*smoke-4.4.4-r1 (22 Jun 2010)
+
+ 22 Jun 2010; Maciej Mrozowski <reavertm@gentoo.org> -smoke-4.4.4.ebuild,
+ +smoke-4.4.4-r1.ebuild, metadata.xml:
+ Fix automagic, bug 323135
21 Jun 2010; Tomáš Chvátal <scarabeus@gentoo.org> smoke-4.4.4.ebuild:
Drop 4.3.3. Drop hppa keywords per bug #304363
diff --git a/kde-base/smoke/metadata.xml b/kde-base/smoke/metadata.xml
index c78d4590a356..f2a6217dfefc 100644
--- a/kde-base/smoke/metadata.xml
+++ b/kde-base/smoke/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>kde</herd>
<use>
+ <flag name="attica">Compile bindings for <pkg>dev-libs/libattica</pkg>.</flag>
<flag name="akonadi">Compile bindings for Akonadi.</flag>
<flag name="multimedia">Compile bindings for <pkg>x11-libs/qt-multimedia</pkg>.</flag>
<flag name="okular">Compile bindings for <pkg>kde-base/okular</pkg>.</flag>
diff --git a/kde-base/smoke/smoke-4.4.4.ebuild b/kde-base/smoke/smoke-4.4.4-r1.ebuild
index cabe16cf9b7b..38dc355427db 100644
--- a/kde-base/smoke/smoke-4.4.4.ebuild
+++ b/kde-base/smoke/smoke-4.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.4.4.ebuild,v 1.3 2010/06/21 15:53:43 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.4.4-r1.ebuild,v 1.1 2010/06/22 12:35:41 reavertm Exp $
EAPI="3"
@@ -11,11 +11,12 @@ inherit kde4-meta
DESCRIPTION="Scripting Meta Object Kompiler Engine"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="akonadi debug okular +phonon qimageblitz qscintilla qwt semantic-desktop"
+IUSE="akonadi attica debug okular +phonon qimageblitz qscintilla qwt semantic-desktop"
COMMON_DEPEND="
$(add_kdebase_dep kdelibs 'semantic-desktop?')
akonadi? ( $(add_kdebase_dep kdepimlibs) )
+ attica? ( dev-libs/libattica )
okular? ( $(add_kdebase_dep okular) )
phonon? ( >=media-sound/phonon-4.3.80[xcb] )
qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
@@ -29,16 +30,18 @@ KMEXTRA="generator/"
src_configure() {
mycmakeargs=(
- $(cmake-utils_use_enable akonadi)
- $(cmake-utils_use_enable akonadi Kdepimlibs)
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_enable attica ATTICA_SMOKE)
$(cmake-utils_use_enable multimedia QTMULTIMEDIA_SMOKE)
- $(cmake-utils_use_enable okular)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
$(cmake-utils_use_enable phonon PHONON_SMOKE)
$(cmake-utils_use_enable qimageblitz QIMAGEBLITZ_SMOKE)
- $(cmake-utils_use_enable qscintilla QSCI_SMOKE)
+ $(cmake-utils_use_with qscintilla QScintilla)
$(cmake-utils_use_enable qwt QWT_SMOKE)
- $(cmake-utils_use_enable semantic-desktop Nepomuk)
- $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
$(cmake-utils_use_enable webkit QTWEBKIT_SMOKE)
)
kde4-meta_src_configure