summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-08-02 16:44:29 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-08-02 16:44:29 +0000
commit9a6f9458e9f63f237b18d08dcd26b7070988c54f (patch)
tree1c3a22a5bab49a1dde2438da2679c72728f78c40 /lxde-base
parentStable on amd64 wrt bug #369573 (diff)
downloadgentoo-2-9a6f9458e9f63f237b18d08dcd26b7070988c54f.tar.gz
gentoo-2-9a6f9458e9f63f237b18d08dcd26b7070988c54f.tar.bz2
gentoo-2-9a6f9458e9f63f237b18d08dcd26b7070988c54f.zip
backport NULL pointer dereference patch from git
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxdm/ChangeLog6
-rw-r--r--lxde-base/lxdm/files/lxdm-0.4.1-git-fix-null-pointer-deref.patch51
-rw-r--r--lxde-base/lxdm/lxdm-0.4.1.ebuild4
3 files changed, 59 insertions, 2 deletions
diff --git a/lxde-base/lxdm/ChangeLog b/lxde-base/lxdm/ChangeLog
index edc00e2fe212..31c0952f489d 100644
--- a/lxde-base/lxdm/ChangeLog
+++ b/lxde-base/lxdm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for lxde-base/lxdm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.8 2011/08/02 16:39:24 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.9 2011/08/02 16:44:29 lxnay Exp $
+
+ 02 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> lxdm-0.4.1.ebuild,
+ +files/lxdm-0.4.1-git-fix-null-pointer-deref.patch:
+ backport NULL pointer dereference patch from git
02 Aug 2011; Fabio Erculiani <lxnay@gentoo.org>
-files/lxdm-0.4.0-pam_console-disable.patch,
diff --git a/lxde-base/lxdm/files/lxdm-0.4.1-git-fix-null-pointer-deref.patch b/lxde-base/lxdm/files/lxdm-0.4.1-git-fix-null-pointer-deref.patch
new file mode 100644
index 000000000000..7abdbd470523
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.4.1-git-fix-null-pointer-deref.patch
@@ -0,0 +1,51 @@
+From 19f82a206b2cec964cea0475395d63dedf183788 Mon Sep 17 00:00:00 2001
+From: Andrea Florio <andrea@opensuse.org>
+Date: Fri, 29 Jul 2011 23:59:32 +0200
+Subject: [PATCH] fix null pointer dereference
+
+---
+ src/config.c | 25 ++++++++++---------------
+ 1 files changed, 10 insertions(+), 15 deletions(-)
+
+diff --git a/src/config.c b/src/config.c
+index 3f92f7b..4603ab4 100644
+--- a/src/config.c
++++ b/src/config.c
+@@ -125,24 +125,19 @@ static gboolean image_file_valid(const char *filename)
+ static void update_face_image(GtkWidget *w)
+ {
+ GdkPixbuf *pixbuf;
+- char *path;
+- path=g_build_filename(user->pw_dir,".face",NULL);
+- if(access(path,R_OK))
+- {
+- g_free(path);
+- if(ui_nobody)
+- pixbuf=gdk_pixbuf_new_from_file_at_scale(ui_nobody,48,48,FALSE,NULL);
+- if(!pixbuf)
+- pixbuf=gtk_icon_theme_load_icon(gtk_icon_theme_get_default(),
++ char *path=g_build_filename(user->pw_dir,".face",NULL);
++ pixbuf=gdk_pixbuf_new_from_file_at_scale(path,48,48,FALSE,NULL);
++ g_free(path);
++ if(!pixbuf && ui_nobody)
++ pixbuf=gdk_pixbuf_new_from_file_at_scale(ui_nobody,48,48,FALSE,NULL);
++ if(!pixbuf)
++ pixbuf=gtk_icon_theme_load_icon(gtk_icon_theme_get_default(),
+ "avatar-default", 48,GTK_ICON_LOOKUP_FORCE_SIZE,NULL);
+- }
+- else
++ if(pixbuf)
+ {
+- pixbuf=gdk_pixbuf_new_from_file_at_scale(path,48,48,FALSE,NULL);
+- g_free(path);
++ gtk_image_set_from_pixbuf(GTK_IMAGE(w),pixbuf);
++ g_object_unref(pixbuf);
+ }
+- gtk_image_set_from_pixbuf(GTK_IMAGE(w),pixbuf);
+- g_object_unref(pixbuf);
+ }
+
+ static void set_face_file(const char *filename)
+--
+1.7.0.1
+
diff --git a/lxde-base/lxdm/lxdm-0.4.1.ebuild b/lxde-base/lxdm/lxdm-0.4.1.ebuild
index 11e7e467abe1..d03562c5d7d7 100644
--- a/lxde-base/lxdm/lxdm-0.4.1.ebuild
+++ b/lxde-base/lxdm/lxdm-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1.ebuild,v 1.1 2011/08/02 16:35:32 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1.ebuild,v 1.2 2011/08/02 16:44:29 lxnay Exp $
EAPI="2"
@@ -40,6 +40,8 @@ src_configure() {
src_prepare() {
# There is consolekit
epatch "${FILESDIR}/${P}-pam_console-disable.patch"
+ # Fix null pointer dereference, backported from git
+ epatch "${FILESDIR}/${P}-git-fix-null-pointer-deref.patch"
# this replaces the bootstrap/autogen script in most packages
eautoreconf