summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-12-05 01:51:31 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-12-05 01:51:31 +0000
commit50fd393a15358435ab1664c85c1f9282e4811e04 (patch)
treee0250b8a91c8222ff2e6051b3018e6a6bc276a8a /mail-client/nmh
parent*portage-2.1.6_rc3 (04 Dec 2008) (diff)
downloadgentoo-2-50fd393a15358435ab1664c85c1f9282e4811e04.tar.gz
gentoo-2-50fd393a15358435ab1664c85c1f9282e4811e04.tar.bz2
gentoo-2-50fd393a15358435ab1664c85c1f9282e4811e04.zip
(non-maintainer commit) version bump for bug #224807
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc6-wl-dirty x86_64)
Diffstat (limited to 'mail-client/nmh')
-rw-r--r--mail-client/nmh/ChangeLog11
-rw-r--r--mail-client/nmh/files/nmh-1.3-inc-login.patch25
-rw-r--r--mail-client/nmh/files/nmh-1.3-install.patch10
-rw-r--r--mail-client/nmh/files/nmh-1.3-m_getfld.patch27
-rw-r--r--mail-client/nmh/nmh-1.3.ebuild55
5 files changed, 126 insertions, 2 deletions
diff --git a/mail-client/nmh/ChangeLog b/mail-client/nmh/ChangeLog
index 32761a531fdb..892c90b69457 100644
--- a/mail-client/nmh/ChangeLog
+++ b/mail-client/nmh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/nmh
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/nmh/ChangeLog,v 1.20 2007/02/08 13:08:44 flameeyes Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nmh/ChangeLog,v 1.21 2008/12/05 01:51:31 darkside Exp $
+
+*nmh-1.3 (05 Dec 2008)
+
+ 05 Dec 2008; Jeremy Olexa <darkside@gentoo.org>
+ +files/nmh-1.3-inc-login.patch, +files/nmh-1.3-install.patch,
+ +files/nmh-1.3-m_getfld.patch, +nmh-1.3.ebuild:
+ (non-maintainer commit) version bump for bug #224807
08 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/mail-client/nmh/files/nmh-1.3-inc-login.patch b/mail-client/nmh/files/nmh-1.3-inc-login.patch
new file mode 100644
index 000000000000..f1a4f1c513ca
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-inc-login.patch
@@ -0,0 +1,25 @@
+--- nmh-1.3/uip/inc.c.~1~ 2007-11-04 03:54:34.000000000 -0800
++++ nmh-1.3/uip/inc.c 2008-11-28 10:24:03.044265843 -0800
+@@ -496,8 +496,7 @@ main (int argc, char **argv)
+ * a POP server?
+ */
+ if (inc_type == INC_POP) {
+- if (user == NULL)
+- user = getusername ();
++
+ if ( strcmp( POPSERVICE, "kpop" ) == 0 ) {
+ kpop = 1;
+ }
+@@ -506,6 +505,12 @@ main (int argc, char **argv)
+ else
+ ruserpass (host, &user, &pass);
+
++ /*
++ * Do this _after_ ruserpass, otherwise the login field will be unusable
++ */
++ if (user == NULL)
++ user = getusername ();
++
+ /*
+ * initialize POP connection
+ */
diff --git a/mail-client/nmh/files/nmh-1.3-install.patch b/mail-client/nmh/files/nmh-1.3-install.patch
new file mode 100644
index 000000000000..370455caf71a
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-install.patch
@@ -0,0 +1,10 @@
+--- nmh-1.3/uip/Makefile.in.~1~ 2005-12-24 09:17:38.000000000 -0800
++++ nmh-1.3/uip/Makefile.in 2008-11-28 10:50:48.613075060 -0800
+@@ -267,7 +267,6 @@ install-lcmds:
+ rm -f $(DESTDIR)$(bindir)/folders
+ rm -f $(DESTDIR)$(bindir)/prev
+ rm -f $(DESTDIR)$(bindir)/next
+- rm -f $(DESTDIR)$(libdir)/install-mh
+ $(LN) $(DESTDIR)$(bindir)/flist $(DESTDIR)$(bindir)/flists
+ $(LN) $(DESTDIR)$(bindir)/folder $(DESTDIR)$(bindir)/folders
+ $(LN) $(DESTDIR)$(bindir)/show $(DESTDIR)$(bindir)/prev
diff --git a/mail-client/nmh/files/nmh-1.3-m_getfld.patch b/mail-client/nmh/files/nmh-1.3-m_getfld.patch
new file mode 100644
index 000000000000..b99f480db74a
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-m_getfld.patch
@@ -0,0 +1,27 @@
+--- nmh-1.3/sbr/m_getfld.c.~1~ 2008-04-05 11:41:37.000000000 -0700
++++ nmh-1.3/sbr/m_getfld.c 2008-11-28 10:25:34.768265994 -0800
+@@ -731,18 +731,18 @@ matchc(int patln, char *pat, int strln,
+ register char *ep = pat + patln;
+ register char pc = *pat++;
+
+- for(;;) {
+- while (pc != *str++)
+- if (str > es)
+- return 0;
++ for(;str <= es; str++) {
++ if (pc != *str)
++ continue;
+ if (str > es+1)
+ return 0;
+- sp = str; pp = pat;
++ sp = str+1; pp = pat;
+ while (pp < ep && *sp++ == *pp)
+ pp++;
+ if (pp >= ep)
+- return ((unsigned char *)--str);
++ return ((unsigned char *)str);
+ }
++ return 0;
+ }
+
+
diff --git a/mail-client/nmh/nmh-1.3.ebuild b/mail-client/nmh/nmh-1.3.ebuild
new file mode 100644
index 000000000000..e113d7454d20
--- /dev/null
+++ b/mail-client/nmh/nmh-1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nmh/nmh-1.3.ebuild,v 1.1 2008/12/05 01:51:31 darkside Exp $
+
+inherit eutils
+DESCRIPTION="New MH mail reader"
+SRC_URI="http://savannah.nongnu.org/download/nmh/${P}.tar.gz"
+HOMEPAGE="http://www.nongnu.org/nmh/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ || ( sys-libs/gdbm =sys-libs/db-1.85* )
+ >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Patches from bug #22173.
+ epatch "${FILESDIR}"/${P}-inc-login.patch
+ epatch "${FILESDIR}"/${P}-install.patch
+ # bug #57886
+ epatch "${FILESDIR}"/${P}-m_getfld.patch
+}
+
+src_compile() {
+ [ -z "${EDITOR}" ] && export EDITOR="prompter"
+ [ -z "${PAGER}" ] && export PAGER="/usr/bin/more"
+
+ # Redefining libdir to be bindir so the support binaries get installed
+ # correctly. Since no libraries are installed with nmh, this does not
+ # pose a problem at this time.
+ econf \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-editor=${EDITOR} \
+ --with-pager=${PAGER} \
+ --enable-nmh-pop \
+ --sysconfdir=/etc/nmh \
+ --libdir=/usr/bin \
+ || die
+ emake -j1 || die
+}
+
+src_install() {
+ emake -j1 prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man \
+ libdir="${D}"/usr/bin \
+ etcdir="${D}"/etc/nmh install || die
+ dodoc ChangeLog DATE MACHINES README
+}