summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2011-04-04 02:33:57 +0000
committerJory Pratt <anarchy@gentoo.org>2011-04-04 02:33:57 +0000
commitcfc03952670f1af0261f276acd47ddb510d77a5e (patch)
tree03992ea5f6f7b856734946e0df9af664668a6be8 /mail-client
parentMask >=mail-client/thunderbird-3.3_alpha3 for move to tree (diff)
downloadgentoo-2-cfc03952670f1af0261f276acd47ddb510d77a5e.tar.gz
gentoo-2-cfc03952670f1af0261f276acd47ddb510d77a5e.tar.bz2
gentoo-2-cfc03952670f1af0261f276acd47ddb510d77a5e.zip
Initial import of tb-3.3_alpha3 to tree for testing/porting
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/ChangeLog12
-rw-r--r--mail-client/thunderbird/files/1001-xulrunner_fix_jemalloc_vs_aslr.patch55
-rw-r--r--mail-client/thunderbird/files/2000-thunderbird_gentoo_install_dirs.patch22
-rw-r--r--mail-client/thunderbird/files/enigmail-1.1.2-20110124-locale-fixup.diff8
-rw-r--r--mail-client/thunderbird/files/thunderbird-3.3-gconf-config-update.patch50
-rw-r--r--mail-client/thunderbird/metadata.xml4
-rw-r--r--mail-client/thunderbird/thunderbird-3.3_alpha3-r1.ebuild264
7 files changed, 414 insertions, 1 deletions
diff --git a/mail-client/thunderbird/ChangeLog b/mail-client/thunderbird/ChangeLog
index 30f1edc9f0df..b1c5acd92c1d 100644
--- a/mail-client/thunderbird/ChangeLog
+++ b/mail-client/thunderbird/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for mail-client/thunderbird
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.70 2011/03/18 17:20:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/ChangeLog,v 1.71 2011/04/04 02:33:57 anarchy Exp $
+
+*thunderbird-3.3_alpha3-r1 (04 Apr 2011)
+
+ 04 Apr 2011; Jory A. Pratt <anarchy@gentoo.org>
+ +files/1001-xulrunner_fix_jemalloc_vs_aslr.patch,
+ +files/enigmail-1.1.2-20110124-locale-fixup.diff,
+ +thunderbird-3.3_alpha3-r1.ebuild,
+ +files/thunderbird-3.3-gconf-config-update.patch,
+ +files/2000-thunderbird_gentoo_install_dirs.patch:
+ Add tb-3.3a3 to tree for testing/porting
18 Mar 2011; Raúl Porcel <armin76@gentoo.org> thunderbird-3.1.9.ebuild:
alpha/ia64/sparc stable wrt #357057
diff --git a/mail-client/thunderbird/files/1001-xulrunner_fix_jemalloc_vs_aslr.patch b/mail-client/thunderbird/files/1001-xulrunner_fix_jemalloc_vs_aslr.patch
new file mode 100644
index 000000000000..7511ac7c3c2a
--- /dev/null
+++ b/mail-client/thunderbird/files/1001-xulrunner_fix_jemalloc_vs_aslr.patch
@@ -0,0 +1,55 @@
+diff -urpx 'cscope*' -x '.*.swp' mozilla-1.9.1-orig/memory/jemalloc/jemalloc.c mozilla-1.9.1/memory/jemalloc/jemalloc.c
+--- mozilla-orig/memory/jemalloc/jemalloc.c 2009-07-30 17:30:25.000000000 +0200
++++ mozilla/memory/jemalloc/jemalloc.c 2009-08-10 14:28:59.000000000 +0200
+@@ -392,7 +392,7 @@ __FBSDID("$FreeBSD: head/lib/libc/stdlib
+ static const bool __isthreaded = true;
+ #endif
+
+-#if defined(MOZ_MEMORY_SOLARIS) && defined(MAP_ALIGN) && !defined(JEMALLOC_NEVER_USES_MAP_ALIGN)
++#if defined(MOZ_MEMORY_SOLARIS) || defined(MOZ_MEMORY_LINUX) || defined(MOZ_MEMORY_BSD)
+ #define JEMALLOC_USES_MAP_ALIGN /* Required on Solaris 10. Might improve performance elsewhere. */
+ #endif
+
+@@ -2305,20 +2305,31 @@ pages_map_align(size_t size, int pfd, si
+ * We don't use MAP_FIXED here, because it can cause the *replacement*
+ * of existing mappings, and we only want to create new mappings.
+ */
+-#ifdef MALLOC_PAGEFILE
+- if (pfd != -1) {
+- ret = mmap((void *)alignment, size, PROT_READ | PROT_WRITE, MAP_PRIVATE |
+- MAP_NOSYNC | MAP_ALIGN, pfd, 0);
+- } else
+-#endif
+- {
+- ret = mmap((void *)alignment, size, PROT_READ | PROT_WRITE, MAP_PRIVATE |
+- MAP_NOSYNC | MAP_ALIGN | MAP_ANON, -1, 0);
+- }
++ ret = mmap(NULL, size + alignment, PROT_READ | PROT_WRITE, MAP_PRIVATE |
++ MAP_NOSYNC| MAP_ANON, -1, 0);
+ assert(ret != NULL);
+
+ if (ret == MAP_FAILED)
+ ret = NULL;
++ else {
++ uintptr_t aligned_ret;
++ size_t extra_size;
++
++ aligned_ret = (uintptr_t)ret + alignment - 1;
++ aligned_ret &= ~(alignment - 1);
++ extra_size = aligned_ret - (uintptr_t)ret;
++ munmap(ret, extra_size);
++ munmap(ret + extra_size + size, alignment - extra_size);
++ ret = (void *)aligned_ret;
++#ifdef MALLOC_PAGEFILE
++ if (pfd != -1) {
++ ret = mmap(ret, size, PROT_READ | PROT_WRITE, MAP_PRIVATE |
++ MAP_NOSYNC | MAP_FIXED, pfd, 0);
++ }
++ if (ret == MAP_FAILED)
++ ret = NULL;
++#endif
++ }
+ return (ret);
+ }
+ #endif
+
diff --git a/mail-client/thunderbird/files/2000-thunderbird_gentoo_install_dirs.patch b/mail-client/thunderbird/files/2000-thunderbird_gentoo_install_dirs.patch
new file mode 100644
index 000000000000..b3af6f35fa88
--- /dev/null
+++ b/mail-client/thunderbird/files/2000-thunderbird_gentoo_install_dirs.patch
@@ -0,0 +1,22 @@
+diff -ur work.orig/config/autoconf.mk.in work/config/autoconf.mk.in
+--- work.orig/config/autoconf.mk.in 2009-04-28 16:55:24.000000000 +0000
++++ work/config/autoconf.mk.in 2009-04-28 16:57:12.000000000 +0000
+@@ -60,14 +60,14 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+-includedir = @includedir@/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++includedir = @includedir@/thunderbird
+ libdir = @libdir@
+ datadir = @datadir@
+ mandir = @mandir@
+-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++idldir = $(datadir)/idl/thunderbird
+
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
++installdir = $(libdir)/thunderbird
++sdkdir = $(libdir)/thunderbird-devel
+
+ MOZDEPTH = $(DEPTH)/mozilla
+ DIST = $(MOZDEPTH)/dist
diff --git a/mail-client/thunderbird/files/enigmail-1.1.2-20110124-locale-fixup.diff b/mail-client/thunderbird/files/enigmail-1.1.2-20110124-locale-fixup.diff
new file mode 100644
index 000000000000..e5e52f1979c8
--- /dev/null
+++ b/mail-client/thunderbird/files/enigmail-1.1.2-20110124-locale-fixup.diff
@@ -0,0 +1,8 @@
+--- enigmail/lang/current-languages.txt
++++ enigmail/lang/current-languages.txt
+@@ -1,5 +1,4 @@
+ ar
+-bg-BG
+ ca
+ cs-CZ
+ de-AT
diff --git a/mail-client/thunderbird/files/thunderbird-3.3-gconf-config-update.patch b/mail-client/thunderbird/files/thunderbird-3.3-gconf-config-update.patch
new file mode 100644
index 000000000000..8bb723771f4f
--- /dev/null
+++ b/mail-client/thunderbird/files/thunderbird-3.3-gconf-config-update.patch
@@ -0,0 +1,50 @@
+diff --git a/configure.in b/configure.in
+--- a/configure.in
++++ b/configure.in
+@@ -5031,16 +5031,21 @@ then
+ fi
+ MOZ_ENABLE_GIO=
+ ])
+ fi
+
+ dnl ========================================================
+ dnl = GConf support module
+ dnl ========================================================
++ MOZ_ARG_DISABLE_BOOL(gconf,
++ [ --disable-gconf Disable Gconf support ],
++ MOZ_ENABLE_GCONF=,
++ MOZ_ENABLE_GCONF=force)
++
+ if test "$MOZ_ENABLE_GCONF"
+ then
+ PKG_CHECK_MODULES(MOZ_GCONF, gconf-2.0 >= $GCONF_VERSION gobject-2.0 ,[
+ MOZ_ENABLE_GCONF=1
+ ],[
+ MOZ_ENABLE_GCONF=
+ ])
+ fi
+diff --git a/mozilla/configure.in b/mozilla/configure.in
+--- a/mozilla/configure.in
++++ b/mozilla/configure.in
+@@ -5701,16 +5701,21 @@ then
+
+ AC_SUBST(MOZ_ENABLE_GIO)
+ AC_SUBST(MOZ_GIO_CFLAGS)
+ AC_SUBST(MOZ_GIO_LIBS)
+
+ dnl ========================================================
+ dnl = GConf support module
+ dnl ========================================================
++ MOZ_ARG_DISABLE_BOOL(gconf,
++ [ --disable-gconf Disable Gconf support ],
++ MOZ_ENABLE_GCONF=,
++ MOZ_ENABLE_GCONF=force)
++
+ if test "$MOZ_ENABLE_GCONF"
+ then
+ PKG_CHECK_MODULES(MOZ_GCONF, gconf-2.0 >= $GCONF_VERSION gobject-2.0 ,[
+ MOZ_GCONF_LIBS=`echo $MOZ_GCONF_LIBS | sed 's/-llinc\>//'`
+ MOZ_ENABLE_GCONF=1
+ ],[
+ if test "$MOZ_ENABLE_GCONF" = "force"
+ then
diff --git a/mail-client/thunderbird/metadata.xml b/mail-client/thunderbird/metadata.xml
index 0ce54c745783..4322881dbfd0 100644
--- a/mail-client/thunderbird/metadata.xml
+++ b/mail-client/thunderbird/metadata.xml
@@ -8,5 +8,9 @@
<flag name='custom-optimization'>Enable user CFLAGS</flag>
<flag name='system-sqlite'>Use the system-wide <pkg>dev-db/sqlite</pkg>
installation with secure-delete enabled</flag>
+ <flag name="ipc">Use inter-process communication between tabs and plugins.
+ Allows for greater stability in case of plugin crashes</flag>
+ <flag name="crashreporter">Enable crash reporter for bugs</flag>
+ <flag name="gconf">Enable gnome2 gconf support</flag>
</use>
</pkgmetadata>
diff --git a/mail-client/thunderbird/thunderbird-3.3_alpha3-r1.ebuild b/mail-client/thunderbird/thunderbird-3.3_alpha3-r1.ebuild
new file mode 100644
index 000000000000..c21537d5dd08
--- /dev/null
+++ b/mail-client/thunderbird/thunderbird-3.3_alpha3-r1.ebuild
@@ -0,0 +1,264 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/thunderbird/thunderbird-3.3_alpha3-r1.ebuild,v 1.1 2011/04/04 02:33:57 anarchy Exp $
+
+EAPI="3"
+WANT_AUTOCONF="2.1"
+
+inherit flag-o-matic toolchain-funcs eutils mozconfig-3 makeedit multilib mozextension autotools pax-utils python
+
+# This list can be updated using get_langs.sh from the mozilla overlay
+#LANGS="af ar be bg bn-BD ca cs da de el en en-GB en-US es-AR es-ES et eu fi fr \
+#fy-NL ga-IE he hu id is it ja ko lt nb-NO nl nn-NO pa-IN pl pt-BR pt-PT ro ru si \
+#sk sl sq sv-SE tr uk zh-CN zh-TW"
+#NOSHORTLANGS="en-GB es-AR pt-BR zh-TW"
+
+MY_PV="${PV/_alpha/a}"
+MY_P="${P/_alpha/a}"
+EMVER="1.2a1"
+
+DESCRIPTION="Thunderbird Mail Client"
+HOMEPAGE="http://www.mozilla.com/en-US/thunderbird/"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
+IUSE="bindist gconf +crashreporter +crypt +ipc +lightning mozdom"
+#PATCH="${PN}-3.1-patches-1.2"
+
+REL_URI="http://releases.mozilla.org/pub/mozilla.org/${PN}/releases"
+SRC_URI="${REL_URI}/${MY_PV}/source/${MY_P}.source.tar.bz2
+ crypt? ( http://dev.gentoo.org/~anarchy/mozilla/firefox/enigmail-${EMVER}-20110316.tar.bz2 )"
+# http://dev.gentoo.org/~anarchy/mozilla/patchsets/${PATCH}.tar.bz2"
+
+#for X in ${LANGS} ; do
+# if [ "${X}" != "en" ] && [ "${X}" != "en-US" ]; then
+# SRC_URI="${SRC_URI}
+# linguas_${X/-/_}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P}-${X}.xpi )"
+# fi
+# IUSE="${IUSE} linguas_${X/-/_}"
+# # english is handled internally
+# if [ "${#X}" == 5 ] && ! has ${X} ${NOSHORTLANGS}; then
+# if [ "${X}" != "en-US" ]; then
+# SRC_URI="${SRC_URI}
+# linguas_${X%%-*}? ( ${REL_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P}-${X}.xpi )"
+# fi
+# IUSE="${IUSE} linguas_${X%%-*}"
+# fi
+#done
+
+RDEPEND=">=sys-devel/binutils-2.16.1
+ >=dev-libs/nss-3.12.9
+ >=dev-libs/nspr-4.8.7
+ gconf? ( >=gnome-base/gconf-1.2.1:2 )
+ !x11-plugins/lightning
+ !x11-plugins/enigmail
+ crypt? ( || (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk]
+ app-crypt/pinentry[qt4]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ ) )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/comm-central
+
+#linguas() {
+# local LANG SLANG
+# for LANG in ${LINGUAS}; do
+# if has ${LANG} en en_US; then
+# has en ${linguas} || linguas="${linguas:+"${linguas} "}en"
+# continue
+# elif has ${LANG} ${LANGS//-/_}; then
+# has ${LANG//_/-} ${linguas} || linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+# continue
+# elif [[ " ${LANGS} " == *" ${LANG}-"* ]]; then
+# for X in ${LANGS}; do
+# if [[ "${X}" == "${LANG}-"* ]] && \
+# [[ " ${NOSHORTLANGS} " != *" ${X} "* ]]; then
+# has ${X} ${linguas} || linguas="${linguas:+"${linguas} "}${X}"
+# continue 2
+# fi
+# done
+# fi
+# ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+# done
+#}
+
+pkg_setup() {
+ moz_pkgsetup
+
+ if ! use bindist; then
+ elog "You are enabling official branding. You may not redistribute this build"
+ elog "to any users on your network or the internet. Doing so puts yourself into"
+ elog "a legal problem with Mozilla Foundation"
+ elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+# linguas
+# for X in ${linguas}; do
+# # FIXME: Add support for unpacking xpis to portage
+# [[ ${X} != "en" ]] && xpi_unpack "${P}-${X}.xpi"
+# done
+# if [[ ${linguas} != "" && ${linguas} != "en" ]]; then
+# einfo "Selected language packs (first will be default): ${linguas}"
+# fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/1001-xulrunner_fix_jemalloc_vs_aslr.patch"
+ epatch "${FILESDIR}/2000-thunderbird_gentoo_install_dirs.patch"
+ epatch "${FILESDIR}/thunderbird-3.3-gconf-config-update.patch"
+
+ if use crypt ; then
+ mv "${WORKDIR}"/enigmail "${S}"/mailnews/extensions/enigmail
+ cd "${S}"/mailnews/extensions/enigmail || die
+ epatch "${FILESDIR}"/enigmail-1.1.2-20110124-locale-fixup.diff
+ cd enigmail
+ ./makemake -r 2> /dev/null
+ sed -i -e 's:@srcdir@:${S}/mailnews/extensions/enigmail:' Makefile.in
+ cd "${S}"
+ fi
+
+ # Allow user to apply any additional patches without modifing ebuild
+ epatch_user
+
+ eautoreconf
+
+ cd mozilla
+ eautoreconf
+ cd js/src
+ eautoreconf
+}
+
+src_configure() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+ MEXTENSIONS="default"
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+ mozconfig_config
+
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ if use crypt ; then
+ # omni.jar breaks enigmail
+ mozconfig_annotate '' --enable-chrome-format=jar
+ fi
+ mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
+ mozconfig_annotate '' --with-default-mozilla-five-home="${EPREFIX}${MOZILLA_FIVE_HOME}"
+ mozconfig_annotate '' --with-user-appdir=.thunderbird
+
+ # Use enable features
+ mozconfig_use_enable lightning calendar
+ mozconfig_use_enable gconf
+
+ # Bug #72667
+ if use mozdom; then
+ MEXTENSIONS="${MEXTENSIONS},inspector"
+ fi
+
+ # Finalize and report settings
+ mozconfig_final
+
+ ####################################
+ #
+ # Configure and build
+ #
+ ####################################
+
+ # Disable no-print-directory
+ MAKEOPTS=${MAKEOPTS/--no-print-directory/}
+
+ if [[ $(gcc-major-version) -lt 4 ]]; then
+ append-cxxflags -fno-stack-protector
+ fi
+
+ CPPFLAGS="${CPPFLAGS}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
+ econf || die
+}
+
+src_compile() {
+ emake || die
+
+ # Only build enigmail extension if crypt enabled.
+ if use crypt ; then
+ emake -C "${S}"/mailnews/extensions/enigmail || die "make enigmail failed"
+ emake -C "${S}"/mailnews/extensions/enigmail xpi || die "make enigmail xpi failed"
+ fi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use crypt ; then
+ cd "${T}" || die
+ unzip "${S}"/mozilla/dist/bin/enigmail*.xpi install.rdf || die
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid} || die
+ cd "${D}"${MOZILLA_FIVE_HOME}/extensions/${emid} || die
+ unzip "${S}"/mozilla/dist/bin/enigmail*.xpi || die
+ fi
+
+ if use lightning ; then
+ declare emid emd1 emid2
+
+ emid="{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}"
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip "${S}"/mozilla/dist/xpi-stage/gdata-provider.xpi
+
+ emid1="calendar-timezones@mozilla.org"
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid1}
+ cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid1}
+ unzip "${S}"/mozilla/dist/xpi-stage/calendar-timezones.xpi
+
+ emid2="{e2fda1a4-762b-4020-b5ad-a41df1933103}"
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid2}
+ cd "${ED}"${MOZILLA_FIVE_HOME}/extensions/${emid2}
+ unzip "${S}"/mozilla/dist/xpi-stage/lightning.xpi
+ fi
+
+# linguas
+# for X in ${linguas}; do
+# [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P}-${X}"
+# done
+
+ if ! use bindist; then
+ newicon "${S}"/other-licenses/branding/thunderbird/content/icon48.png thunderbird-icon.png
+ domenu "${FILESDIR}"/icon/${PN}.desktop
+ else
+ newicon "${S}"/mail/branding/unofficial/content/icon48.png thunderbird-icon-unbranded.png
+ newmenu "${FILESDIR}"/icon/${PN}-unbranded.desktop \
+ ${PN}.desktop
+
+ sed -i -e "s:Mozilla\ Thunderbird:Lanikai:g" \
+ "${D}"/usr/share/applications/${PN}.desktop
+
+ fi
+
+ pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/thunderbird-bin
+
+ # Enable very specific settings for thunderbird-3
+ cp "${FILESDIR}"/thunderbird-gentoo-default-prefs-1.js \
+ "${ED}/${MOZILLA_FIVE_HOME}/defaults/pref/all-gentoo.js" || \
+ die "failed to cp thunderbird-gentoo-default-prefs.js"
+}