summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-12-06 11:27:29 +0000
committerEray Aslan <eras@gentoo.org>2012-12-06 11:27:29 +0000
commit3406c6cf2ea8656231a2ddd394eb96d36bdf1a46 (patch)
tree85587aa6cf36232832a80eee0c8c07a8db5dcf14 /mail-mta
parentwww-servers/tomcat: removed obsolete file (diff)
downloadgentoo-2-3406c6cf2ea8656231a2ddd394eb96d36bdf1a46.tar.gz
gentoo-2-3406c6cf2ea8656231a2ddd394eb96d36bdf1a46.tar.bz2
gentoo-2-3406c6cf2ea8656231a2ddd394eb96d36bdf1a46.zip
Remove old
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/nullmailer/ChangeLog7
-rw-r--r--mail-mta/nullmailer/files/init.d-nullmailer56
-rw-r--r--mail-mta/nullmailer/files/nullmailer-1.10-fix-sendmail.patch100
-rw-r--r--mail-mta/nullmailer/nullmailer-1.05.ebuild121
-rw-r--r--mail-mta/nullmailer/nullmailer-1.06.ebuild121
-rw-r--r--mail-mta/nullmailer/nullmailer-1.10-r1.ebuild121
-rw-r--r--mail-mta/nullmailer/nullmailer-1.10.ebuild120
7 files changed, 6 insertions, 640 deletions
diff --git a/mail-mta/nullmailer/ChangeLog b/mail-mta/nullmailer/ChangeLog
index cb1509e8059c..a0cd0ceaadfc 100644
--- a/mail-mta/nullmailer/ChangeLog
+++ b/mail-mta/nullmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-mta/nullmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.58 2012/11/06 11:18:38 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.59 2012/12/06 11:27:28 eras Exp $
+
+ 06 Dec 2012; Eray Aslan <eras@gentoo.org> -files/init.d-nullmailer,
+ -files/nullmailer-1.10-fix-sendmail.patch, -nullmailer-1.05.ebuild,
+ -nullmailer-1.06.ebuild, -nullmailer-1.10-r1.ebuild, -nullmailer-1.10.ebuild:
+ Remove old
06 Nov 2012; Eray Aslan <eras@gentoo.org> nullmailer-1.05.ebuild,
nullmailer-1.06.ebuild, nullmailer-1.10-r1.ebuild, nullmailer-1.10.ebuild,
diff --git a/mail-mta/nullmailer/files/init.d-nullmailer b/mail-mta/nullmailer/files/init.d-nullmailer
deleted file mode 100644
index 070c5737e13d..000000000000
--- a/mail-mta/nullmailer/files/init.d-nullmailer
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/files/init.d-nullmailer,v 1.1 2006/01/30 03:50:34 robbat2 Exp $
-
-DAEMON="/usr/sbin/nullmailer-send"
-ARGS="--daemon"
-USER=nullmail
-GROUP=nullmail
-
-depend() {
- need net logger
-}
-
-checkconfig() {
- local error=0
- local f=/etc/nullmailer/me
- if [ ! -s ${f} ]; then
- eerror "${f} does not exist"
- error=1
- fi
- f=/etc/nullmailer/defaultdomain
- if [ ! -s ${f} ]; then
- eerror "${f} does not exist"
- error=1
- fi
- if [ ${error} -eq 1 ]; then
- einfo "You need to run 'emerge --config nullmailer'!"
- fi
- if [ -e /service/nullmailer ]; then
- eerror "Nullmailer is already running under svscan!"
- error=2
- fi
- if [ ${error} -ne 0 ]; then
- return 1
- else
- return 0
- fi
-}
-
-start() {
- checkconfig
- ebegin "Starting nullmailer"
- cd /var/nullmailer
- start-stop-daemon --start --quiet --chuid ${USER}:${GROUP} \
- --exec ${DAEMON} -- ${ARGS}
- eend $?
-}
-
-stop() {
- checkconfig # to avoid init.d stopping svscan instance
- ebegin "Stopping nullmailer"
- cd /var/nullmailer
- start-stop-daemon --stop --user ${USER} --exec ${DAEMON}
- eend $?
-}
diff --git a/mail-mta/nullmailer/files/nullmailer-1.10-fix-sendmail.patch b/mail-mta/nullmailer/files/nullmailer-1.10-fix-sendmail.patch
deleted file mode 100644
index 98669a64c777..000000000000
--- a/mail-mta/nullmailer/files/nullmailer-1.10-fix-sendmail.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-diff --git a/lib/cli++/main.cc b/lib/cli++/main.cc
-index f0eb014..406e990 100644
---- a/lib/cli++/main.cc
-+++ b/lib/cli++/main.cc
-@@ -36,6 +36,7 @@ static cli_option help_option = { 'h', "help", cli_option::flag,
-
- static cli_option** options;
- static unsigned optionc;
-+static const char* short_options;
-
- static void build_options()
- {
-@@ -47,6 +48,13 @@ static void build_options()
- for(unsigned i = 0; i < optionc-1; i++)
- options[i] = &cli_options[i];
- options[optionc-1] = &help_option;
-+
-+ char* so;
-+ short_options = so = new char[optionc+1];
-+ for (unsigned i = 0; i < optionc; i++)
-+ if (options[i]->ch != 0)
-+ *so++ = options[i]->ch;
-+ *so = 0;
- }
-
- static inline int max(int a, int b)
-@@ -275,14 +283,6 @@ static int parse_long(int, char* argv[])
- ++arg;
- for(unsigned j = 0; j < optionc; j++) {
- cli_option* o = options[j];
-- if (cli_only_long && o->ch) {
-- if (arg[0] == o->ch) {
-- if (arg[1] == '\0')
-- return o->parse_long_noeq(argv[1], true);
-- else if (arg[1] == '=')
-- return o->parse_long_eq(arg+2, true);
-- }
-- }
- if(o->name) {
- size_t len = strlen(o->name);
- if(!memcmp(arg, o->name, len)) {
-@@ -297,6 +297,13 @@ static int parse_long(int, char* argv[])
- return -1;
- }
-
-+static int parse_either(int argc, char* argv[])
-+{
-+ return (strchr(short_options, argv[0][1]) != 0)
-+ ? parse_short(argc, argv)
-+ : parse_long(argc, argv);
-+}
-+
- static int parse_args(int argc, char* argv[])
- {
- build_options();
-@@ -312,9 +319,9 @@ static int parse_args(int argc, char* argv[])
- i++;
- break;
- }
-- int j = (!cli_only_long && arg[1] != '-')
-- ? parse_short(argc-i, argv+i)
-- : parse_long(argc-i, argv+i);
-+ int j = (arg[1] == '-') ? parse_long(argc-i, argv+i)
-+ : cli_only_long ? parse_either(argc-i, argv+i)
-+ : parse_short(argc-i, argv+i);
- if(j < 0)
- usage(1);
- else
-diff --git a/src/sendmail.cc b/src/sendmail.cc
-index f245226..2e5615b 100644
---- a/src/sendmail.cc
-+++ b/src/sendmail.cc
-@@ -66,26 +66,13 @@ cli_option cli_options[] = {
- { 'N', 0, cli_option::string, 0, &o_dummys, "Ignored", 0 },
- { 'n', 0, cli_option::flag, 0, &o_dummyi, "Ignored", 0 },
- { 'O', 0, cli_option::string, 0, &o_dummys, "Ignored", 0 },
-- { 0, "odb", cli_option::flag, 0, &o_dummyi,
-- "Deliver in background (always true)", 0 },
-- { 0, "odf", cli_option::flag, 0, &o_dummyi,
-- "Deliver in foreground (ignored)", 0 },
-- { 0, "oem", cli_option::flag, 0, &o_dummyi,
-- "Ignored", 0 },
-+ { 'o', 0, cli_option::string, 0, &o_dummys, "Set sendmail flag, ignored", 0 },
- { 0, "em", cli_option::flag, 0, &o_dummyi,
- "Ignored", 0 },
-- { 0, "oep", cli_option::flag, 0, &o_dummyi,
-- "Ignored", 0 },
- { 0, "ep", cli_option::flag, 0, &o_dummyi,
- "Ignored", 0 },
-- { 0, "oeq", cli_option::flag, 0, &o_dummyi,
-- "Ignored", 0 },
- { 0, "eq", cli_option::flag, 0, &o_dummyi,
- "Ignored", 0 },
-- { 0, "oi", cli_option::flag, 0, &o_dummyi,
-- "Ignored", 0 },
-- { 0, "om", cli_option::flag, 0, &o_dummyi,
-- "Ignored", 0 },
- { 'p', 0, cli_option::string, 0, &o_dummys, "Ignored", 0 },
- { 'q', 0, cli_option::string, 0, &o_dummys, "Ignored", 0 },
- { 'R', 0, cli_option::string, 0, &o_dummys, "Ignored", 0 },
diff --git a/mail-mta/nullmailer/nullmailer-1.05.ebuild b/mail-mta/nullmailer/nullmailer-1.05.ebuild
deleted file mode 100644
index 332c617d707d..000000000000
--- a/mail-mta/nullmailer/nullmailer-1.05.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.05.ebuild,v 1.7 2012/11/06 11:18:38 eras Exp $
-
-inherit eutils flag-o-matic autotools user
-
-MY_P="${P/_rc/RC}"
-S=${WORKDIR}/${MY_P}
-DEBIAN_PV=1.04
-DEBIAN_PR="1"
-DEBIAN_P="${PN}-${DEBIAN_PV}"
-DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
-DEBIAN_SRC="${DEBIAN_PF}.diff.gz"
-DESCRIPTION="Simple relay-only local mail transport agent"
-SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
- mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-
-IUSE=""
-
-DEPEND="sys-apps/groff"
-RDEPEND="virtual/shadow
- virtual/logger
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/ssmtp"
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${DISTDIR}"/${DEBIAN_SRC}
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${S}"/debian/patches/02_ipv6.diff || die "IPV6 patch failed"
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${S}"/debian/patches/03_syslog.diff || die "daemon/syslog patch failed"
- # this fixes the debian daemon/syslog to actually compile
- sed -i.orig \
- -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
- "${S}"/src/Makefile.am || die "Sed failed"
-
- cd "${S}"
- eautoreconf
-}
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
-src_compile() {
- # Note that we pass a different directory below due to bugs in the makefile!
- econf --localstatedir=/var || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- einstall localstatedir="${D}"/var/nullmailer || die "einstall failed"
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README YEAR2000 TODO
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-1.04 remotes
- # daemontools stuff
- dodir /var/nullmailer/service{,/log}
- insinto /var/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/nullmailer/service/run
- insinto /var/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/nullmailer/service/log/run
- # usablity
- dodir /usr/lib
- dosym /usr/sbin/sendmail usr/lib/sendmail
- # permissions stuff
- keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer nullmailer
-}
-
-pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
-
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- echo
- elog "To start nullmailer at boot you may use either the nullmailer init.d"
- elog "script, or emerge sys-process/supervise-scripts, enable the"
- elog "svscan init.d script and create the following link:"
- elog "ln -fs /var/nullmailer/service /service/nullmailer"
- echo
- ewarn "${PF} introduces a new configuration syntax for SMTP AUTH."
- ewarn "Please adjust your configuration accordingly."
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}
diff --git a/mail-mta/nullmailer/nullmailer-1.06.ebuild b/mail-mta/nullmailer/nullmailer-1.06.ebuild
deleted file mode 100644
index b1b47ee62157..000000000000
--- a/mail-mta/nullmailer/nullmailer-1.06.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.06.ebuild,v 1.4 2012/11/06 11:18:38 eras Exp $
-
-inherit eutils flag-o-matic autotools user
-
-MY_P="${P/_rc/RC}"
-S=${WORKDIR}/${MY_P}
-DEBIAN_PV=1.04
-DEBIAN_PR="1"
-DEBIAN_P="${PN}-${DEBIAN_PV}"
-DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
-DEBIAN_SRC="${DEBIAN_PF}.diff.gz"
-DESCRIPTION="Simple relay-only local mail transport agent"
-SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
- mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE=""
-
-DEPEND="sys-apps/groff"
-RDEPEND="virtual/shadow
- virtual/logger
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/ssmtp"
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${DISTDIR}"/${DEBIAN_SRC}
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${S}"/debian/patches/02_ipv6.diff || die "IPV6 patch failed"
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${S}"/debian/patches/03_syslog.diff || die "daemon/syslog patch failed"
- # this fixes the debian daemon/syslog to actually compile
- sed -i.orig \
- -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
- "${S}"/src/Makefile.am || die "Sed failed"
-
- cd "${S}"
- eautoreconf
-}
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
-src_compile() {
- # Note that we pass a different directory below due to bugs in the makefile!
- econf --localstatedir=/var || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
- einstall localstatedir="${D}"/var/nullmailer || die "einstall failed"
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-1.04 remotes
- # daemontools stuff
- dodir /var/nullmailer/service{,/log}
- insinto /var/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/nullmailer/service/run
- insinto /var/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/nullmailer/service/log/run
- # usablity
- dodir /usr/lib
- dosym /usr/sbin/sendmail usr/lib/sendmail
- # permissions stuff
- keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer nullmailer
-}
-
-pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
-
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- echo
- elog "To start nullmailer at boot you may use either the nullmailer init.d"
- elog "script, or emerge sys-process/supervise-scripts, enable the"
- elog "svscan init.d script and create the following link:"
- elog "ln -fs /var/nullmailer/service /service/nullmailer"
- echo
- ewarn "${PF} introduces a new configuration syntax for SMTP AUTH."
- ewarn "Please adjust your configuration accordingly."
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}
diff --git a/mail-mta/nullmailer/nullmailer-1.10-r1.ebuild b/mail-mta/nullmailer/nullmailer-1.10-r1.ebuild
deleted file mode 100644
index 9401086581d7..000000000000
--- a/mail-mta/nullmailer/nullmailer-1.10-r1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.10-r1.ebuild,v 1.5 2012/11/06 11:18:38 eras Exp $
-
-EAPI=4
-inherit eutils flag-o-matic autotools user multilib
-
-MY_P="${P/_rc/RC}"
-S=${WORKDIR}/${MY_P}
-DEBIAN_PV=1.10
-DEBIAN_PR="1"
-DEBIAN_P="${PN}-${DEBIAN_PV}"
-DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
-DEBIAN_SRC="${DEBIAN_PF}.debian.tar.gz"
-DESCRIPTION="Simple relay-only local mail transport agent"
-SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
- mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 ppc x86"
-
-IUSE="ssl"
-
-DEPEND="sys-apps/groff
- ssl? ( net-libs/gnutls )"
-RDEPEND="virtual/shadow
- virtual/logger
- ssl? ( net-libs/gnutls )
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/ssmtp"
-
-src_prepare() {
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${DISTDIR}"/${DEBIAN_SRC}
- # why revert? Ask Robin when he is back!
- EPATCH_OPTS="-d ${WORKDIR} -p0 -R" \
- epatch "${WORKDIR}"/debian/patches/02_ipv6.diff
- # this fixes the debian daemon/syslog to actually compile
- sed -i.orig \
- -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
- "${S}"/src/Makefile.am || die "Sed failed"
- # bug #420301
- epatch "${FILESDIR}"/"${P}"-fix-sendmail.patch
- eautoreconf
-}
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
-src_configure() {
- # Note that we pass a different directory below due to bugs in the makefile!
- econf \
- --localstatedir=/var \
- $(use_enable ssl tls)
-}
-
-src_install () {
- einstall localstatedir="${D}"/var/nullmailer
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-1.04 remotes
- # daemontools stuff
- dodir /var/nullmailer/service{,/log}
- insinto /var/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/nullmailer/service/run
- insinto /var/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/nullmailer/service/log/run
- # usablity
- dodir /usr/$(get_libdir)
- dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
- # permissions stuff
- keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer-r1 nullmailer
-}
-
-pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
-
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- echo
- elog "To start nullmailer at boot you may use either the nullmailer init.d"
- elog "script, or emerge sys-process/supervise-scripts, enable the"
- elog "svscan init.d script and create the following link:"
- elog "ln -fs /var/nullmailer/service /service/nullmailer"
- echo
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}
diff --git a/mail-mta/nullmailer/nullmailer-1.10.ebuild b/mail-mta/nullmailer/nullmailer-1.10.ebuild
deleted file mode 100644
index b0f24a8c8e2f..000000000000
--- a/mail-mta/nullmailer/nullmailer-1.10.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.10.ebuild,v 1.2 2012/11/06 11:18:38 eras Exp $
-
-EAPI=4
-inherit eutils flag-o-matic autotools user multilib
-
-MY_P="${P/_rc/RC}"
-S=${WORKDIR}/${MY_P}
-DEBIAN_PV=1.10
-DEBIAN_PR="1"
-DEBIAN_P="${PN}-${DEBIAN_PV}"
-DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
-DEBIAN_SRC="${DEBIAN_PF}.debian.tar.gz"
-DESCRIPTION="Simple relay-only local mail transport agent"
-SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
- mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
-HOMEPAGE="http://untroubled.org/nullmailer/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE="ssl"
-
-DEPEND="sys-apps/groff
- ssl? ( net-libs/gnutls )"
-RDEPEND="virtual/shadow
- virtual/logger
- ssl? ( net-libs/gnutls )
- !mail-mta/courier
- !mail-mta/esmtp
- !mail-mta/exim
- !mail-mta/mini-qmail
- !mail-mta/msmtp
- !mail-mta/netqmail
- !mail-mta/postfix
- !mail-mta/qmail-ldap
- !mail-mta/sendmail
- !mail-mta/ssmtp"
-
-src_prepare() {
- EPATCH_OPTS="-d ${S} -p1" \
- epatch "${DISTDIR}"/${DEBIAN_SRC}
- # why revert? Ask Robin when he is back!
- EPATCH_OPTS="-d ${WORKDIR} -p0 -R" \
- epatch "${WORKDIR}"/debian/patches/02_ipv6.diff
- # this fixes the debian daemon/syslog to actually compile
- sed -i.orig \
- -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
- "${S}"/src/Makefile.am || die "Sed failed"
-
- eautoreconf
-}
-
-pkg_setup() {
- enewgroup nullmail 88
- enewuser nullmail 88 -1 /var/nullmailer nullmail
-}
-
-src_configure() {
- # Note that we pass a different directory below due to bugs in the makefile!
- econf \
- --localstatedir=/var \
- $(use_enable ssl tls)
-}
-
-src_install () {
- einstall localstatedir="${D}"/var/nullmailer
- dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
- # A small bit of sample config
- insinto /etc/nullmailer
- newins "${FILESDIR}"/remotes.sample-1.04 remotes
- # daemontools stuff
- dodir /var/nullmailer/service{,/log}
- insinto /var/nullmailer/service
- newins scripts/nullmailer.run run
- fperms 700 /var/nullmailer/service/run
- insinto /var/nullmailer/service/log
- newins scripts/nullmailer-log.run run
- fperms 700 /var/nullmailer/service/log/run
- # usablity
- dodir /usr/$(get_libdir)
- dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
- # permissions stuff
- keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
- fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
- fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
- fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
- fperms 660 /var/nullmailer/trigger
- newinitd "${FILESDIR}"/init.d-nullmailer-r1 nullmailer
-}
-
-pkg_postinst() {
- [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
- chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
- chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
- chmod 660 "${ROOT}"/var/nullmailer/trigger
-
- elog "To create an initial setup, please do:"
- elog "emerge --config =${CATEGORY}/${PF}"
- echo
- elog "To start nullmailer at boot you may use either the nullmailer init.d"
- elog "script, or emerge sys-process/supervise-scripts, enable the"
- elog "svscan init.d script and create the following link:"
- elog "ln -fs /var/nullmailer/service /service/nullmailer"
- echo
-}
-
-pkg_config() {
- if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
- einfo "Setting /etc/nullmailer/me"
- /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
- fi
- if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
- einfo "Setting /etc/nullmailer/defaultdomain"
- /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
- fi
-}