summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2012-12-16 05:46:16 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2012-12-16 05:46:16 +0000
commitdb1b2cc417a3a4de22c50d6b2934e30043596c9c (patch)
tree76d1cab60a510cce253b3d65127b5c357d6fc5c7 /media-fonts
parentwhitespace (diff)
downloadgentoo-2-db1b2cc417a3a4de22c50d6b2934e30043596c9c.tar.gz
gentoo-2-db1b2cc417a3a4de22c50d6b2934e30043596c9c.tar.bz2
gentoo-2-db1b2cc417a3a4de22c50d6b2934e30043596c9c.zip
Per Gregory Beauregard's suggestion, bump.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-fonts')
-rw-r--r--media-fonts/source-pro/ChangeLog8
-rw-r--r--media-fonts/source-pro/source-pro-20121216.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/media-fonts/source-pro/ChangeLog b/media-fonts/source-pro/ChangeLog
index 0b8a9102c6af..6a6ef4caee9a 100644
--- a/media-fonts/source-pro/ChangeLog
+++ b/media-fonts/source-pro/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-fonts/source-pro
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/source-pro/ChangeLog,v 1.1 2012/10/14 18:59:21 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/source-pro/ChangeLog,v 1.2 2012/12/16 05:46:16 zx2c4 Exp $
+
+*source-pro-20121216 (16 Dec 2012)
+
+ 16 Dec 2012; Jason A. Donenfeld <zx2c4@gentoo.org>
+ +source-pro-20121216.ebuild:
+ Per Gregory Beauregard's suggestion, bump.
*source-pro-20121014 (14 Oct 2012)
diff --git a/media-fonts/source-pro/source-pro-20121216.ebuild b/media-fonts/source-pro/source-pro-20121216.ebuild
new file mode 100644
index 000000000000..60205f92a570
--- /dev/null
+++ b/media-fonts/source-pro/source-pro-20121216.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/source-pro/source-pro-20121216.ebuild,v 1.1 2012/12/16 05:46:16 zx2c4 Exp $
+
+EAPI=4
+inherit font
+
+CODE_P=SourceCodePro_FontsOnly-1.013
+SANS_P=SourceSansPro_FontsOnly-1.038
+
+DESCRIPTION="Adobe Source Pro, an open source multi-lingual font family"
+HOMEPAGE="http://blogs.adobe.com/typblography/2012/08/source-sans-pro.html
+ http://blogs.adobe.com/typblography/2012/09/source-code-pro.html"
+SRC_URI="mirror://sourceforge/sourcecodepro.adobe/${CODE_P}.zip
+ mirror://sourceforge/sourcesans.adobe/${SANS_P}.zip"
+
+LICENSE="OFL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+RDEPEND="media-libs/fontconfig"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+FONT_SUFFIX="otf ttf"
+FONT_S=${S}
+FONT_CONF=( "${FILESDIR}"/63-${PN}.conf )
+
+src_prepare() {
+ # Put otf and ttf files in one directory so that font_src_install can
+ # actually find them. We make this non-fatal because releases appear to be
+ # alternating between having OTF/TTF subdirs and not, so it's easier just to
+ # glob for everything.
+ mv -vf ${CODE_P}/{OTF,TTF,""}/* .
+ mv -vf ${SANS_P}/{OTF,TTF,""}/* .
+}
+
+src_install() {
+ font_src_install
+ dohtml *.html
+}