summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-16 11:40:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-16 11:40:02 +0000
commite2ec608cc9b0ac54c2df2df9c51534eeddbfc841 (patch)
treec014160743886f0c4bc09614ace90e782a07e0ed /media-gfx/blender
parentVersion bump. (diff)
downloadgentoo-2-e2ec608cc9b0ac54c2df2df9c51534eeddbfc841.tar.gz
gentoo-2-e2ec608cc9b0ac54c2df2df9c51534eeddbfc841.tar.bz2
gentoo-2-e2ec608cc9b0ac54c2df2df9c51534eeddbfc841.zip
Simplify handling of iconv USE flag (masked on profiles where it's useless). Simplify blend_with calls (no longer in a loop).
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/blender')
-rw-r--r--media-gfx/blender/ChangeLog6
-rw-r--r--media-gfx/blender/blender-2.63a-r1.ebuild76
2 files changed, 38 insertions, 44 deletions
diff --git a/media-gfx/blender/ChangeLog b/media-gfx/blender/ChangeLog
index 34f3da1c4191..216478bf194c 100644
--- a/media-gfx/blender/ChangeLog
+++ b/media-gfx/blender/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/blender
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.229 2012/07/16 09:28:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.230 2012/07/16 11:40:02 flameeyes Exp $
+
+ 16 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> blender-2.63a-r1.ebuild:
+ Simplify handling of iconv USE flag (masked on profiles where it's useless).
+ Simplify blend_with calls (no longer in a loop).
16 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> blender-2.63a-r1.ebuild,
metadata.xml:
diff --git a/media-gfx/blender/blender-2.63a-r1.ebuild b/media-gfx/blender/blender-2.63a-r1.ebuild
index 677ca7890f1a..6bc3ca0354d7 100644
--- a/media-gfx/blender/blender-2.63a-r1.ebuild
+++ b/media-gfx/blender/blender-2.63a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.63a-r1.ebuild,v 1.2 2012/07/16 09:28:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.63a-r1.ebuild,v 1.3 2012/07/16 11:40:02 flameeyes Exp $
EAPI=4
PYTHON_DEPEND="3:3.2"
@@ -56,7 +56,7 @@ RDEPEND="virtual/jpeg
media-libs/openimageio
>=dev-libs/boost-1.44
)
- iconv? ( virtual/libiconv )
+ iconv? ( dev-libs/libiconv )
sdl? ( media-libs/libsdl[audio,joystick] )
openexr? ( media-libs/openexr )
ffmpeg? (
@@ -111,11 +111,6 @@ src_prepare() {
}
src_configure() {
- blend_with() {
- echo "WITH_BF_${2:-$1}=$(usex $1 1 0)" | tr '[:lower:]' '[:upper:]' \
- >> "${S}"/user-config.py
- }
-
# FIX: forcing '-funsigned-char' fixes an anti-aliasing issue with menu
# shadows, see bug #276338 for reference
append-flags -funsigned-char
@@ -124,7 +119,6 @@ src_configure() {
local mycflags=$(printf "'%s'," ${CPPFLAGS} ${CFLAGS} | sed -e 's:,$::')
local mycxxflags=$(printf "'%s'," ${CPPFLAGS} ${CXXFLAGS} | sed -e 's:,$::')
local myldflags=$(printf "'%s'," ${LDFLAGS} | sed -e 's:,$::')
-
cat << EOF >> "${S}"/user-config.py
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"
@@ -165,6 +159,8 @@ BF_OIIO_LIB="OpenImageIO"
BF_BOOST="/usr"
BF_BOOST_INC="/usr/include/boost"
+BF_ICONV="/usr"
+
BF_TWEAK_MODE=$(usex tweak-mode 1 0)
BF_DEBUG=$(usex debug 1 0)
@@ -183,43 +179,37 @@ WITH_BF_BINRELOC=0
WITH_BF_STATICOPENGL=0
EOF
- #add iconv into Scons build options.
- if use !elibc_glibc && use !elibc_uclibc && use iconv; then
- cat <<- EOF >> "${S}"/user-config.py
- WITH_BF_ICONV=1
- BF_ICONV="/usr"
- EOF
- fi
+ blend_with() {
+ echo "WITH_BF_${2:-$1}=$(usex $1 1 0)" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ }
# configure WITH_BF* Scons build options
- for arg in \
- '3dmouse' \
- 'collada' \
- 'cycles boost' \
- 'cycles oiio' \
- 'cycles' \
- 'dds' \
- 'doc docs' \
- 'elbeem fluid' \
- 'ffmpeg ogg' \
- 'ffmpeg' \
- 'fftw fftw3' \
- 'fftw oceansim' \
- 'game-engine gameengine' \
- 'jack' \
- 'jpeg2k openjpeg' \
- 'nls international' \
- 'openal'\
- 'openexr' \
- 'openmp' \
- 'player' \
- 'redcode' \
- 'sdl' \
- 'sndfile' \
- 'sse rayoptimization' \
- ; do
- blend_with ${arg}
- done
+ blend_with 3dmouse
+ blend_with collada
+ blend_with cycles boost
+ blend_with cycles oiio
+ blend_with cycles
+ blend_with dds
+ blend_with doc docs
+ blend_with elbeem fluid
+ blend_with ffmpeg ogg
+ blend_with ffmpeg
+ blend_with fftw fftw3
+ blend_with fftw oceansim
+ blend_with game-engine gameengine
+ blend_with iconv
+ blend_with jack
+ blend_with jpeg2k openjpeg
+ blend_with nls international
+ blend_with openal
+ blend_with openexr
+ blend_with openmp
+ blend_with player
+ blend_with redcode
+ blend_with sdl
+ blend_with sndfile
+ blend_with sse rayoptimization
}
src_compile() {