summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-09-04 21:10:00 +0000
committerTim Harder <radhermit@gentoo.org>2014-09-04 21:10:00 +0000
commite060f690032f398497e1bd771eddb95fa9f5f00e (patch)
tree941b753eec5a55d6d7c6ed2db25b42f679e1efe5 /media-gfx/graphicsmagick
parentStable for HPPA (bug #521478). (diff)
downloadgentoo-2-e060f690032f398497e1bd771eddb95fa9f5f00e.tar.gz
gentoo-2-e060f690032f398497e1bd771eddb95fa9f5f00e.tar.bz2
gentoo-2-e060f690032f398497e1bd771eddb95fa9f5f00e.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4F064CA3)
Diffstat (limited to 'media-gfx/graphicsmagick')
-rw-r--r--media-gfx/graphicsmagick/ChangeLog8
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch20
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.20.ebuild130
3 files changed, 157 insertions, 1 deletions
diff --git a/media-gfx/graphicsmagick/ChangeLog b/media-gfx/graphicsmagick/ChangeLog
index efacb61b6d26..f83e62a3227c 100644
--- a/media-gfx/graphicsmagick/ChangeLog
+++ b/media-gfx/graphicsmagick/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/graphicsmagick
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/ChangeLog,v 1.122 2014/03/03 19:22:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/ChangeLog,v 1.123 2014/09/04 21:10:00 radhermit Exp $
+
+*graphicsmagick-1.3.20 (04 Sep 2014)
+
+ 04 Sep 2014; Tim Harder <radhermit@gentoo.org> +graphicsmagick-1.3.20.ebuild,
+ +files/graphicsmagick-1.3.20-powerpc.patch:
+ Version bump.
03 Mar 2014; Samuli Suominen <ssuominen@gentoo.org>
graphicsmagick-1.3.19.ebuild:
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch
new file mode 100644
index 000000000000..44a13581e42a
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.20-powerpc.patch
@@ -0,0 +1,20 @@
+--- GraphicsMagick-1.3.20/magick/studio.h
++++ GraphicsMagick-1.3.20/magick/studio.h
+@@ -51,12 +51,11 @@
+ threads. Most CPUs have cache lines of 32 or 64 bytes. IBM Power CPUs have
+ cache lines of 128 bytes.
+ */
+-/* FIXME: C pre-processor does not support comparing strings. */
+-/* #if defined(MAGICK_TARGET_CPU) && (MAGICK_TARGET_CPU == powerpc) */
+-/* # define MAGICK_CACHE_LINE_SIZE 128 */
+-/* #else */
+-# define MAGICK_CACHE_LINE_SIZE 64
+-/* #endif */
++#ifdef __powerpc__
++#define MAGICK_CACHE_LINE_SIZE 128
++#else
++#define MAGICK_CACHE_LINE_SIZE 64
++#endif
+
+
+ /*
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.20.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.20.ebuild
new file mode 100644
index 000000000000..83e170def0cc
--- /dev/null
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.20.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.20.ebuild,v 1.1 2014/09/04 21:10:00 radhermit Exp $
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+MY_P=${P/graphicsm/GraphicsM}
+
+DESCRIPTION="Collection of tools and libraries for many image formats"
+HOMEPAGE="http://www.graphicsmagick.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bzip2 cxx debug fpx imagemagick jbig jpeg jpeg2k lcms lzma modules openmp
+ perl png postscript q16 q32 static-libs svg threads tiff truetype webp wmf X zlib"
+
+RDEPEND=">=sys-devel/libtool-2.2.6b
+ bzip2? ( app-arch/bzip2 )
+ fpx? ( media-libs/libfpx )
+ imagemagick? ( !media-gfx/imagemagick )
+ jbig? ( media-libs/jbigkit )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/jasper )
+ lcms? ( media-libs/lcms:2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng:0 )
+ postscript? ( app-text/ghostscript-gpl )
+ svg? ( dev-libs/libxml2 )
+ tiff? ( media-libs/tiff:0 )
+ truetype? (
+ media-fonts/urw-fonts
+ >=media-libs/freetype-2
+ )
+ webp? ( media-libs/libwebp )
+ wmf? ( media-libs/libwmf )
+ X? (
+ x11-libs/libSM
+ x11-libs/libXext
+ )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.19-freetype.patch
+ epatch "${FILESDIR}"/${PN}-1.3.19-flags.patch
+ epatch "${FILESDIR}"/${PN}-1.3.19-perl.patch
+ epatch "${FILESDIR}"/${P}-powerpc.patch
+
+ epatch_user #498942
+
+ eautoreconf
+}
+
+src_configure() {
+ local depth=8
+ use q16 && depth=16
+ use q32 && depth=32
+
+ local openmp=disable
+ if use openmp && tc-has-openmp; then
+ openmp=enable
+ fi
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ --${openmp}-openmp \
+ --enable-largefile \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug prof) \
+ $(use_enable debug gcov) \
+ $(use_enable imagemagick magick-compat) \
+ $(use_with threads) \
+ $(use_with modules) \
+ --with-quantum-depth=${depth} \
+ --without-frozenpaths \
+ $(use_with cxx magick-plus-plus) \
+ $(use_with perl) \
+ --with-perl-options=INSTALLDIRS=vendor \
+ $(use_with bzip2 bzlib) \
+ $(use_with postscript dps) \
+ $(use_with fpx) \
+ --without-gslib \
+ $(use_with jbig) \
+ $(use_with webp) \
+ $(use_with jpeg) \
+ $(use_with jpeg2k jp2) \
+ --without-lcms \
+ $(use_with lcms lcms2) \
+ $(use_with lzma) \
+ $(use_with png) \
+ $(use_with tiff) \
+ $(use_with truetype ttf) \
+ $(use_with wmf) \
+ --with-fontpath="${EPREFIX}"/usr/share/fonts \
+ --with-gs-font-dir="${EPREFIX}"/usr/share/fonts/urw-fonts \
+ --with-windows-font-dir="${EPREFIX}"/usr/share/fonts/corefonts \
+ $(use_with svg xml) \
+ $(use_with zlib) \
+ $(use_with X x)
+}
+
+src_compile() {
+ default
+ use perl && emake perl-build
+}
+
+src_test() {
+ unset DISPLAY # some perl tests fail when DISPLAY is set
+ default
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ emake -C PerlMagick DESTDIR="${D}" install
+ find "${ED}" -type f -name perllocal.pod -exec rm -f {} +
+ find "${ED}" -depth -mindepth 1 -type d -empty -exec rm -rf {} +
+ fi
+
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}