summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-10 19:04:25 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-10 19:04:25 +0000
commitbcd85f9a8da8f5c10e8ac1e43d83d3698f12c2d7 (patch)
treea100b12448529c67d348a7594615e9625010b26f /media-gfx/jhead/jhead-2.4.ebuild
parentVersion bump including 2.6.13 and 2.6.13-mm compatibility fix (diff)
downloadgentoo-2-bcd85f9a8da8f5c10e8ac1e43d83d3698f12c2d7.tar.gz
gentoo-2-bcd85f9a8da8f5c10e8ac1e43d83d3698f12c2d7.tar.bz2
gentoo-2-bcd85f9a8da8f5c10e8ac1e43d83d3698f12c2d7.zip
bug 105492
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-gfx/jhead/jhead-2.4.ebuild')
-rw-r--r--media-gfx/jhead/jhead-2.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/jhead/jhead-2.4.ebuild b/media-gfx/jhead/jhead-2.4.ebuild
new file mode 100644
index 000000000000..9dca654feb85
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/jhead/jhead-2.4.ebuild,v 1.1 2005/09/10 19:04:25 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/libc
+ media-libs/jpeg"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-gcc4.diff
+ sed -i "s:-O3 -Wall:${CFLAGS}:" makefile || die
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin jhead || die
+ dodoc {readme,changes}.txt
+ dohtml usage.html
+ doman jhead.1.gz
+}