summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-31 14:07:29 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-31 14:07:29 +0000
commit7b47accda8e86ad161a10f48494c5f6567619fc3 (patch)
tree111b982e38c0cccfe4781cccc56133e5c6b0ef81 /media-gfx/k3d
parentAdd maintainer. (diff)
downloadgentoo-2-7b47accda8e86ad161a10f48494c5f6567619fc3.tar.gz
gentoo-2-7b47accda8e86ad161a10f48494c5f6567619fc3.tar.bz2
gentoo-2-7b47accda8e86ad161a10f48494c5f6567619fc3.zip
Build with gcc47 (#421951 by Peter Asplund)
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx/k3d')
-rw-r--r--media-gfx/k3d/ChangeLog6
-rw-r--r--media-gfx/k3d/files/k3d-0.7.11.0-gcc47.patch87
-rw-r--r--media-gfx/k3d/k3d-0.7.11.0-r1.ebuild5
3 files changed, 95 insertions, 3 deletions
diff --git a/media-gfx/k3d/ChangeLog b/media-gfx/k3d/ChangeLog
index afbda8f43705..9b37316b7df6 100644
--- a/media-gfx/k3d/ChangeLog
+++ b/media-gfx/k3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/k3d
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/ChangeLog,v 1.57 2013/08/18 03:08:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/ChangeLog,v 1.58 2013/08/31 14:07:29 pacho Exp $
+
+ 31 Aug 2013; Pacho Ramos <pacho@gentoo.org> +files/k3d-0.7.11.0-gcc47.patch,
+ k3d-0.7.11.0-r1.ebuild:
+ Build with gcc47 (#421951 by Peter Asplund)
18 Aug 2013; Patrick Lauer <patrick@gentoo.org> k3d-0.7.11.0-r1.ebuild:
Whitespace
diff --git a/media-gfx/k3d/files/k3d-0.7.11.0-gcc47.patch b/media-gfx/k3d/files/k3d-0.7.11.0-gcc47.patch
new file mode 100644
index 000000000000..56603d2d2b1b
--- /dev/null
+++ b/media-gfx/k3d/files/k3d-0.7.11.0-gcc47.patch
@@ -0,0 +1,87 @@
+--- k3d-source-0.8.0.2/k3dsdk/gil/boost/gil/extension/dynamic_image/apply_operation_base.hpp 2010-07-02 23:27:47.000000000 -0300
++++ k3d-source-0.8.0.2_patched/k3dsdk/gil/boost/gil/extension/dynamic_image/apply_operation_base.hpp 2012-09-14 15:48:20.000000000 -0300
+@@ -114,7 +114,7 @@
+ template <typename T2, typename Op>
+ struct reduce_bind1 {
+ const T2& _t2;
+- mutable Op& _op;
++ Op& _op;
+
+ typedef typename Op::result_type result_type;
+
+@@ -127,7 +127,7 @@
+ struct reduce_bind2 {
+ const Bits1& _bits1;
+ std::size_t _index1;
+- mutable Op& _op;
++ Op& _op;
+
+ typedef typename Op::result_type result_type;
+
+--- k3d-source-0.8.0.2/k3dsdk/data.h 2010-07-02 23:27:46.000000000 -0300
++++ k3d-source-0.8.0.2_patched/k3dsdk/data.h 2012-09-14 16:50:20.000000000 -0300
+@@ -580,7 +580,7 @@
+
+ try
+ {
+- set_value(boost::lexical_cast<value_t>(*new_value), Hint);
++ this->set_value(boost::lexical_cast<value_t>(*new_value), Hint);
+ return true;
+ }
+ catch(...)
+@@ -865,7 +865,7 @@
+
+ try
+ {
+- set_value(boost::lexical_cast<value_t>(*new_value), Hint);
++ this->set_value(boost::lexical_cast<value_t>(*new_value), Hint);
+ return true;
+ }
+ catch(...)
+@@ -1011,7 +1011,7 @@
+
+ try
+ {
+- set_value(boost::lexical_cast<value_t>(*new_value), Hint);
++ this->set_value(boost::lexical_cast<value_t>(*new_value), Hint);
+ return true;
+ }
+ catch(...)
+@@ -1146,7 +1146,7 @@
+ if(!new_value)
+ return false;
+
+- set_value(*new_value, Hint);
++ this->set_value(*new_value, Hint);
+ return true;
+ }
+
+@@ -1671,7 +1671,7 @@
+ /// This little bit of magic makes it possible for base classes (such as node_storage) to update their own values while observing the correct undo policy
+ void internal_set_value(const value_t& Value, ihint* const Hint)
+ {
+- set_value(Value, Hint);
++ this->set_value(Value, Hint);
+ }
+ };
+
+--- k3d-source-0.8.0.2/modules/animation/interpolator.h 2010-07-02 23:27:55.000000000 -0300
++++ k3d-source-0.8.0.2_patched/modules/animation/interpolator.h 2012-09-14 16:45:16.000000000 -0300
+@@ -92,7 +92,7 @@
+ {
+ time_t t_lower, t_upper;
+ value_t v_lower, v_upper;
+- get_surrounding_keys(Time, Keyframes, t_lower, t_upper, v_lower, v_upper);
++ this->get_surrounding_keys(Time, Keyframes, t_lower, t_upper, v_lower, v_upper);
+ return lerp(t_lower, t_upper, v_lower, v_upper, Time);
+ }
+ protected:
+@@ -116,7 +116,7 @@
+ {
+ time_t t_lower, t_upper;
+ value_t v_lower, v_upper;
+- get_surrounding_keys(Time, Keyframes, t_lower, t_upper, v_lower, v_upper);
++ this->get_surrounding_keys(Time, Keyframes, t_lower, t_upper, v_lower, v_upper);
+ return lerp(t_lower, t_upper, v_lower, v_upper, Time);
+ }
+ protected:
diff --git a/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild b/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild
index 58571a314686..0c4d3956aafe 100644
--- a/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild
+++ b/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild,v 1.13 2013/08/18 03:08:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild,v 1.14 2013/08/31 14:07:29 pacho Exp $
EAPI="2"
@@ -77,7 +77,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-fix-potfiles.patch \
"${FILESDIR}"/${P}-cuda.patch \
"${FILESDIR}"/${P}-gcc44.patch \
- "${FILESDIR}"/${P}-gtk-liststore-vs-treemodel.patch
+ "${FILESDIR}"/${P}-gtk-liststore-vs-treemodel.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
[[ -f CMakeCache.txt ]] && rm CMakeCache.txt
}