summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-03-11 10:38:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-03-11 10:38:36 +0000
commit1839a996e89641f9e21f790cf886911e20fd9c7a (patch)
tree0b3c193fe15da951585791c22a484e457c788f86 /media-gfx/wally
parentAdd opengl useflag. Bug #406955. Patch by Ian Delaney (diff)
downloadgentoo-2-1839a996e89641f9e21f790cf886911e20fd9c7a.tar.gz
gentoo-2-1839a996e89641f9e21f790cf886911e20fd9c7a.tar.bz2
gentoo-2-1839a996e89641f9e21f790cf886911e20fd9c7a.zip
Version bump. Bug #406405. Patch for Bug #370327. Thanks to Michael (kensington) <gentoo@scribeofthenile.com>
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/wally')
-rw-r--r--media-gfx/wally/ChangeLog11
-rw-r--r--media-gfx/wally/files/wally-2.4.4-gold.patch11
-rw-r--r--media-gfx/wally/wally-2.4.4.ebuild65
3 files changed, 85 insertions, 2 deletions
diff --git a/media-gfx/wally/ChangeLog b/media-gfx/wally/ChangeLog
index 3a0a113fb91d..37863dc19825 100644
--- a/media-gfx/wally/ChangeLog
+++ b/media-gfx/wally/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/wally
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.39 2011/10/25 16:38:30 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/ChangeLog,v 1.40 2012/03/11 10:38:36 hwoarang Exp $
+
+*wally-2.4.4 (11 Mar 2012)
+
+ 11 Mar 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/wally-2.4.4-gold.patch, +wally-2.4.4.ebuild:
+ Version bump. Bug #406405. Patch for Bug #370327. Thanks to Michael
+ (kensington) <gentoo@scribeofthenile.com>
25 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> wally-2.4.2.ebuild:
x86 stable wrt bug #387737
diff --git a/media-gfx/wally/files/wally-2.4.4-gold.patch b/media-gfx/wally/files/wally-2.4.4-gold.patch
new file mode 100644
index 000000000000..bed2d67d26a5
--- /dev/null
+++ b/media-gfx/wally/files/wally-2.4.4-gold.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -284,7 +284,7 @@
+ set( PROGNAME wally )
+
+ add_executable( ${PROGNAME} ${WALLY_QMS} ${WALLY_SRCS} ${WALLY_MOC_SRCS} ${WALLY_IMAGES_RC_SRCS} ${WALLY_LANGUAGES_RC_SRCS} ${WALLY_UI_HDRS} )
+- target_link_libraries( ${PROGNAME} ${QT_LIBRARIES} ${EXIF_LIBRARIES} )
++ target_link_libraries( ${PROGNAME} ${QT_LIBRARIES} ${EXIF_LIBRARIES} -lX11 )
+ install( TARGETS ${PROGNAME} DESTINATION /usr/bin )
+
+ if( CMAKE_BUILD_TYPE STREQUAL Release )
diff --git a/media-gfx/wally/wally-2.4.4.ebuild b/media-gfx/wally/wally-2.4.4.ebuild
new file mode 100644
index 000000000000..6a13d8a6b97d
--- /dev/null
+++ b/media-gfx/wally/wally-2.4.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/wally/wally-2.4.4.ebuild,v 1.1 2012/03/11 10:38:36 hwoarang Exp $
+
+EAPI=4
+KDE_REQUIRED="optional"
+
+inherit eutils kde4-base
+
+DESCRIPTION="A Qt4/KDE4 wallpaper changer"
+HOMEPAGE="http://www.becrux.com/index.php?page=projects&name=wally"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kde"
+
+DEPEND="
+ media-libs/libexif
+ x11-libs/libX11
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
+ kde? ( $(add_kdebase_dep kdelibs) )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ "AUTHORS" "ChangeLog" "README" "README.XFCE4"
+ "README.shortcuts" "TODO"
+)
+PATCHES=(
+ "${FILESDIR}/${P}-gold.patch"
+ "${FILESDIR}/${PN}-2.2.0-disable_popup.patch"
+)
+
+src_prepare() {
+ kde4-base_src_prepare
+ use kde || epatch "${FILESDIR}/${PN}-2.2.0-disable-kde4.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DSTATIC=FALSE
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon "${S}"/res/images/idle.png wally.png
+ make_desktop_entry wally Wally wally "Graphics;Qt"
+}
+
+pkg_postinst() {
+ if use kde ; then
+ elog
+ elog "In order to use wallyplugin you need to"
+ elog "restart plasma in your KDE4 enviroment."
+ elog
+ fi
+}