summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-03-13 18:05:08 +0000
committerMichael Januszewski <spock@gentoo.org>2007-03-13 18:05:08 +0000
commit7e51f6604501bc1dad27cf16fde5f2149bc5b2fc (patch)
tree25d0c612844b288555ff80dbb5c6b428c275b064 /media-gfx
parentx86 stable and drop old (diff)
downloadgentoo-2-7e51f6604501bc1dad27cf16fde5f2149bc5b2fc.tar.gz
gentoo-2-7e51f6604501bc1dad27cf16fde5f2149bc5b2fc.tar.bz2
gentoo-2-7e51f6604501bc1dad27cf16fde5f2149bc5b2fc.zip
Add a patch to use BOOT_MSG to set the system message when running the splash daemon.
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/splashutils/ChangeLog7
-rw-r--r--media-gfx/splashutils/files/splashutils-1.3.1-boot_msg.patch17
-rw-r--r--media-gfx/splashutils/splashutils-1.3.1.ebuild3
3 files changed, 25 insertions, 2 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 35d1c2640e42..aa2ef979c487 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.74 2007/03/13 16:39:23 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.75 2007/03/13 18:05:08 spock Exp $
+
+ 13 Mar 2007; Michał Januszewski <spock@gentoo.org>
+ +files/splashutils-1.3.1-boot_msg.patch, splashutils-1.3.1.ebuild:
+ Add a patch to use BOOT_MSG to set the system message when running the
+ splash daemon.
*splashutils-1.3.1 (13 Mar 2007)
diff --git a/media-gfx/splashutils/files/splashutils-1.3.1-boot_msg.patch b/media-gfx/splashutils/files/splashutils-1.3.1-boot_msg.patch
new file mode 100644
index 000000000000..2235a63978e1
--- /dev/null
+++ b/media-gfx/splashutils/files/splashutils-1.3.1-boot_msg.patch
@@ -0,0 +1,17 @@
+diff --git a/gentoo/splash-functions.sh b/gentoo/splash-functions.sh
+index 9601116..38216f1 100644
+--- a/gentoo/splash-functions.sh
++++ b/gentoo/splash-functions.sh
+@@ -260,11 +260,10 @@ splash_start() {
+ [[ ${SPLASH_KDMODE} == "GRAPHICS" ]] && options="--kdgraphics"
+
+ # Start the splash daemon
+- ${spl_util} -d --theme=${SPLASH_THEME} --pidfile=${spl_pidfile} ${options}
++ BOOT_MSG="$(splash_get_boot_message)" ${spl_util} -d --theme=${SPLASH_THEME} --pidfile=${spl_pidfile} ${options}
+
+ # Set the silent TTY and boot message
+ splash_comm_send "set tty silent ${SPLASH_TTY}"
+- splash_comm_send "set message $(splash_get_boot_message)"
+
+ if [[ ${SPLASH_MODE_REQ} == "silent" ]] ; then
+ splash_comm_send "set mode silent"
diff --git a/media-gfx/splashutils/splashutils-1.3.1.ebuild b/media-gfx/splashutils/splashutils-1.3.1.ebuild
index 18eedebd2b23..527141205481 100644
--- a/media-gfx/splashutils/splashutils-1.3.1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3.1.ebuild,v 1.1 2007/03/13 16:39:23 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3.1.ebuild,v 1.2 2007/03/13 18:05:08 spock Exp $
inherit eutils multilib toolchain-funcs
@@ -66,6 +66,7 @@ src_unpack() {
cd ${SG}
epatch ${FILESDIR}/${GENTOOSPLASH}-old-baselayout.patch
+ epatch ${FILESDIR}/${P}-boot_msg.patch
cd ${S}