summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-04-29 21:46:02 +0000
committerSebastian Pipping <sping@gentoo.org>2013-04-29 21:46:02 +0000
commit4fedd2d435a52f25f16dd2e81a8cfcd1de136320 (patch)
tree14c34de316cc79734d5fda7ad43c761ffe87fd35 /media-libs/babl
parentFix building with USE=-static-libs. (diff)
downloadgentoo-2-4fedd2d435a52f25f16dd2e81a8cfcd1de136320.tar.gz
gentoo-2-4fedd2d435a52f25f16dd2e81a8cfcd1de136320.tar.bz2
gentoo-2-4fedd2d435a52f25f16dd2e81a8cfcd1de136320.zip
media-libs/babl: Fix build with USE=introspection (bug #413663)
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'media-libs/babl')
-rw-r--r--media-libs/babl/ChangeLog8
-rw-r--r--media-libs/babl/babl-0.1.10.ebuild5
-rw-r--r--media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch12
-rw-r--r--media-libs/babl/files/babl-0.1.10-introspection.patch25
4 files changed, 47 insertions, 3 deletions
diff --git a/media-libs/babl/ChangeLog b/media-libs/babl/ChangeLog
index 0d30c9d4b7b8..33123ae08cce 100644
--- a/media-libs/babl/ChangeLog
+++ b/media-libs/babl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/babl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.45 2013/02/21 18:07:17 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.46 2013/04/29 21:46:02 sping Exp $
+
+ 29 Apr 2013; Sebastian Pipping <sping@gentoo.org> babl-0.1.10.ebuild,
+ +files/babl-0.1.10-g-ir-compiler-crash.patch,
+ +files/babl-0.1.10-introspection.patch:
+ Fix build with USE=introspection (bug #413663), patches by upstream and
+ openSUSE
21 Feb 2013; Zac Medico <zmedico@gentoo.org> babl-0.1.10.ebuild:
Add ~arm-linux keyword.
diff --git a/media-libs/babl/babl-0.1.10.ebuild b/media-libs/babl/babl-0.1.10.ebuild
index a5f2d2f13792..6604a457e72e 100644
--- a/media-libs/babl/babl-0.1.10.ebuild
+++ b/media-libs/babl/babl-0.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.10.ebuild,v 1.6 2013/02/21 18:07:17 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.10.ebuild,v 1.7 2013/04/29 21:46:02 sping Exp $
EAPI=3
VALASLOT=0.14
@@ -28,7 +28,8 @@ src_prepare() {
# fix compilation on OSX, can be dropped on next release:
# http://mail.gnome.org/archives/commits-list/2012-April/msg02589.html
sed -i -e 's/values\.h/limits.h/' babl/babl-palette.c || die
- epatch "${FILESDIR}"/${PN}-0.1.6-introspection.patch
+ epatch "${FILESDIR}"/${P}-introspection.patch
+ epatch "${FILESDIR}"/${P}-g-ir-compiler-crash.patch
eautoreconf
}
diff --git a/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch b/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch
new file mode 100644
index 000000000000..4b6cf919a849
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-g-ir-compiler-crash.patch
@@ -0,0 +1,12 @@
+Index: babl-0.1.10/babl/Makefile.am
+===================================================================
+--- babl-0.1.10.orig/babl/Makefile.am
++++ babl-0.1.10/babl/Makefile.am
+@@ -95,6 +95,7 @@ INTROSPECTION_COMPILER_ARGS = --included
+ if HAVE_INTROSPECTION
+ Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am libbabl-@BABL_API_VERSION@.la
+ $(INTROSPECTION_SCANNER) -v --namespace Babl --nsversion=$(BABL_API_VERSION) \
++ --identifier-prefix= --symbol-prefix=babl \
+ --add-include-path=$(srcdir) --add-include-path=. \
+ --library=$(builddir)/libbabl-$(BABL_API_VERSION).la \
+ --libtool="$(LIBTOOL)" \
diff --git a/media-libs/babl/files/babl-0.1.10-introspection.patch b/media-libs/babl/files/babl-0.1.10-introspection.patch
new file mode 100644
index 000000000000..f9b92698689d
--- /dev/null
+++ b/media-libs/babl/files/babl-0.1.10-introspection.patch
@@ -0,0 +1,25 @@
+From c024c89f95de4a8fa95ba96790dac61768d11a17 Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Tue, 10 Jan 2012 16:32:50 +0000
+Subject: gobject-introspection: fix build of the .gir and .typelib files.
+
+---
+diff --git a/babl/Makefile.am b/babl/Makefile.am
+index cefab57..03115a3 100644
+--- a/babl/Makefile.am
++++ b/babl/Makefile.am
+@@ -93,10 +93,10 @@ INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
+ INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
+
+ if HAVE_INTROSPECTION
+-Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am
++Babl-$(BABL_API_VERSION).gir: $(G_IR_SCANNER) $(library_include_HEADERS) $(c_sources) $(srcdir)/Makefile.am libbabl-@BABL_API_VERSION@.la
+ $(INTROSPECTION_SCANNER) -v --namespace Babl --nsversion=$(BABL_API_VERSION) \
+ --add-include-path=$(srcdir) --add-include-path=. \
+- --library=babl-$(BABL_API_VERSION) \
++ --library=$(builddir)/libbabl-$(BABL_API_VERSION).la \
+ --libtool="$(LIBTOOL)" \
+ --output $@ \
+ -DBABL_IS_BEING_COMPILED \
+--
+cgit v0.9.1