summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-07 18:08:14 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-07 18:08:14 +0000
commite6bf5a57cf6dfcd432ebcbaed49e44cb1179d7c8 (patch)
treedce292e4f0a6b7b0dd9b0700f2a897a9e0d70800 /media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
parentVersion bumped. Closes #20656. (diff)
downloadgentoo-2-e6bf5a57cf6dfcd432ebcbaed49e44cb1179d7c8.tar.gz
gentoo-2-e6bf5a57cf6dfcd432ebcbaed49e44cb1179d7c8.tar.bz2
gentoo-2-e6bf5a57cf6dfcd432ebcbaed49e44cb1179d7c8.zip
Version bumped. Closes #20656.
Diffstat (limited to 'media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild')
-rw-r--r--media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild b/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
new file mode 100644
index 000000000000..de385dc9502e
--- /dev/null
+++ b/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild,v 1.1 2003/07/07 18:07:53 mholzer Exp $
+
+DESCRIPTION="CMT (computer music toolkit) Lasdpa library plugins"
+HOMEPAGE="http://www.ladspa.org/"
+LICENSE="LGPL-2.1"
+DEPEND="media-libs/ladspa-sdk"
+SRC_URI="http://www.ladspa.org/download/cmt_src_${PV}.tgz"
+KEYWORDS="x86"
+
+SLOT="0"
+
+S=${WORKDIR}/cmt/src
+P=cmt_src
+A=${P}.tgz
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ sed -e "/^CFLAGS/ s/-O3/${CFLAGS}/" \
+ -e 's|/usr/local/include||g' \
+ -e 's|/usr/local/lib||g' \
+ makefile > makefile.new
+ mv makefile.new makefile
+
+}
+src_compile() {
+ emake || die
+}
+
+src_install() {
+
+ dodoc ../doc/*
+ insinto /usr/lib/ladspa
+ INSOPTIONS="-m755"
+ doins ../plugins/*.so
+
+
+
+}
+