summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2014-09-14 09:05:47 +0000
committerMarkus Meier <maekke@gentoo.org>2014-09-14 09:05:47 +0000
commit13a52980e827537c47fa507fc481817285761d23 (patch)
tree1cfbdab1165e454cf0da038f37c45ba5ea61caa5 /media-libs/lensfun
parentVersion bump. Thanks to Andreas Sturmlechner. (diff)
downloadgentoo-2-13a52980e827537c47fa507fc481817285761d23.tar.gz
gentoo-2-13a52980e827537c47fa507fc481817285761d23.tar.bz2
gentoo-2-13a52980e827537c47fa507fc481817285761d23.zip
add support for building with clang by Fabio Scaccabarozzi in bug #519006
(Portage version: 2.2.12-r1/cvs/Linux x86_64, signed Manifest commit with key 072AD062)
Diffstat (limited to 'media-libs/lensfun')
-rw-r--r--media-libs/lensfun/ChangeLog6
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.8-support-clang-visibility-as-gcc.patch14
-rw-r--r--media-libs/lensfun/lensfun-0.2.8-r1.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index cc6cc15f2e6f..5b3bbe4083a3 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.74 2014/08/03 18:47:36 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.75 2014/09/14 09:05:46 maekke Exp $
+
+ 14 Sep 2014; Markus Meier <maekke@gentoo.org> lensfun-0.2.8-r1.ebuild,
+ +files/lensfun-0.2.8-support-clang-visibility-as-gcc.patch:
+ add support for building with clang by Fabio Scaccabarozzi in bug #519006
03 Aug 2014; Markus Meier <maekke@gentoo.org> -lensfun-0.2.7.ebuild,
-files/lensfun-0.2.6-auxfun.patch, -files/lensfun-0.2.7-build.patch,
diff --git a/media-libs/lensfun/files/lensfun-0.2.8-support-clang-visibility-as-gcc.patch b/media-libs/lensfun/files/lensfun-0.2.8-support-clang-visibility-as-gcc.patch
new file mode 100644
index 000000000000..83462ee0cda7
--- /dev/null
+++ b/media-libs/lensfun/files/lensfun-0.2.8-support-clang-visibility-as-gcc.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/show_bug.cgi?id=519006
+
+diff -Nuar lensfun-0.2.8.orig/include/lensfun/lensfun.h.in lensfun-0.2.8/include/lensfun/lensfun.h.in
+--- lensfun-0.2.8.orig/include/lensfun/lensfun.h.in 2013-01-27 17:32:37.000000000 +0100
++++ lensfun-0.2.8/include/lensfun/lensfun.h.in 2014-08-05 08:14:20.096691200 +0200
+@@ -62,7 +62,7 @@
+ # ifdef CONF_SYMBOL_VISIBILITY
+ # if defined PLATFORM_WINDOWS
+ # define LF_EXPORT __declspec(dllexport)
+-# elif defined CONF_COMPILER_GCC
++# elif defined CONF_COMPILER_GCC || __clang__
+ # define LF_EXPORT __attribute__((visibility("default")))
+ # else
+ # error "I don't know how to change symbol visibility for your compiler"
diff --git a/media-libs/lensfun/lensfun-0.2.8-r1.ebuild b/media-libs/lensfun/lensfun-0.2.8-r1.ebuild
index f8e42e0237d9..60f58ed49487 100644
--- a/media-libs/lensfun/lensfun-0.2.8-r1.ebuild
+++ b/media-libs/lensfun/lensfun-0.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.8-r1.ebuild,v 1.1 2014/07/20 18:17:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.8-r1.ebuild,v 1.2 2014/09/14 09:05:46 maekke Exp $
EAPI=5
@@ -28,6 +28,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=(
"${FILESDIR}"/${PF}-build.patch
"${FILESDIR}"/${P}-x32.patch
+ "${FILESDIR}"/${P}-support-clang-visibility-as-gcc.patch
)
DOCS=( README docs/mounts.txt )