summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2014-07-20 18:17:10 +0000
committerMarkus Meier <maekke@gentoo.org>2014-07-20 18:17:10 +0000
commit4fe7a69c9961ea00c65a956e1a02310a1cbac686 (patch)
treee463567f7c5e1917474d4b54444a7f7687c58864 /media-libs/lensfun
parentVersion bump (bug #504216). (diff)
downloadgentoo-2-4fe7a69c9961ea00c65a956e1a02310a1cbac686.tar.gz
gentoo-2-4fe7a69c9961ea00c65a956e1a02310a1cbac686.tar.bz2
gentoo-2-4fe7a69c9961ea00c65a956e1a02310a1cbac686.zip
do not modify header file install destination path by disposable in bug #500696, drop python2.6 support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 072AD062)
Diffstat (limited to 'media-libs/lensfun')
-rw-r--r--media-libs/lensfun/ChangeLog9
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.8-r1-build.patch27
-rw-r--r--media-libs/lensfun/lensfun-0.2.8-r1.ebuild48
3 files changed, 83 insertions, 1 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index f9e6aba73cf5..9b483b0acd95 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.67 2014/06/19 18:16:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.68 2014/07/20 18:17:10 maekke Exp $
+
+*lensfun-0.2.8-r1 (20 Jul 2014)
+
+ 20 Jul 2014; Markus Meier <maekke@gentoo.org> +lensfun-0.2.8-r1.ebuild,
+ +files/lensfun-0.2.8-r1-build.patch:
+ do not modify header file install destination path by disposable in bug
+ #500696, drop python2.6 support
19 Jun 2014; Markus Meier <maekke@gentoo.org> lensfun-0.2.8.ebuild:
arm stable, bug #513336
diff --git a/media-libs/lensfun/files/lensfun-0.2.8-r1-build.patch b/media-libs/lensfun/files/lensfun-0.2.8-r1-build.patch
new file mode 100644
index 000000000000..452de6865a8c
--- /dev/null
+++ b/media-libs/lensfun/files/lensfun-0.2.8-r1-build.patch
@@ -0,0 +1,27 @@
+diff -ru lensfun-0.2.8.orig/CMakeLists.txt lensfun-0.2.8/CMakeLists.txt
+--- lensfun-0.2.8.orig/CMakeLists.txt 2013-12-18 23:15:40.496926617 +0100
++++ lensfun-0.2.8/CMakeLists.txt 2013-12-18 23:18:12.289679316 +0100
+@@ -74,14 +74,9 @@
+
+ # define destination dirs (relative to prefix)
+ SET(BINDIR bin CACHE PATH "Directory for library example programs")
+-SET(LIBDIR lib${LIB_SUFFIX} CACHE PATH "Directory for library itself")
+ SET(INCLUDEDIR include CACHE PATH "Directory for library header files")
+ SET(DATADIR share/lensfun CACHE PATH "Directory for library data files")
+
+-IF(BUILD_DOC)
+- SET(DOCDIR share/doc/lensfun-${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX} CACHE PATH "Directory to put library documentation in")
+-ENDIF(BUILD_DOC)
+-
+ IF(WIN32)
+ # install into place in build-dir
+ SET(LENSFUN_INSTALL_PREFIX "${SOURCE_BASE_DIR}/lensfun" CACHE PATH "Install prefix for lensfun")
+diff -ru lensfun-0.2.8.orig/docs/CMakeLists.txt lensfun-0.2.8/docs/CMakeLists.txt
+--- lensfun-0.2.8.orig/docs/CMakeLists.txt 2013-12-18 23:15:40.496926617 +0100
++++ lensfun-0.2.8/docs/CMakeLists.txt 2013-12-18 23:19:27.578052651 +0100
+@@ -20,4 +20,4 @@
+ )
+
+ # install documentation
+-INSTALL(DIRECTORY ${CMAKE_DOC_OUT}/ DESTINATION ${DOCDIR})
++INSTALL(DIRECTORY "${CMAKE_BINARY_DIR}/doc_doxygen/" DESTINATION ${DOCDIR})
diff --git a/media-libs/lensfun/lensfun-0.2.8-r1.ebuild b/media-libs/lensfun/lensfun-0.2.8-r1.ebuild
new file mode 100644
index 000000000000..f8e42e0237d9
--- /dev/null
+++ b/media-libs/lensfun/lensfun-0.2.8-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.8-r1.ebuild,v 1.1 2014/07/20 18:17:10 maekke Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib python-single-r1 cmake-utils
+
+DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens distortions"
+HOMEPAGE="http://lensfun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3 CC-BY-SA-3.0" # See README for reasoning.
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc sse sse2"
+
+RDEPEND=">=dev-libs/glib-2.28
+ media-libs/libpng:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/${PF}-build.patch
+ "${FILESDIR}"/${P}-x32.patch
+)
+
+DOCS=( README docs/mounts.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ -DLIBDIR=$(get_libdir)
+ -DBUILD_AUXFUN=ON
+ $(cmake-utils_use_build doc)
+ $(cmake-utils_use_build sse FOR_SSE)
+ $(cmake-utils_use_build sse2 FOR_SSE2)
+ -DBUILD_STATIC=OFF
+ -DBUILD_TESTS=OFF
+ )
+
+ cmake-utils_src_configure
+}