summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-11-01 14:39:18 +0000
committerNed Ludd <solar@gentoo.org>2005-11-01 14:39:18 +0000
commitc0e96273793080e1309cc0de62731aceb99de93b (patch)
tree0c08924c48a22c5d383c2cad5dcb4ae358c3f291 /media-libs/libdv/libdv-0.104-r1.ebuild
parentFixed dodoc not to install COPYING and/or INSTALL. (diff)
downloadgentoo-2-c0e96273793080e1309cc0de62731aceb99de93b.tar.gz
gentoo-2-c0e96273793080e1309cc0de62731aceb99de93b.tar.bz2
gentoo-2-c0e96273793080e1309cc0de62731aceb99de93b.zip
- x86 pic fix that allows us to not have to use the --disable-asm while still retaining proper pic shared objects
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'media-libs/libdv/libdv-0.104-r1.ebuild')
-rw-r--r--media-libs/libdv/libdv-0.104-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/libdv/libdv-0.104-r1.ebuild b/media-libs/libdv/libdv-0.104-r1.ebuild
new file mode 100644
index 000000000000..0d06493b2601
--- /dev/null
+++ b/media-libs/libdv/libdv-0.104-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdv/libdv-0.104-r1.ebuild,v 1.1 2005/11/01 14:39:18 solar Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Software codec for dv-format video (camcorders etc)"
+HOMEPAGE="http://libdv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz mirror://gentoo/libdv-0.104-pic-fix.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~sparc ~x86"
+IUSE="debug gtk sdl xv"
+
+RDEPEND="dev-libs/popt
+ gtk? ( =x11-libs/gtk+-1.2* )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ xv? ( virtual/x11 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.99-2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.104-amd64reloc.patch
+ epatch "${FILESDIR}"/${PN}-0.104-no-exec-stack.patch
+ # big patch.. test here hard and fast then push upstream
+ epatch "${WORKDIR}"/libdv-0.104-pic-fix.patch
+
+ epunt_cxx #74497
+}
+
+src_compile() {
+ econf \
+ $(use_with debug) \
+ $(use_enable gtk) $(use_enable gtk gtktest) \
+ $(use_enable sdl) \
+ $(use_enable xv) \
+ || die "econf failed"
+ make || die "compile problem"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README* TODO
+}