summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-04-11 09:47:09 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-04-11 09:47:09 +0000
commitb84e4c7c00f2cbd1ea8029199c221501621141f9 (patch)
treeab8d6cc7b93f447d93f109ed6b8aa26faef49c4c /media-libs/libharu/libharu-2.2.1-r1.ebuild
parentDe-slot media-libs/libharu (diff)
downloadgentoo-2-b84e4c7c00f2cbd1ea8029199c221501621141f9.tar.gz
gentoo-2-b84e4c7c00f2cbd1ea8029199c221501621141f9.tar.bz2
gentoo-2-b84e4c7c00f2cbd1ea8029199c221501621141f9.zip
Remove .la file, unslot, drop old
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libharu/libharu-2.2.1-r1.ebuild')
-rw-r--r--media-libs/libharu/libharu-2.2.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libharu/libharu-2.2.1-r1.ebuild b/media-libs/libharu/libharu-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..6b7faf55866f
--- /dev/null
+++ b/media-libs/libharu/libharu-2.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libharu/libharu-2.2.1-r1.ebuild,v 1.1 2012/04/11 09:47:09 xarthisius Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+DESCRIPTION="C/C++ library for PDF generation"
+HOMEPAGE="http://www.libharu.org/"
+SRC_URI="http://libharu.org/files/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="png static-libs zlib"
+
+DEPEND="
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng-1.5.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with png) \
+ $(use_with zlib)
+}
+
+src_install() {
+ emake \
+ INSTALL_STRIP_FLAG="" \
+ DESTDIR="${D}" install
+ dodoc README
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/libhpdf.la
+}