summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2014-11-29 13:00:23 +0000
committerAkinori Hattori <hattya@gentoo.org>2014-11-29 13:00:23 +0000
commita4502d4de262d6ad1cabd7b64bd26c6b143733a7 (patch)
tree5df561898df245cd8fb7d8f1c378ccf4f2e23bc3 /media-libs/libsixel
parentAllow building of high resolution tool rfsplat-hd (bug #482476). Thanks for r... (diff)
downloadgentoo-2-a4502d4de262d6ad1cabd7b64bd26c6b143733a7.tar.gz
gentoo-2-a4502d4de262d6ad1cabd7b64bd26c6b143733a7.tar.bz2
gentoo-2-a4502d4de262d6ad1cabd7b64bd26c6b143733a7.zip
new upstream release
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key EC917A6D)
Diffstat (limited to 'media-libs/libsixel')
-rw-r--r--media-libs/libsixel/ChangeLog7
-rw-r--r--media-libs/libsixel/libsixel-1.3.6.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/media-libs/libsixel/ChangeLog b/media-libs/libsixel/ChangeLog
index 05ffa85f9c87..a03b6bee5a95 100644
--- a/media-libs/libsixel/ChangeLog
+++ b/media-libs/libsixel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsixel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsixel/ChangeLog,v 1.6 2014/11/22 12:28:14 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsixel/ChangeLog,v 1.7 2014/11/29 13:00:23 hattya Exp $
+
+*libsixel-1.3.6 (29 Nov 2014)
+
+ 29 Nov 2014; Akinori Hattori <hattya@gentoo.org> +libsixel-1.3.6.ebuild:
+ new upstream release
*libsixel-1.3.5 (22 Nov 2014)
diff --git a/media-libs/libsixel/libsixel-1.3.6.ebuild b/media-libs/libsixel/libsixel-1.3.6.ebuild
new file mode 100644
index 000000000000..f3912dadbdd2
--- /dev/null
+++ b/media-libs/libsixel/libsixel-1.3.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsixel/libsixel-1.3.6.ebuild,v 1.1 2014/11/29 13:00:23 hattya Exp $
+
+EAPI="5"
+
+inherit bash-completion-r1
+
+DESCRIPTION="A lightweight, fast implementation of DEC SIXEL graphics codec"
+HOMEPAGE="https://github.com/saitoha/libsixel"
+SRC_URI="https://github.com/saitoha/libsixel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl gd gtk jpeg png zsh-completion"
+
+RDEPEND="curl? ( net-misc/curl )
+ gd? ( media-libs/gd )
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng )
+ zsh-completion? ( app-shells/zsh )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-bashcompletiondir=$(get_bashcompdir) \
+ $(use_with curl libcurl) \
+ $(use_with gd) \
+ $(use_with gtk gdk-pixbuf2) \
+ $(use_with jpeg) \
+ $(use_with png)
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/images
+ dodoc -r images
+
+ use zsh-completion || rm -rf "${ED}"/usr/share/zsh
+}