summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-03-14 15:24:40 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-03-14 15:24:40 +0000
commit70044ec1569dfc8a78252181baae10ce05cafcd1 (patch)
tree66c9732bce5378c886eac74f80ebe2655251bc33 /media-libs/opengtl
parentStable for ppc64, wrt bug #461242 (diff)
downloadgentoo-2-70044ec1569dfc8a78252181baae10ce05cafcd1.tar.gz
gentoo-2-70044ec1569dfc8a78252181baae10ce05cafcd1.tar.bz2
gentoo-2-70044ec1569dfc8a78252181baae10ce05cafcd1.zip
Version bump wrt bug #460930, fixing bug #453420. Fix underlinking wrt bug #450160. Don't strip RPATH created after linking since LLVM libraries are not in the standard search path. Restrict tests wrt bug #377995. Remove old.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'media-libs/opengtl')
-rw-r--r--media-libs/opengtl/ChangeLog11
-rw-r--r--media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch30
-rw-r--r--media-libs/opengtl/opengtl-0.9.17.ebuild4
-rw-r--r--media-libs/opengtl/opengtl-0.9.18.ebuild (renamed from media-libs/opengtl/opengtl-0.9.16.ebuild)21
4 files changed, 57 insertions, 9 deletions
diff --git a/media-libs/opengtl/ChangeLog b/media-libs/opengtl/ChangeLog
index d3e79e65551c..29e2b0f87f6b 100644
--- a/media-libs/opengtl/ChangeLog
+++ b/media-libs/opengtl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-libs/opengtl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/ChangeLog,v 1.15 2013/02/19 18:05:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/ChangeLog,v 1.16 2013/03/14 15:24:40 kensington Exp $
+
+*opengtl-0.9.18 (14 Mar 2013)
+
+ 14 Mar 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/opengtl-0.9.18-underlinking.patch, +opengtl-0.9.18.ebuild,
+ -opengtl-0.9.16.ebuild, opengtl-0.9.17.ebuild:
+ Version bump wrt bug #460930, fixing bug #453420. Fix underlinking wrt bug
+ #450160. Don't strip RPATH created after linking since LLVM libraries are not
+ in the standard search path. Restrict tests wrt bug #377995. Remove old.
19 Feb 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
opengtl-0.9.17.ebuild:
diff --git a/media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch b/media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch
new file mode 100644
index 000000000000..6e6d1bda0af9
--- /dev/null
+++ b/media-libs/opengtl/files/opengtl-0.9.18-underlinking.patch
@@ -0,0 +1,30 @@
+changeset: 1792:99a2017746c0
+tag: tip
+user: Michael Palimaka <kensington@gentoo.org>
+date: Wed Jan 30 05:28:12 2013 +1100
+summary: Fix underlinking.
+
+diff -r e150672a54ad -r 99a2017746c0 OpenGTL/GTLCore/CMakeLists.txt
+--- a/OpenGTL/GTLCore/CMakeLists.txt Sat Dec 29 12:27:12 2012 +0100
++++ b/OpenGTL/GTLCore/CMakeLists.txt Wed Jan 30 05:28:12 2013 +1100
+@@ -10,6 +10,10 @@
+
+ ## GTLCore library ##
+
++if(PTHREAD_FOUND)
++ set(GTLCore_Thread_LIBS pthread)
++endif(PTHREAD_FOUND)
++
+ set(GTLCore_SRCS
+ AbstractColorConverter.cpp
+ AbstractImage.cpp
+@@ -110,7 +114,7 @@
+ set(EXTRA_GTLCORE_LINK_OPTIONS -Wl,-u,__ZTVN4llvm3JITE )
+ endif()
+
+-target_link_libraries(GTLCore ${LLVM_LDFLAGS} ${LLVM_LIBS} ${EXTRA_GTLCORE_LINK_OPTIONS})
++target_link_libraries(GTLCore ${LLVM_LDFLAGS} ${LLVM_LIBS} ${GTLCore_Thread_LIBS} ${EXTRA_GTLCORE_LINK_OPTIONS})
+
+ # Set the ABI version of the library
+ set_target_properties(GTLCore PROPERTIES VERSION ${OPENGTL_LIB_VERSION} SOVERSION ${OPENGTL_LIB_SOVERSION} )
+
diff --git a/media-libs/opengtl/opengtl-0.9.17.ebuild b/media-libs/opengtl/opengtl-0.9.17.ebuild
index dfa88340cbb9..78a814c215b9 100644
--- a/media-libs/opengtl/opengtl-0.9.17.ebuild
+++ b/media-libs/opengtl/opengtl-0.9.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/opengtl-0.9.17.ebuild,v 1.4 2013/02/19 18:05:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/opengtl-0.9.17.ebuild,v 1.5 2013/03/14 15:24:40 kensington Exp $
EAPI=4
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
test? ( dev-util/lcov )
"
+RESTRICT="test"
+
S=${WORKDIR}/${MY_P}
PATCHES=(
diff --git a/media-libs/opengtl/opengtl-0.9.16.ebuild b/media-libs/opengtl/opengtl-0.9.18.ebuild
index 728a4164878c..da9c1d631679 100644
--- a/media-libs/opengtl/opengtl-0.9.16.ebuild
+++ b/media-libs/opengtl/opengtl-0.9.18.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/opengtl-0.9.16.ebuild,v 1.4 2012/09/24 11:41:31 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opengtl/opengtl-0.9.18.ebuild,v 1.1 2013/03/14 15:24:40 kensington Exp $
-EAPI=4
+EAPI=5
MY_P="OpenGTL-${PV}"
@@ -14,22 +14,29 @@ SRC_URI="http://download.opengtl.org/${MY_P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~arm ~x86"
IUSE="debug test"
RDEPEND="
- media-libs/libpng
- =sys-devel/llvm-3.0*
- sys-libs/zlib
+ media-libs/libpng:0
+ >=sys-devel/llvm-3.1
+ <sys-devel/llvm-3.3
"
DEPEND="${RDEPEND}
test? ( dev-util/lcov )
"
+RESTRICT="test"
+
S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.18-underlinking.patch"
+)
+
src_configure() {
local mycmakeargs=(
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE
$(cmake-utils_use debug OPENGTL_ENABLE_DEBUG_OUTPUT)
$(cmake-utils_use test OPENGTL_BUILD_TESTS)
$(cmake-utils_use test OPENGTL_CODE_COVERAGE)