summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-07-30 17:03:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-07-30 17:03:27 +0000
commit15f96c9e25a2a92e46c5a299d6ff46dde9040bae (patch)
tree7eb466d7590f2bf318e896e0f0165c7c3ac6a888 /media-libs/sdl-mixer
parentDrop one more place where wrapper.in was used. (diff)
downloadgentoo-2-15f96c9e25a2a92e46c5a299d6ff46dde9040bae.tar.gz
gentoo-2-15f96c9e25a2a92e46c5a299d6ff46dde9040bae.tar.bz2
gentoo-2-15f96c9e25a2a92e46c5a299d6ff46dde9040bae.zip
add multilib patch from Nathan Phillip (bug #376717
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'media-libs/sdl-mixer')
-rw-r--r--media-libs/sdl-mixer/ChangeLog8
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.11-multilib.patch25
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.11-r1.ebuild8
3 files changed, 37 insertions, 4 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index fdec5387bcff..04638ba03947 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/sdl-mixer
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.81 2010/07/27 05:25:15 mr_bones_ Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.82 2011/07/30 17:03:27 mr_bones_ Exp $
+
+ 30 Jul 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ sdl-mixer-1.2.11-r1.ebuild, +files/sdl-mixer-1.2.11-multilib.patch:
+ add multilib patch from Nathan Phillip (bug #376717)
27 Jul 2010; Michael Sterrett <mr_bones_@gentoo.org>
sdl-mixer-1.2.11-r1.ebuild:
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.11-multilib.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.11-multilib.patch
new file mode 100644
index 000000000000..2e6d6d5ceb63
--- /dev/null
+++ b/media-libs/sdl-mixer/files/sdl-mixer-1.2.11-multilib.patch
@@ -0,0 +1,25 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Date: 2011-07-28
+Subject: Fix linking to respect CFLAGS and LDFLAGS properly, fixing a
+ compilation bug (https://bugs.gentoo.org/376717) on
+ portage-multilib.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -72,13 +72,13 @@
+ @PLAYMUS_DEPENDS@
+
+ $(objects)/$(TARGET): $(OBJECTS) $(VERSION_OBJECTS)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(OBJECTS) $(VERSION_OBJECTS) $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS)
++ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) -o $@ $(OBJECTS) $(VERSION_OBJECTS)
+
+ $(objects)/playwave$(EXE): $(objects)/playwave.lo $(objects)/$(TARGET)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(objects)/playwave.lo $(SDL_CFLAGS) $(SDL_LIBS) $(objects)/$(TARGET)
++ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(objects)/playwave.lo $(SDL_CFLAGS) $(SDL_LIBS) $(objects)/$(TARGET)
+
+ $(objects)/playmus$(EXE): $(objects)/playmus.lo $(objects)/$(TARGET)
+- $(LIBTOOL) --mode=link $(CC) -o $@ $(objects)/playmus.lo $(SDL_CFLAGS) $(SDL_LIBS) $(objects)/$(TARGET)
++ $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(objects)/playmus.lo $(SDL_CFLAGS) $(SDL_LIBS) $(objects)/$(TARGET)
+
+ install: all install-hdrs install-lib #install-bin
+ install-hdrs:
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.11-r1.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.11-r1.ebuild
index 231e56af96be..9f854d5a8553 100644
--- a/media-libs/sdl-mixer/sdl-mixer-1.2.11-r1.ebuild
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.11-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.11-r1.ebuild,v 1.8 2010/07/27 05:25:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.11-r1.ebuild,v 1.9 2011/07/30 17:03:27 mr_bones_ Exp $
EAPI=2
inherit eutils
@@ -25,6 +25,10 @@ DEPEND=">=media-libs/libsdl-1.2.10
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-multilib.patch
+}
+
src_configure() {
econf \
--disable-dependency-tracking \