summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-24 12:07:21 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-24 12:07:21 +0000
commit93dc9c7be71b6c5ae8cbf62334bd3e21e4c265b4 (patch)
treef634e0e3e370f7de1f22e9ad3d3c7128ebbd0434 /media-libs/sk1libs
parentStable on amd64, wrt bug #452078 (diff)
downloadgentoo-2-93dc9c7be71b6c5ae8cbf62334bd3e21e4c265b4.tar.gz
gentoo-2-93dc9c7be71b6c5ae8cbf62334bd3e21e4c265b4.tar.bz2
gentoo-2-93dc9c7be71b6c5ae8cbf62334bd3e21e4c265b4.zip
media-libs/sk1libs: Fix problems with double prefixes reported by Johan Hattne
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'media-libs/sk1libs')
-rw-r--r--media-libs/sk1libs/ChangeLog7
-rw-r--r--media-libs/sk1libs/sk1libs-0.9.1-r3.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/media-libs/sk1libs/ChangeLog b/media-libs/sk1libs/ChangeLog
index bf1d9f2375ab..becb873a8009 100644
--- a/media-libs/sk1libs/ChangeLog
+++ b/media-libs/sk1libs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sk1libs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sk1libs/ChangeLog,v 1.19 2013/04/18 06:35:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sk1libs/ChangeLog,v 1.20 2013/04/24 12:07:21 jlec Exp $
+
+*sk1libs-0.9.1-r3 (24 Apr 2013)
+
+ 24 Apr 2013; Justin Lecher <jlec@gentoo.org> +sk1libs-0.9.1-r3.ebuild:
+ Fix problems with double prefixes reported by Johan Hattne
*sk1libs-0.9.1-r2 (18 Apr 2013)
diff --git a/media-libs/sk1libs/sk1libs-0.9.1-r3.ebuild b/media-libs/sk1libs/sk1libs-0.9.1-r3.ebuild
new file mode 100644
index 000000000000..60eb27da16c1
--- /dev/null
+++ b/media-libs/sk1libs/sk1libs-0.9.1-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sk1libs/sk1libs-0.9.1-r3.ebuild,v 1.1 2013/04/24 12:07:21 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_8,1_9} )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="sk1 vector graphics lib"
+HOMEPAGE="http://sk1project.org"
+SRC_URI="http://uniconvertor.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ media-fonts/ttf-bitstream-vera
+ media-libs/freetype:2
+ virtual/jpeg
+ >=media-libs/lcms-1.15:0[python]
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}
+ app-arch/bzip2
+ app-arch/gzip
+ app-text/ghostscript-gpl
+ media-libs/netpbm
+"
+
+python_prepare_all() {
+ sed \
+ -e "/include_dirs/s:\(/usr/include/freetype2\):${EPREFIX}\1:" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ font-fixation() {
+ local ttf
+ local sitedir=$(python_get_sitedir)
+ for ttf in "${ED}"/${sitedir#${EPREFIX}}/sk1libs/ft2engine/fallback_fonts/*.ttf; do
+ rm -f "${ttf}" || die
+ dosym \
+ /usr/share/fonts/ttf-bitstream-vera/$(basename "${ttf}") \
+ ${sitedir#${EPREFIX}}/sk1libs/ft2engine/fallback_fonts/$(basename "${ttf}")
+ done
+ }
+ python_foreach_impl font-fixation
+
+ distutils-r1_python_install_all
+}