summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-01 23:34:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-01 23:34:07 +0000
commit0e5841cc20d89bf7e838982638602a6c8468c6a7 (patch)
tree26f5ea53f904634b5340cb10dcc604ae408d9c2f /media-libs/tunepimp
parentRemoved conflicts with x11-misc/shared-mime-info noted by bug 99900 (diff)
downloadgentoo-2-0e5841cc20d89bf7e838982638602a6c8468c6a7.tar.gz
gentoo-2-0e5841cc20d89bf7e838982638602a6c8468c6a7.tar.bz2
gentoo-2-0e5841cc20d89bf7e838982638602a6c8468c6a7.zip
Replace -lthr with -lpthread, else amarok dies on Gentoo/FreeBSD.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/tunepimp')
-rw-r--r--media-libs/tunepimp/ChangeLog6
-rw-r--r--media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild13
2 files changed, 15 insertions, 4 deletions
diff --git a/media-libs/tunepimp/ChangeLog b/media-libs/tunepimp/ChangeLog
index 5ea6d0a2102a..1d2ca1d9cc8c 100644
--- a/media-libs/tunepimp/ChangeLog
+++ b/media-libs/tunepimp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/tunepimp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.25 2005/07/02 00:16:48 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.26 2005/08/01 23:34:07 flameeyes Exp $
+
+ 01 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ tunepimp-0.3.0-r1.ebuild:
+ Replace -lthr with -lpthread, else amarok dies on Gentoo/FreeBSD.
02 Jul 2005; Hardave Riar <hardave@gentoo.org> tunepimp-0.3.0.ebuild:
Stable on mips
diff --git a/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild b/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild
index 0de2c4ff89c6..d981f0d4b9f5 100644
--- a/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild
+++ b/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild,v 1.11 2005/06/17 20:38:43 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild,v 1.12 2005/08/01 23:34:07 flameeyes Exp $
inherit eutils distutils perl-module
@@ -25,11 +25,18 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/lib${P}
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/thread.patch
+
# do not try to link against obsolete libtermcap
sed -i -e 's,-ltermcap,-lncurses,' configure
+ sed -i -e 's:-lthr:-lpthread:g' ${S}/lib/threads/posix/Makefile.in
+}
- epatch ${FILESDIR}/thread.patch
+src_compile() {
econf || die "configure failed"
emake || die "emake failed"
if use perl; then