summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
commite4f208dd887e639fdac3f8a599c7c06cac41dde1 (patch)
tree59db30fcd642a5476b02fdfb3a3ff5fd7dc18f2f /media-plugins/mythvideo
parentIntroduced CVS snapshot (diff)
downloadgentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.gz
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.bz2
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.zip
Version bump
Diffstat (limited to 'media-plugins/mythvideo')
-rw-r--r--media-plugins/mythvideo/ChangeLog7
-rw-r--r--media-plugins/mythvideo/Manifest2
-rw-r--r--media-plugins/mythvideo/files/digest-mythvideo-0.141
-rw-r--r--media-plugins/mythvideo/mythvideo-0.14.ebuild62
4 files changed, 71 insertions, 1 deletions
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
index 800b83e88c52..8444a73d041d 100644
--- a/media-plugins/mythvideo/ChangeLog
+++ b/media-plugins/mythvideo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythvideo
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.9 2004/01/15 18:05:03 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.10 2004/02/03 13:51:53 aliz Exp $
+
+*mythvideo-0.14 (03 Feb 2004)
+
+ 03 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> mythvideo-0.14.ebuild:
+ Version bump
15 Jan 2004; Max Kalika <max@gentoo.org> mythvideo-0.13.ebuild:
Bump to stable x86.
diff --git a/media-plugins/mythvideo/Manifest b/media-plugins/mythvideo/Manifest
index 1e0f61913b04..832711a3eb76 100644
--- a/media-plugins/mythvideo/Manifest
+++ b/media-plugins/mythvideo/Manifest
@@ -1,4 +1,5 @@
MD5 711c93bf7418cb1d2577e5b6204ac10e mythvideo-0.12.ebuild 1766
+MD5 38660fe948cdfa5b3522cf697fed3664 mythvideo-0.14.ebuild 1766
MD5 db1b0ed067864987f267f21c870f037b mythvideo-0.11.ebuild 1749
MD5 38660fe948cdfa5b3522cf697fed3664 mythvideo-0.13.ebuild 1766
MD5 6a449e83c27e7ae3a548b451076e666a ChangeLog 2303
@@ -6,3 +7,4 @@ MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 1c1055ed7527e3c6e5c556e1f79456bc files/digest-mythvideo-0.11 67
MD5 8b1f40b48872fd36d6dfd997ee675a30 files/digest-mythvideo-0.12 67
MD5 a8800f5c5151851b8e57a6a777fde3b0 files/digest-mythvideo-0.13 67
+MD5 51fbad420f3d94ef8747f16c24ee8c18 files/digest-mythvideo-0.14 67
diff --git a/media-plugins/mythvideo/files/digest-mythvideo-0.14 b/media-plugins/mythvideo/files/digest-mythvideo-0.14
new file mode 100644
index 000000000000..4d8b81e7e736
--- /dev/null
+++ b/media-plugins/mythvideo/files/digest-mythvideo-0.14
@@ -0,0 +1 @@
+MD5 aaaa60b11db1c76acacffc1185c7d9d6 mythvideo-0.14.tar.bz2 241309
diff --git a/media-plugins/mythvideo/mythvideo-0.14.ebuild b/media-plugins/mythvideo/mythvideo-0.14.ebuild
new file mode 100644
index 000000000000..26bfe5e79fa9
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Video player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( media-video/mplayer media-video/xine-ui )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins videodb/*.sql
+
+ dodoc COPYING README UPGRADING
+ newdoc videodb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythVideo,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}