summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-03-25 11:51:03 +0000
committerTony Vroon <chainsaw@gentoo.org>2015-03-25 11:51:03 +0000
commit9c1b40712b64eee7da2a616d24404468cc5be144 (patch)
treedd69ca4919b693fd84eee15f86286ced569396e9 /media-sound/alsa-tools
parentVersion bump, as requested by Manuel Rüger in bug #541798. (diff)
downloadgentoo-2-9c1b40712b64eee7da2a616d24404468cc5be144.tar.gz
gentoo-2-9c1b40712b64eee7da2a616d24404468cc5be144.tar.bz2
gentoo-2-9c1b40712b64eee7da2a616d24404468cc5be144.zip
Version bump, as requested by Manuel Rüger in bug #541798.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'media-sound/alsa-tools')
-rw-r--r--media-sound/alsa-tools/ChangeLog9
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.0.29.ebuild143
2 files changed, 150 insertions, 2 deletions
diff --git a/media-sound/alsa-tools/ChangeLog b/media-sound/alsa-tools/ChangeLog
index b4a65bb98a18..3ceccfecb81c 100644
--- a/media-sound/alsa-tools/ChangeLog
+++ b/media-sound/alsa-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-tools
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.229 2014/11/23 14:57:56 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.230 2015/03/25 11:51:03 chainsaw Exp $
+
+*alsa-tools-1.0.29 (25 Mar 2015)
+
+ 25 Mar 2015; Tony Vroon <chainsaw@gentoo.org> +alsa-tools-1.0.29.ebuild:
+ Version bump, as requested by Manuel Rüger in bug #541798.
23 Nov 2014; Agostino Sarubbo <ago@gentoo.org> alsa-tools-1.0.28.ebuild:
Stable for sparc, wrt bug #522038
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.29.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.29.ebuild
new file mode 100644
index 000000000000..067ba1448cc1
--- /dev/null
+++ b/media-sound/alsa-tools/alsa-tools-1.0.29.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.29.ebuild,v 1.1 2015/03/25 11:51:03 chainsaw Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Advanced Linux Sound Architecture tools"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="fltk gtk alsa_cards_hdsp alsa_cards_hdspm alsa_cards_mixart
+alsa_cards_vx222 alsa_cards_usb-usx2y alsa_cards_sb16 alsa_cards_sbawe
+alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_ice1712
+alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sscape alsa_cards_pcxhr"
+
+COMMON_DEPEND=">=media-libs/alsa-lib-${PV}
+ >=dev-python/pyalsa-1.0.26
+ fltk? ( >=x11-libs/fltk-1.3.0:1 )
+ gtk? (
+ >=dev-python/pygtk-2
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ )" #468294
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( media-fonts/font-misc-misc )" #456114
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ ALSA_TOOLS="seq/sbiload us428control hwmixvolume hda-verb"
+
+ if use gtk; then
+ ALSA_TOOLS="${ALSA_TOOLS} hdajackretask"
+ use alsa_cards_ice1712 && \
+ ALSA_TOOLS="${ALSA_TOOLS} envy24control"
+ use alsa_cards_rme32 && use alsa_cards_rme96 && \
+ ALSA_TOOLS="${ALSA_TOOLS} rmedigicontrol"
+ fi
+
+ if use alsa_cards_hdsp || use alsa_cards_hdspm; then
+ ALSA_TOOLS="${ALSA_TOOLS} hdsploader"
+ use fltk && ALSA_TOOLS="${ALSA_TOOLS} hdspconf hdspmixer"
+ fi
+
+ use alsa_cards_mixart && ALSA_TOOLS="${ALSA_TOOLS} mixartloader"
+ use alsa_cards_vx222 && ALSA_TOOLS="${ALSA_TOOLS} vxloader"
+ use alsa_cards_usb-usx2y && ALSA_TOOLS="${ALSA_TOOLS} usx2yloader"
+ use alsa_cards_pcxhr && ALSA_TOOLS="${ALSA_TOOLS} pcxhr"
+ use alsa_cards_sscape && ALSA_TOOLS="${ALSA_TOOLS} sscape_ctl"
+
+ { use alsa_cards_sb16 || use alsa_cards_sbawe; } && \
+ ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
+
+ if use alsa_cards_emu10k1 || use alsa_cards_emu10k1x; then
+ ALSA_TOOLS="${ALSA_TOOLS} as10k1 ld10k1"
+ fi
+
+ use gtk && ALSA_TOOLS="${ALSA_TOOLS} echomixer"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/envy24control-config-dir.patch
+
+ epatch_user
+
+ # This block only deals with the tools that still use GTK and the
+ # AM_PATH_GTK macro.
+ for dir in echomixer envy24control rmedigicontrol; do
+ has "${dir}" "${ALSA_TOOLS}" || continue
+ pushd "${dir}" &> /dev/null
+ eautoreconf
+ popd &> /dev/null
+ done
+
+ # This block deals with the tools that are being patched
+ for dir in hdspconf; do
+ has "${dir}" "${ALSA_TOOLS}" || continue
+ pushd "${dir}" &> /dev/null
+ eautoreconf
+ popd &> /dev/null
+ done
+
+ elibtoolize
+}
+
+src_configure() {
+ if use fltk; then
+ # hdspmixer requires fltk
+ append-ldflags "-L$(dirname $(fltk-config --libs))"
+ append-flags "-I$(fltk-config --includedir)"
+ fi
+
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ cd "${S}/${f}"
+ case "${f}" in
+ echomixer,envy24control,rmedigicontrol )
+ econf --with-gtk2
+ ;;
+ * )
+ econf
+ ;;
+ esac
+ done
+}
+
+src_compile() {
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ cd "${S}/${f}"
+ emake
+ done
+}
+
+src_install() {
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ # Install the main stuff
+ cd "${S}/${f}"
+ # hotplugdir is for usx2yloader/Makefile.am
+ emake DESTDIR="${D}" hotplugdir=/lib/firmware install
+
+ # Install the text documentation
+ local doc
+ for doc in README TODO ChangeLog AUTHORS; do
+ if [[ -f "${doc}" ]]; then
+ mv "${doc}" "${doc}.$(basename ${f})" || die
+ dodoc "${doc}.$(basename ${f})"
+ fi
+ done
+ done
+
+ # Punt at least /usr/lib/liblo10k1.la (last checked, 1.0.27)
+ prune_libtool_files
+}