summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-12-05 23:26:40 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-12-05 23:26:40 +0000
commit47e62d37a161ca050819959978005f0269192657 (patch)
treedaee54ae68d8538803de69e8a7fd4df534a0200d /media-sound/banshee
parentVersion bump. (diff)
downloadgentoo-2-47e62d37a161ca050819959978005f0269192657.tar.gz
gentoo-2-47e62d37a161ca050819959978005f0269192657.tar.bz2
gentoo-2-47e62d37a161ca050819959978005f0269192657.zip
Fix metadata not being written to disk. http://bugzilla.gnome.org/563283. Author is thansen@freenode.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc6 x86_64)
Diffstat (limited to 'media-sound/banshee')
-rw-r--r--media-sound/banshee/ChangeLog9
-rw-r--r--media-sound/banshee/banshee-1.4.1-r1.ebuild106
-rw-r--r--media-sound/banshee/files/banshee-1.4.1-metadata-writefail.patch35
3 files changed, 149 insertions, 1 deletions
diff --git a/media-sound/banshee/ChangeLog b/media-sound/banshee/ChangeLog
index 44e3f8f4e7c4..27b0b7425181 100644
--- a/media-sound/banshee/ChangeLog
+++ b/media-sound/banshee/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/banshee
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.73 2008/11/23 16:03:12 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/ChangeLog,v 1.74 2008/12/05 23:26:40 loki_val Exp $
+
+*banshee-1.4.1-r1 (05 Dec 2008)
+
+ 05 Dec 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/banshee-1.4.1-metadata-writefail.patch, +banshee-1.4.1-r1.ebuild:
+ Fix metadata not being written to disk. http://bugzilla.gnome.org/563283.
+ Author is thansen@freenode.
23 Nov 2008; Peter Alfredsen <loki_val@gentoo.org> banshee-1.4.1.ebuild:
Add notice about a theme having to be selected for the user running
diff --git a/media-sound/banshee/banshee-1.4.1-r1.ebuild b/media-sound/banshee/banshee-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..4120e63f6d8e
--- /dev/null
+++ b/media-sound/banshee/banshee-1.4.1-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/banshee/banshee-1.4.1-r1.ebuild,v 1.1 2008/12/05 23:26:40 loki_val Exp $
+
+EAPI=1
+
+inherit base gnome2 mono autotools
+
+GVER=0.10.3
+
+DESCRIPTION="Import, organize, play, and share your music using a simple and powerful interface."
+HOMEPAGE="http://banshee-project.org"
+SRC_URI="http://download.banshee-project.org/${PN}/${PN}-1-${PV}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+aac +boo daap doc +encode +flac ipod +mad mtp +podcast test +vorbis"
+
+RDEPEND=">=dev-lang/mono-2
+ >=dev-dotnet/gtk-sharp-2.12
+ >=dev-dotnet/gconf-sharp-2.8
+ >=dev-dotnet/gnome-sharp-2.8
+ >=media-libs/gst-plugins-bad-${GVER}
+ >=media-libs/gst-plugins-good-${GVER}
+ >=media-libs/gst-plugins-ugly-${GVER}
+ >=media-plugins/gst-plugins-alsa-${GVER}
+ >=media-plugins/gst-plugins-gnomevfs-${GVER}
+ >=media-plugins/gst-plugins-gconf-${GVER}
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-${GVER}
+ >=media-plugins/gst-plugins-cdio-${GVER}
+ )
+ media-libs/musicbrainz:1
+ >=dev-dotnet/dbus-glib-sharp-0.3
+ >=dev-dotnet/dbus-sharp-0.5
+ >=dev-dotnet/mono-addins-0.3.1
+ >=dev-dotnet/taglib-sharp-2.0.3
+ >=dev-db/sqlite-3.4
+ aac? (
+ >=media-plugins/gst-plugins-faad-${GVER}
+ )
+ boo? (
+ >=dev-lang/boo-0.8.1
+ )
+ daap? (
+ >=dev-dotnet/mono-zeroconf-0.7.3
+ )
+ doc? (
+ dev-util/monodoc
+ )
+ encode? (
+ >=media-plugins/gst-plugins-lame-${GVER}
+ >=media-plugins/gst-plugins-taglib-${GVER}
+ )
+ flac? (
+ >=media-plugins/gst-plugins-flac-${GVER}
+ )
+ ipod? (
+ >=dev-dotnet/ipod-sharp-0.8.0
+ )
+ mad? (
+ >=media-plugins/gst-plugins-mad-${GVER}
+ )
+ mtp? (
+ media-libs/libmtp
+ )
+ vorbis? (
+ >=media-plugins/gst-plugins-ogg-${GVER}
+ >=media-plugins/gst-plugins-vorbis-${GVER}
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+S=${WORKDIR}/${PN}-1-${PV}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ #Upstream bug 563283
+ #Author is thansen on freenode.
+ epatch "${FILESDIR}/${P}-metadata-writefail.patch"
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable doc docs)
+ $(use_enable boo)
+ $(use_enable mtp)
+ $(use_enable daap)
+ $(use_enable ipod)
+ $(use_enable podcast)
+ $(use_enable test tests)
+ --enable-gnome
+ --enable-schemas-install
+ --with-gconf-schema-file-dir=/etc/gconf/schemas"
+
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "If banshee segfaults not long after being started, try running gnome-appearance-properties and select a theme."
+}
diff --git a/media-sound/banshee/files/banshee-1.4.1-metadata-writefail.patch b/media-sound/banshee/files/banshee-1.4.1-metadata-writefail.patch
new file mode 100644
index 000000000000..b7f1c3b8eb2b
--- /dev/null
+++ b/media-sound/banshee/files/banshee-1.4.1-metadata-writefail.patch
@@ -0,0 +1,35 @@
+--- src/Core/Banshee.Core/Banshee.Streaming/StreamTagger.cs 2008-10-06 10:27:31.000000000 -0600
++++ src/Core/Banshee.Core/Banshee.Streaming/StreamTagger.cs.new 2008-12-05 16:01:22.513964625 -0700
+@@ -130,7 +130,7 @@
+ track.ArtistName = Choose (file.Tag.JoinedPerformers, track.ArtistName, preferTrackInfo);
+ track.AlbumTitle = Choose (file.Tag.Album, track.AlbumTitle, preferTrackInfo);
+ track.AlbumArtist = Choose (file.Tag.FirstAlbumArtist, track.AlbumArtist, preferTrackInfo);
+- track.IsCompilation = IsCompilation (file.Tag);
++ track.IsCompilation = IsCompilation (file);
+
+ track.TrackTitle = Choose (file.Tag.Title, track.TrackTitle, preferTrackInfo);
+ track.Genre = Choose (file.Tag.FirstGenre, track.Genre, preferTrackInfo);
+@@ -171,18 +171,18 @@
+ // TODO these ideas could also be done in an extension that collects such hacks
+ }
+
+- private static bool IsCompilation (TagLib.Tag tag)
++ private static bool IsCompilation (TagLib.File file)
+ {
+- TagLib.Id3v2.Tag id3v2_tag = tag as TagLib.Id3v2.Tag;
++ TagLib.Id3v2.Tag id3v2_tag = file.GetTag(TagLib.TagTypes.Id3v2, true) as TagLib.Id3v2.Tag;
+ if (id3v2_tag != null && id3v2_tag.IsCompilation)
+ return true;
+
+- TagLib.Mpeg4.AppleTag apple_tag = tag as TagLib.Mpeg4.AppleTag;
++ TagLib.Mpeg4.AppleTag apple_tag = file.GetTag(TagLib.TagTypes.Apple,true) as TagLib.Mpeg4.AppleTag;
+ if (apple_tag != null && apple_tag.IsCompilation)
+ return true;
+
+- if (tag.Performers.Length > 0 && tag.AlbumArtists.Length > 0 &&
+- (tag.Performers.Length != tag.AlbumArtists.Length || tag.FirstAlbumArtist != tag.FirstPerformer)) {
++ if (file.Tag.Performers.Length > 0 && file.Tag.AlbumArtists.Length > 0 &&
++ (file.Tag.Performers.Length != file.Tag.AlbumArtists.Length || file.Tag.FirstAlbumArtist != file.Tag.FirstPerformer)) {
+ return true;
+ }
+ return false;