summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-04-18 17:22:50 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-04-18 17:22:50 +0000
commit97c5cffe9854d47f508bb4c09cea59ef46a37068 (patch)
tree47465dd557b6d3b5f7b1e1b330396878d4ab2176 /media-sound/clementine
parentFix segfault when being built without nethack support (bug #507916) (diff)
downloadgentoo-2-97c5cffe9854d47f508bb4c09cea59ef46a37068.tar.gz
gentoo-2-97c5cffe9854d47f508bb4c09cea59ef46a37068.tar.bz2
gentoo-2-97c5cffe9854d47f508bb4c09cea59ef46a37068.zip
Add patch for building with >=gcc-4.9, bug #507484. Thanks to Ryan Hill <rhill@gentoo.org>.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'media-sound/clementine')
-rw-r--r--media-sound/clementine/ChangeLog7
-rw-r--r--media-sound/clementine/clementine-1.2.2.ebuild3
-rw-r--r--media-sound/clementine/files/clementine-1.2.2-gcc49.patch17
3 files changed, 25 insertions, 2 deletions
diff --git a/media-sound/clementine/ChangeLog b/media-sound/clementine/ChangeLog
index c1d64e276c8d..1b41108bc8ca 100644
--- a/media-sound/clementine/ChangeLog
+++ b/media-sound/clementine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/clementine
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/ChangeLog,v 1.86 2014/03/12 13:19:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/ChangeLog,v 1.87 2014/04/18 17:22:50 maksbotan Exp $
+
+ 18 Apr 2014; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/clementine-1.2.2-gcc49.patch, clementine-1.2.2.ebuild:
+ Add patch for building with >=gcc-4.9, bug #507484. Thanks to Ryan Hill
+ <rhill@gentoo.org>.
*clementine-1.2.2 (12 Mar 2014)
diff --git a/media-sound/clementine/clementine-1.2.2.ebuild b/media-sound/clementine/clementine-1.2.2.ebuild
index 79889c55181b..ba48fb833ab1 100644
--- a/media-sound/clementine/clementine-1.2.2.ebuild
+++ b/media-sound/clementine/clementine-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/clementine-1.2.2.ebuild,v 1.1 2014/03/12 13:19:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/clementine/clementine-1.2.2.ebuild,v 1.2 2014/04/18 17:22:50 maksbotan Exp $
EAPI=5
@@ -93,6 +93,7 @@ S="${WORKDIR}/${P^}"
PATCHES=(
"${FILESDIR}"/${P}-fix-build.patch
"${FILESDIR}"/${P}-fix-build2.patch
+ "${FILESDIR}"/${P}-gcc49.patch
)
src_prepare() {
diff --git a/media-sound/clementine/files/clementine-1.2.2-gcc49.patch b/media-sound/clementine/files/clementine-1.2.2-gcc49.patch
new file mode 100644
index 000000000000..119298787a55
--- /dev/null
+++ b/media-sound/clementine/files/clementine-1.2.2-gcc49.patch
@@ -0,0 +1,17 @@
+In file included from ../../Clementine-1.2.2/src/core/mergedproxymodel.cpp:18:0:
+../../Clementine-1.2.2/src/core/mergedproxymodel.h:23:12: error: 'std::placeholders' has not been declared
+ using std::placeholders::_1;
+../../Clementine-1.2.2/src/core/mergedproxymodel.h:24:12: error: 'std::placeholders' has not been declared
+ using std::placeholders::_2;
+
+
+--- a/src/core/mergedproxymodel.h
++++ b/src/core/mergedproxymodel.h
+@@ -19,6 +19,7 @@
+ #define MERGEDPROXYMODEL_H
+
+ #include <QAbstractProxyModel>
++#include <functional>
+
+ using std::placeholders::_1;
+ using std::placeholders::_2;