summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-12-21 17:03:42 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-12-21 17:03:42 +0000
commit6eef7f77cc081be90343cfd84ed9dafa0897ca43 (patch)
tree2eb8879bb2271f0db63ea811597eab6f7e3c75cf /media-sound/mac
parentAdd ~sparc wrt #283235 (diff)
downloadgentoo-2-6eef7f77cc081be90343cfd84ed9dafa0897ca43.tar.gz
gentoo-2-6eef7f77cc081be90343cfd84ed9dafa0897ca43.tar.bz2
gentoo-2-6eef7f77cc081be90343cfd84ed9dafa0897ca43.zip
Update gcc-4.4 patch. Thanks to Yu Yuwei in bug #297721.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-sound/mac')
-rw-r--r--media-sound/mac/ChangeLog6
-rw-r--r--media-sound/mac/files/mac-3.99.4.5.4-gcc44.patch47
-rw-r--r--media-sound/mac/mac-3.99.4.5.4.ebuild4
3 files changed, 54 insertions, 3 deletions
diff --git a/media-sound/mac/ChangeLog b/media-sound/mac/ChangeLog
index 8b6ce71f9411..7f89acafa6a2 100644
--- a/media-sound/mac/ChangeLog
+++ b/media-sound/mac/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mac
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/ChangeLog,v 1.8 2009/12/20 20:31:00 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/ChangeLog,v 1.9 2009/12/21 17:03:42 billie Exp $
+
+ 21 Dec 2009; Daniel Pielmeier <billie@gentoo.org> mac-3.99.4.5.4.ebuild,
+ +files/mac-3.99.4.5.4-gcc44.patch:
+ Update gcc-4.4 patch. Thanks to Yu Yuwei in bug #297721.
20 Dec 2009; Daniel Pielmeier <billie@gentoo.org> mac-3.99.4.5.4.ebuild:
Fix epatch.
diff --git a/media-sound/mac/files/mac-3.99.4.5.4-gcc44.patch b/media-sound/mac/files/mac-3.99.4.5.4-gcc44.patch
new file mode 100644
index 000000000000..2d5ed3296728
--- /dev/null
+++ b/media-sound/mac/files/mac-3.99.4.5.4-gcc44.patch
@@ -0,0 +1,47 @@
+diff -Nuar mac-3.99-u4-b5-s4-orig/src/MACLib/APECompressCreate.cpp mac-3.99-u4-b5-s4/src/MACLib/APECompressCreate.cpp
+--- mac-3.99-u4-b5-s4-orig/src/MACLib/APECompressCreate.cpp 2008-03-12 16:25:54.000000000 +0100
++++ mac-3.99-u4-b5-s4/src/MACLib/APECompressCreate.cpp 2009-12-21 17:44:59.000000000 +0100
+@@ -279,14 +279,14 @@
+ nDataSize = (((nNumberOfFrames - 1) * m_nSamplesPerFrame + nFinalFrameBlocks) * m_wfeInput.nBlockAlign);
+ for (i = 0; i < nHeaderBytes; i++)
+ {
+- if ((p = strstr((const char *)pHeaderData+i,"RIFF"))) {
++ if ((p = strstr((char *)pHeaderData+i,"RIFF"))) {
+ ULONG_TO_UCHAR_LE((unsigned char *)p+4,nDataSize + nHeaderBytes - 8);
+ break;
+ }
+ }
+ for (i = 0; i < nHeaderBytes; i++)
+ {
+- if ((p = strstr((const char *)pHeaderData+i,"data"))) {
++ if ((p = strstr((char *)pHeaderData+i,"data"))) {
+ ULONG_TO_UCHAR_LE((unsigned char *)p+4,nDataSize);
+ break;
+ }
+diff -Nuar mac-3.99-u4-b5-s4-orig/src/MACLib/APELink.cpp mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp
+--- mac-3.99-u4-b5-s4-orig/src/MACLib/APELink.cpp 2006-06-01 11:00:57.000000000 +0200
++++ mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp 2009-12-21 17:38:52.000000000 +0100
+@@ -63,10 +63,10 @@
+ if (pData != NULL)
+ {
+ // parse out the information
+- char * pHeader = strstr(pData, APE_LINK_HEADER);
+- char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
+- char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
+- char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
++ const char * pHeader = strstr(pData, APE_LINK_HEADER);
++ const char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
++ const char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
++ const char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
+
+ if (pHeader && pImageFile && pStartBlock && pFinishBlock)
+ {
+@@ -81,7 +81,7 @@
+
+ // get the path
+ char cImageFile[MAX_PATH + 1]; int nIndex = 0;
+- char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
++ const char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
+ while ((*pImageCharacter != 0) && (*pImageCharacter != '\r') && (*pImageCharacter != '\n'))
+ cImageFile[nIndex++] = *pImageCharacter++;
+ cImageFile[nIndex] = 0;
diff --git a/media-sound/mac/mac-3.99.4.5.4.ebuild b/media-sound/mac/mac-3.99.4.5.4.ebuild
index dacd7876eb34..ca28d4a97413 100644
--- a/media-sound/mac/mac-3.99.4.5.4.ebuild
+++ b/media-sound/mac/mac-3.99.4.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/mac-3.99.4.5.4.ebuild,v 1.2 2009/12/20 20:31:00 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mac/mac-3.99.4.5.4.ebuild,v 1.3 2009/12/21 17:03:42 billie Exp $
EAPI=2
@@ -28,7 +28,7 @@ S=${WORKDIR}/${MY_P}
RESTRICT="mirror"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.99.4.5-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
sed -i -e 's:-O3::' configure || die
}