summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-10 21:50:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-02-10 21:50:03 +0000
commit01fd708cbe8f12623497e06c6bc8a85e1f62582d (patch)
tree411e4e04a640deca797e73c899d26c2cfd66a906 /media-sound/mpg123
parentarm/ia64/s390/sh stable (diff)
downloadgentoo-2-01fd708cbe8f12623497e06c6bc8a85e1f62582d.tar.gz
gentoo-2-01fd708cbe8f12623497e06c6bc8a85e1f62582d.tar.bz2
gentoo-2-01fd708cbe8f12623497e06c6bc8a85e1f62582d.zip
Version bump.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/ChangeLog7
-rw-r--r--media-sound/mpg123/files/digest-mpg123-0.653
-rw-r--r--media-sound/mpg123/mpg123-0.65.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/media-sound/mpg123/ChangeLog b/media-sound/mpg123/ChangeLog
index d7621e0fa53c..d1907b26be8c 100644
--- a/media-sound/mpg123/ChangeLog
+++ b/media-sound/mpg123/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpg123
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.107 2007/01/28 11:47:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.108 2007/02/10 21:50:03 flameeyes Exp $
+
+*mpg123-0.65 (10 Feb 2007)
+
+ 10 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> +mpg123-0.65.ebuild:
+ Version bump.
28 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
-mpg123-0.59s-r9.ebuild:
diff --git a/media-sound/mpg123/files/digest-mpg123-0.65 b/media-sound/mpg123/files/digest-mpg123-0.65
new file mode 100644
index 000000000000..ff777a74f11b
--- /dev/null
+++ b/media-sound/mpg123/files/digest-mpg123-0.65
@@ -0,0 +1,3 @@
+MD5 b15d3e442dcf86133df70f1f3eff7c59 mpg123-0.65.tar.bz2 529154
+RMD160 f28f79425a41cd71d9cca7e817fd3c010f71ab30 mpg123-0.65.tar.bz2 529154
+SHA256 091f0b29e630530b42c4a06671d14a7a9acc0b0cadad90edcf1983e798691e0b mpg123-0.65.tar.bz2 529154
diff --git a/media-sound/mpg123/mpg123-0.65.ebuild b/media-sound/mpg123/mpg123-0.65.ebuild
new file mode 100644
index 000000000000..ce041a317fd3
--- /dev/null
+++ b/media-sound/mpg123/mpg123-0.65.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-0.65.ebuild,v 1.1 2007/02/10 21:50:03 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="Real Time mp3 player"
+HOMEPAGE="http://www.mpg123.de/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="mmx 3dnow alsa oss sdl esd nas jack portaudio"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ sdl? ( !alsa? ( !oss? ( media-libs/libsdl ) ) )
+ esd? ( !alsa? ( !oss? ( !sdl? ( media-sound/esound ) ) ) )
+ nas? ( !alsa? ( !oss? ( !sdl? ( !esd? ( media-libs/nas ) ) ) ) )
+ jack? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( media-sound/jack-audio-connection-kit ) ) ) ) ) )
+ portaudio? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( !jack? ( media-libs/portaudio ) ) ) ) ) ) )"
+
+DEPEND="${RDEPEND}"
+
+PROVIDE="virtual/mpg123"
+
+src_compile() {
+ local audiodev
+ if use alsa; then
+ audiodev="alsa"
+ elif use oss; then
+ audiodev="oss"
+ elif use sdl; then
+ audiodev="sdl"
+ elif use esd; then
+ audiodev="esd"
+ elif use nas; then
+ audiodev="nas"
+ elif use jack; then
+ audiodev="jack"
+ elif use portaudio; then
+ audiodev="portaudio"
+ elif use ppc-macos; then
+ audiodev="macosx";
+ else audiodev="dummy"
+ fi
+
+ if use 3dnow; then
+ myconf="--with-cpu=3dnow"
+ elif use mmx; then
+ myconf="--with-cpu=mmx"
+ fi
+
+ einfo "Compiling with ${audiodev} audio output."
+ einfo "If that is not what you want, then select exactly ONE"
+ einfo "of the following USE flags:"
+ einfo "alsa oss sdl esd nas jack portaudio"
+ einfo "and recompile ${PN}."
+ epause 5
+
+ econf \
+ --with-optimization=0 \
+ --with-audio=$audiodev \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}