summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-12-10 18:39:36 +0000
committerSamuli Suominen <drac@gentoo.org>2007-12-10 18:39:36 +0000
commit5ee1da7ff07469ef8a9bce676e60b6064691e49d (patch)
tree00017e535dc38284ec7539a5e596bf310347d19a /media-sound/mpg123
parentNew homepage (diff)
downloadgentoo-2-5ee1da7ff07469ef8a9bce676e60b6064691e49d.tar.gz
gentoo-2-5ee1da7ff07469ef8a9bce676e60b6064691e49d.tar.bz2
gentoo-2-5ee1da7ff07469ef8a9bce676e60b6064691e49d.zip
Version bump to 1 -series, now installs a shared library and a pkgconfig file for it.
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/ChangeLog9
-rw-r--r--media-sound/mpg123/files/1.0_rc2-no-faltivec.patch12
-rw-r--r--media-sound/mpg123/files/digest-mpg123-1.0_rc23
-rw-r--r--media-sound/mpg123/mpg123-1.0_rc2.ebuild85
4 files changed, 108 insertions, 1 deletions
diff --git a/media-sound/mpg123/ChangeLog b/media-sound/mpg123/ChangeLog
index e5d7b70029f7..ebc3bccf5c95 100644
--- a/media-sound/mpg123/ChangeLog
+++ b/media-sound/mpg123/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/mpg123
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.126 2007/11/29 17:54:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.127 2007/12/10 18:39:34 drac Exp $
+
+*mpg123-1.0_rc2 (10 Dec 2007)
+
+ 10 Dec 2007; Samuli Suominen <drac@gentoo.org>
+ +files/1.0_rc2-no-faltivec.patch, +mpg123-1.0_rc2.ebuild:
+ Version bump to 1 -series, now installs a shared library and a pkgconfig
+ file for it.
29 Nov 2007; Raúl Porcel <armin76@gentoo.org> mpg123-0.67.ebuild:
alpha/ia64/sparc stable wrt #200106 thanks to Tobias Klausmann and Alex
diff --git a/media-sound/mpg123/files/1.0_rc2-no-faltivec.patch b/media-sound/mpg123/files/1.0_rc2-no-faltivec.patch
new file mode 100644
index 000000000000..60f91b7ed019
--- /dev/null
+++ b/media-sound/mpg123/files/1.0_rc2-no-faltivec.patch
@@ -0,0 +1,12 @@
+diff -ur mpg123-1.0rc2.orig/configure.ac mpg123-1.0rc2/configure.ac
+--- mpg123-1.0rc2.orig/configure.ac 2007-12-09 17:13:26.000000000 +0200
++++ mpg123-1.0rc2/configure.ac 2007-12-10 20:24:16.000000000 +0200
+@@ -577,7 +577,7 @@
+ more_sources="$s_gen"
+ ;;
+ altivec)
+- ADD_CFLAGS="$ADD_CFLAGS -maltivec -faltivec"
++ ADD_CFLAGS="$ADD_CFLAGS -maltivec"
+ ADD_CPPFLAGS="$ADD_CPPFLAGS -DREAL_IS_FLOAT -DOPT_ALTIVEC"
+ more_sources="$s_altivec"
+ ;;
diff --git a/media-sound/mpg123/files/digest-mpg123-1.0_rc2 b/media-sound/mpg123/files/digest-mpg123-1.0_rc2
new file mode 100644
index 000000000000..260d72003f13
--- /dev/null
+++ b/media-sound/mpg123/files/digest-mpg123-1.0_rc2
@@ -0,0 +1,3 @@
+MD5 9d2af48224bfb88654d7496ccd39d9e1 mpg123-1.0rc2.tar.bz2 966599
+RMD160 89bad349f8d55c1f5dc3c14cf4322ae138e3dca7 mpg123-1.0rc2.tar.bz2 966599
+SHA256 97d2183851edd2e97afd8ba88586c019310471153bd4456fd0a1179c4c23470e mpg123-1.0rc2.tar.bz2 966599
diff --git a/media-sound/mpg123/mpg123-1.0_rc2.ebuild b/media-sound/mpg123/mpg123-1.0_rc2.ebuild
new file mode 100644
index 000000000000..80fbc961ba88
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.0_rc2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-1.0_rc2.ebuild,v 1.1 2007/12/10 18:39:34 drac Exp $
+
+inherit eutils autotools
+
+MY_P=${P/_/}
+
+DESCRIPTION="Real Time mp3 player"
+HOMEPAGE="http://www.mpg123.de"
+SRC_URI="http://www.${PN}.de/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="3dnow 3dnowext alsa altivec esd jack mmx nas oss portaudio sdl sse"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ sdl? ( !alsa? ( !oss? ( media-libs/libsdl ) ) )
+ esd? ( !alsa? ( !oss? ( !sdl? ( media-sound/esound ) ) ) )
+ nas? ( !alsa? ( !oss? ( !sdl? ( !esd? ( media-libs/nas ) ) ) ) )
+ jack? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( media-sound/jack-audio-connection-kit ) ) ) ) ) )
+ portaudio? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( !jack? ( media-libs/portaudio ) ) ) ) ) ) )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PROVIDE="virtual/mpg123"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-no-faltivec.patch"
+ eautoreconf
+}
+
+src_compile() {
+ local audiodev
+ if use alsa; then
+ audiodev="alsa"
+ elif use oss; then
+ audiodev="oss"
+ elif use sdl; then
+ audiodev="sdl"
+ elif use esd; then
+ audiodev="esd"
+ elif use nas; then
+ audiodev="nas"
+ elif use jack; then
+ audiodev="jack"
+ elif use portaudio; then
+ audiodev="portaudio";
+ else audiodev="dummy"
+ fi
+
+ if use altivec; then
+ myconf="--with-cpu=altivec"
+ elif use 3dnowext; then
+ myconf="--with-cpu=3dnowext"
+ elif use 3dnow; then
+ myconf="--with-cpu=3dnow"
+ elif use sse; then
+ myconf="--with-cpu=sse"
+ elif use mmx; then
+ myconf="--with-cpu=mmx"
+ fi
+
+ elog "Compiling with ${audiodev} audio output."
+ elog "If that is not what you want, then select exactly ONE"
+ elog "of the following USE flags:"
+ elog "alsa oss sdl esd nas jack portaudio"
+ elog "and recompile ${PN}."
+ epause 5
+
+ econf --with-optimization=0 \
+ --with-audio=${audiodev} \
+ ${myconf} || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}