summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-12-10 20:25:18 +0000
committerSamuli Suominen <drac@gentoo.org>2007-12-10 20:25:18 +0000
commit9d6d6af8222681cb9cf65340854a3132ef9ff47c (patch)
treedd9421af76394b4bffe1c588507d741676e9607d /media-sound/mpg123
parenttemp. mask mpg123 1.0 rc2, problems with autotools. dies during configure if ... (diff)
downloadgentoo-2-9d6d6af8222681cb9cf65340854a3132ef9ff47c.tar.gz
gentoo-2-9d6d6af8222681cb9cf65340854a3132ef9ff47c.tar.bz2
gentoo-2-9d6d6af8222681cb9cf65340854a3132ef9ff47c.zip
Add USE pulseaudio, allow more than one audio output by default, can be selected runtime.
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/ChangeLog6
-rw-r--r--media-sound/mpg123/mpg123-1.0_rc2.ebuild66
2 files changed, 32 insertions, 40 deletions
diff --git a/media-sound/mpg123/ChangeLog b/media-sound/mpg123/ChangeLog
index ebc3bccf5c95..055c2387c85c 100644
--- a/media-sound/mpg123/ChangeLog
+++ b/media-sound/mpg123/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/mpg123
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.127 2007/12/10 18:39:34 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/ChangeLog,v 1.128 2007/12/10 20:25:18 drac Exp $
+
+ 10 Dec 2007; Samuli Suominen <drac@gentoo.org> mpg123-1.0_rc2.ebuild:
+ Add USE pulseaudio, allow more than one audio output by default, can be
+ selected runtime.
*mpg123-1.0_rc2 (10 Dec 2007)
diff --git a/media-sound/mpg123/mpg123-1.0_rc2.ebuild b/media-sound/mpg123/mpg123-1.0_rc2.ebuild
index 80fbc961ba88..9f551e88a0ac 100644
--- a/media-sound/mpg123/mpg123-1.0_rc2.ebuild
+++ b/media-sound/mpg123/mpg123-1.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-1.0_rc2.ebuild,v 1.1 2007/12/10 18:39:34 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg123/mpg123-1.0_rc2.ebuild,v 1.2 2007/12/10 20:25:18 drac Exp $
inherit eutils autotools
@@ -13,14 +13,15 @@ SRC_URI="http://www.${PN}.de/download/${MY_P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="3dnow 3dnowext alsa altivec esd jack mmx nas oss portaudio sdl sse"
+IUSE="3dnow 3dnowext alsa altivec esd jack mmx nas oss portaudio pulseaudio sdl sse"
RDEPEND="alsa? ( media-libs/alsa-lib )
- sdl? ( !alsa? ( !oss? ( media-libs/libsdl ) ) )
- esd? ( !alsa? ( !oss? ( !sdl? ( media-sound/esound ) ) ) )
- nas? ( !alsa? ( !oss? ( !sdl? ( !esd? ( media-libs/nas ) ) ) ) )
- jack? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( media-sound/jack-audio-connection-kit ) ) ) ) ) )
- portaudio? ( !alsa? ( !oss? ( !sdl? ( !esd? ( !nas? ( !jack? ( media-libs/portaudio ) ) ) ) ) ) )"
+ sdl? ( media-libs/libsdl )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ jack? ( media-sound/jack-audio-connection-kit )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
@@ -30,51 +31,38 @@ PROVIDE="virtual/mpg123"
src_unpack() {
unpack "${A}"
cd "${S}"
- epatch "${FILESDIR}/${PV}-no-faltivec.patch"
+ epatch "${FILESDIR}"/${PV}-no-faltivec.patch
eautoreconf
}
src_compile() {
- local audiodev
- if use alsa; then
- audiodev="alsa"
- elif use oss; then
- audiodev="oss"
- elif use sdl; then
- audiodev="sdl"
- elif use esd; then
- audiodev="esd"
- elif use nas; then
- audiodev="nas"
- elif use jack; then
- audiodev="jack"
- elif use portaudio; then
- audiodev="portaudio";
- else audiodev="dummy"
- fi
+ local myaudio
+
+ use alsa && myaudio="${myaudio} alsa"
+ use esd && myaudio="${myaudio} esd"
+ use jack && myaudio="${myaudio} jack"
+ use nas && myaudio="${myaudio} nas"
+ use oss && myaudio="${myaudio} oss"
+ use pulseaudio && myaudio="${myaudio} pulse"
+ use sdl && myaudio="${myaudio} sdl"
+
+ local mycpu
if use altivec; then
- myconf="--with-cpu=altivec"
+ mycpu="--with-cpu=altivec"
elif use 3dnowext; then
- myconf="--with-cpu=3dnowext"
+ mycpu="--with-cpu=3dnowext"
elif use 3dnow; then
- myconf="--with-cpu=3dnow"
+ mycpu="--with-cpu=3dnow"
elif use sse; then
- myconf="--with-cpu=sse"
+ mycpu="--with-cpu=sse"
elif use mmx; then
- myconf="--with-cpu=mmx"
+ mycpu="--with-cpu=mmx"
fi
- elog "Compiling with ${audiodev} audio output."
- elog "If that is not what you want, then select exactly ONE"
- elog "of the following USE flags:"
- elog "alsa oss sdl esd nas jack portaudio"
- elog "and recompile ${PN}."
- epause 5
-
econf --with-optimization=0 \
- --with-audio=${audiodev} \
- ${myconf} || die "econf failed."
+ --with-audio="${myaudio}" \
+ ${mycpu} || die "econf failed."
emake || die "emake failed."
}