summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-07-12 08:04:38 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-07-12 08:04:38 +0000
commit50070c15c59f3baa844c11b20e6170f3239f58c2 (patch)
treec02054d1dc641dce17215bbc5b2d22c9e7bd2e0b /media-sound/mpg321
parentmacos keyword (diff)
downloadgentoo-2-50070c15c59f3baa844c11b20e6170f3239f58c2.tar.gz
gentoo-2-50070c15c59f3baa844c11b20e6170f3239f58c2.tar.bz2
gentoo-2-50070c15c59f3baa844c11b20e6170f3239f58c2.zip
Make ebuild play nicer with GRP.
Diffstat (limited to 'media-sound/mpg321')
-rw-r--r--media-sound/mpg321/ChangeLog5
-rw-r--r--media-sound/mpg321/Manifest6
-rw-r--r--media-sound/mpg321/mpg321-0.2.10-r1.ebuild47
3 files changed, 25 insertions, 33 deletions
diff --git a/media-sound/mpg321/ChangeLog b/media-sound/mpg321/ChangeLog
index fe308577be3d..34d4c22252a2 100644
--- a/media-sound/mpg321/ChangeLog
+++ b/media-sound/mpg321/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/mpg321
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/ChangeLog,v 1.17 2004/06/25 00:13:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/ChangeLog,v 1.18 2004/07/12 08:04:38 eradicator Exp $
+
+ 12 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> :
+ Make ebuild play nicer with GRP.
03 May 2004; Jeremy Huddleston <eradicator@gentoo.org>
mpg321-0.2.10-r1.ebuild:
diff --git a/media-sound/mpg321/Manifest b/media-sound/mpg321/Manifest
index 84f68803b83e..4cff97aa09da 100644
--- a/media-sound/mpg321/Manifest
+++ b/media-sound/mpg321/Manifest
@@ -1,5 +1,7 @@
MD5 fa42ad06ae819a8ea869f24cd9e5df52 ChangeLog 2516
-MD5 f2d11f78233de7aff97f453716dfc3c8 mpg321-0.2.10-r1.ebuild 1250
MD5 a1eaeb2ae801daeb712c90c060e922dc metadata.xml 158
-MD5 f69e111b891dc01d56fb394621897e0d files/mpg321-0.1.5-ao.diff 7909
+MD5 f2d11f78233de7aff97f453716dfc3c8 mpg321-0.2.10-r1.ebuild 1250
+MD5 547974b18e36798e85a40a03eea96670 mpg321-0.2.10-r2.ebuild 868
MD5 7f4e867ab9a86c4f3618228fdccc48f4 files/digest-mpg321-0.2.10-r1 65
+MD5 f69e111b891dc01d56fb394621897e0d files/mpg321-0.1.5-ao.diff 7909
+MD5 7f4e867ab9a86c4f3618228fdccc48f4 files/digest-mpg321-0.2.10-r2 65
diff --git a/media-sound/mpg321/mpg321-0.2.10-r1.ebuild b/media-sound/mpg321/mpg321-0.2.10-r1.ebuild
index 99a108297f1e..cffe9779e987 100644
--- a/media-sound/mpg321/mpg321-0.2.10-r1.ebuild
+++ b/media-sound/mpg321/mpg321-0.2.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r1.ebuild,v 1.19 2004/06/25 00:13:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r1.ebuild,v 1.20 2004/07/12 08:04:38 eradicator Exp $
IUSE=""
@@ -17,36 +17,9 @@ KEYWORDS="amd64 x86 ~ppc sparc mips alpha"
PROVIDE="virtual/mpg123"
-MPG123="false"
-
-pkg_setup() {
-
- # test if mpg123 owns the /usr/bin/mpg123 file. If it does, then do not
- # create a symlink. If it is already a symlink or does not exist, then
- # we create it
- if [ -f /usr/bin/mpg123 ]
- then
- if [ -L /usr/bin/mpg123 ]
- then
- MPEG123="false"
- else
- MPEG123="true"
- fi
- else
- MPEG123="false"
- fi
-}
-
src_compile() {
- local myconf
- if [ ${MPEG123} = "true" ]
- then
- myconf="--disable-mpg123-symlink"
- else
- myconf="--enable-mpg123-symlink"
- fi
- einfo ${myconf}
- econf ${myconf} || die
+ # disabling the symlink here and doing it in postinst is better for GRP
+ econf --disable-mpg123-symlink || die
emake || die
}
@@ -54,3 +27,17 @@ src_install () {
make DESTDIR=${D} install || die
dodoc AUTHORS BUGS COPYING ChangeLog HACKING INSTALL NEWS README README.remote THANKS TODO
}
+
+pkg_postinst() {
+ # We create a symlink for /usr/bin/mpg123 if it doesn't already exist
+ if ! [ -f /usr/bin/mpg123 ]; then
+ ln -s mpg321 /usr/bin/mpg123
+ fi
+}
+
+pkg_postrm() {
+ # We can't delete it here because it would break upgrades.
+ if [ -L /usr/bin/mpg123 ]; then
+ einfo "The /usr/bin/mpg123 symlink still exists. You may wish to remove it."
+ fi
+}