summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-03 08:04:49 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-03 08:04:49 +0000
commit1640e65d1f8038bfa3499d8c9eabb25e22c8303f (patch)
tree06ddcca17e7b60c2ce489d61a0fef8d7a76f0aa4 /media-sound/solfege
parentVersion bump for security bug 449826. (diff)
downloadgentoo-2-1640e65d1f8038bfa3499d8c9eabb25e22c8303f.tar.gz
gentoo-2-1640e65d1f8038bfa3499d8c9eabb25e22c8303f.tar.bz2
gentoo-2-1640e65d1f8038bfa3499d8c9eabb25e22c8303f.zip
Version bump. Update to use python-single-r1 eclass.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound/solfege')
-rw-r--r--media-sound/solfege/ChangeLog9
-rw-r--r--media-sound/solfege/solfege-3.20.7.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/media-sound/solfege/ChangeLog b/media-sound/solfege/ChangeLog
index 2e10cdbb52bd..a6842840d2a1 100644
--- a/media-sound/solfege/ChangeLog
+++ b/media-sound/solfege/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/solfege
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/solfege/ChangeLog,v 1.88 2012/09/25 03:22:17 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/solfege/ChangeLog,v 1.89 2013/01/03 08:04:49 radhermit Exp $
+
+*solfege-3.20.7 (03 Jan 2013)
+
+ 03 Jan 2013; Tim Harder <radhermit@gentoo.org> +solfege-3.20.7.ebuild:
+ Version bump. Update to use python-single-r1 eclass.
25 Sep 2012; Tim Harder <radhermit@gentoo.org> -solfege-3.20.4.ebuild:
Remove old.
diff --git a/media-sound/solfege/solfege-3.20.7.ebuild b/media-sound/solfege/solfege-3.20.7.ebuild
new file mode 100644
index 000000000000..cc4223f22800
--- /dev/null
+++ b/media-sound/solfege/solfege-3.20.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/solfege/solfege-3.20.7.ebuild,v 1.1 2013/01/03 08:04:49 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1
+
+DESCRIPTION="GNU Solfege is a program written to help you practice ear training."
+HOMEPAGE="http://www.solfege.org"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa oss"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pygtk-2.12
+ gnome-base/librsvg
+ alsa? ( dev-python/pyalsa )
+ !oss? ( media-sound/timidity++ )"
+DEPEND="${PYTHON_DEPS}
+ dev-lang/swig
+ sys-devel/gettext
+ sys-apps/texinfo
+ virtual/pkgconfig
+ dev-libs/libxslt
+ app-text/txt2man
+ >=app-text/docbook-xsl-stylesheets-1.60"
+
+src_prepare() {
+ sed -i -e '/^CFLAGS/s:-I/usr/src/linux/include::' \
+ solfege/soundcard/Makefile || die "sed failed"
+}
+
+src_configure() {
+ local xslloc=$( xmlcatalog /etc/xml/catalog http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl | sed 's@file://@@' )
+
+ econf \
+ --enable-docbook-stylesheet=${xslloc} \
+ $(use_enable oss oss-sound)
+}
+
+src_compile() {
+ emake skipmanual=yes
+}
+
+src_install() {
+ emake DESTDIR="${ED}" nopycompile=YES skipmanual=yes install
+ dodoc AUTHORS *hange*og FAQ README
+}