summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-30 00:45:59 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-30 00:45:59 +0000
commit0942e5da6d412ecf8fe8d918e3757e3ac8160c79 (patch)
tree7bb453ced0dad4d297dc85b5a83d409d231be59e /media-sound
parentNew package for sys-process/ftop, monitors open files and filesystems; tested... (diff)
downloadgentoo-2-0942e5da6d412ecf8fe8d918e3757e3ac8160c79.tar.gz
gentoo-2-0942e5da6d412ecf8fe8d918e3757e3ac8160c79.tar.bz2
gentoo-2-0942e5da6d412ecf8fe8d918e3757e3ac8160c79.zip
Update to EAPI 5 and use waf-utils and python-any-r1 eclasses (fixes bug #442168).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/patchage/ChangeLog11
-rw-r--r--media-sound/patchage/files/patchage-0.5.0-desktop.patch8
-rw-r--r--media-sound/patchage/patchage-0.5.0-r1.ebuild44
3 files changed, 61 insertions, 2 deletions
diff --git a/media-sound/patchage/ChangeLog b/media-sound/patchage/ChangeLog
index 8b704ebab9ee..ab5aa9a56e7a 100644
--- a/media-sound/patchage/ChangeLog
+++ b/media-sound/patchage/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/patchage
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/ChangeLog,v 1.14 2012/05/05 08:45:11 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/ChangeLog,v 1.15 2014/01/30 00:45:59 radhermit Exp $
+
+*patchage-0.5.0-r1 (30 Jan 2014)
+
+ 30 Jan 2014; Tim Harder <radhermit@gentoo.org> +patchage-0.5.0-r1.ebuild,
+ +files/patchage-0.5.0-desktop.patch:
+ Update to EAPI 5 and use waf-utils and python-any-r1 eclasses (fixes bug
+ #442168).
05 May 2012; Michał Górny <mgorny@gentoo.org> patchage-0.4.2.ebuild,
patchage-0.4.4.ebuild, patchage-0.4.5.ebuild, patchage-0.5.0.ebuild:
diff --git a/media-sound/patchage/files/patchage-0.5.0-desktop.patch b/media-sound/patchage/files/patchage-0.5.0-desktop.patch
new file mode 100644
index 000000000000..cf4eaeaaa788
--- /dev/null
+++ b/media-sound/patchage/files/patchage-0.5.0-desktop.patch
@@ -0,0 +1,8 @@
+--- patchage-0.5.0/patchage.desktop.in
++++ patchage-0.5.0/patchage.desktop.in
+@@ -6,4 +6,4 @@
+ Terminal=false
+ Icon=@APP_INSTALL_NAME@
+ Type=Application
+-Categories=Application;AudioVideo;Audio
++Categories=AudioVideo;Audio;
diff --git a/media-sound/patchage/patchage-0.5.0-r1.ebuild b/media-sound/patchage/patchage-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..40ec8463e5ed
--- /dev/null
+++ b/media-sound/patchage/patchage-0.5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/patchage/patchage-0.5.0-r1.ebuild,v 1.1 2014/01/30 00:45:59 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils waf-utils python-any-r1
+
+DESCRIPTION="Modular patch bay for audio and MIDI systems"
+HOMEPAGE="http://wiki.drobilla.net/Patchage"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug lash"
+
+RDEPEND=">=media-libs/raul-0.7.0
+ >=x11-libs/flowcanvas-0.7.1
+ >=dev-cpp/gtkmm-2.11.12:2.4
+ >=dev-cpp/glibmm-2.14:2
+ >=dev-cpp/libglademm-2.6.0:2.4
+ dev-cpp/libgnomecanvasmm:2.6
+ dev-libs/boost
+ >=media-sound/jack-audio-connection-kit-0.107
+ alsa? ( media-libs/alsa-lib )
+ lash? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README ChangeLog )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop.patch
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ $(use debug && echo "--debug") \
+ $(use alsa || echo "--no-alsa") \
+ $(use lash || echo "--no-lash")
+}