summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-07-30 23:58:57 +0000
committerBrian Evans <grknight@gentoo.org>2014-07-30 23:58:57 +0000
commit9fc230ae6e8ca835d14755f4caa2f8ae743791ff (patch)
tree47860310f0e22ce8f25c6e4a71c9cf554363244f /media-sound
parentVersion bump. (diff)
downloadgentoo-2-9fc230ae6e8ca835d14755f4caa2f8ae743791ff.tar.gz
gentoo-2-9fc230ae6e8ca835d14755f4caa2f8ae743791ff.tar.bz2
gentoo-2-9fc230ae6e8ca835d14755f4caa2f8ae743791ff.zip
Revision bump to fix libmysqld rpath. Patch by Gabriel Marcano <gabemarcano@yahoo.com> from bug 508824. Ack by
jmbsvicetto (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-2.8.0-r3.ebuild137
-rw-r--r--media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch12
3 files changed, 157 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index aa3bda03ee42..db21540a343e 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.470 2014/07/17 13:22:57 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.471 2014/07/30 23:58:57 grknight Exp $
+
+*amarok-2.8.0-r3 (30 Jul 2014)
+
+ 30 Jul 2014; Brian Evans <grknight@gentoo.org> +amarok-2.8.0-r3.ebuild,
+ +files/amarok-2.8.0-mysqld-rpath.patch:
+ Revision bump to fix libmysqld rpath. Patch by Gabriel Marcano
+ <gabemarcano@yahoo.com> from bug 508824. Ack by jmbsvicetto
17 Jul 2014; Michael Palimaka <kensington@gentoo.org> amarok-2.8.0-r2.ebuild:
Remove workaround now handled in the eclass.
diff --git a/media-sound/amarok/amarok-2.8.0-r3.ebuild b/media-sound/amarok/amarok-2.8.0-r3.ebuild
new file mode 100644
index 000000000000..2555902e1226
--- /dev/null
+++ b/media-sound/amarok/amarok-2.8.0-r3.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.8.0-r3.ebuild,v 1.1 2014/07/30 23:58:57 grknight Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl hu it ja
+lt lv nb nl pa pl pt pt_BR ro ru sl sr sr@ijekavian sr@ijekavianlatin sr@latin
+sv tr uk zh_CN zh_TW"
+KDE_REQUIRED="never"
+KDE_HANDBOOK="optional"
+KDE_MINIMAL="4.13.1"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit flag-o-matic kde4-base pax-utils
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} != *9999* ]]; then
+ if [[ $PV == *[6-9][0-9]* ]]; then
+ SRC_URI="mirror://kde/unstable/${PN}/${PV}/src/${P}.tar.bz2"
+ else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+ fi
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="cdda debug +embedded ipod lastfm mp3tunes mtp nepomuk ofa opengl test +utils"
+
+if [[ ${KDE_BUILD_TYPE} == live ]]; then
+ RESTRICT="test"
+fi
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ app-crypt/qca:2
+ $(add_kdebase_dep kdelibs 'nepomuk?,opengl?' 4.8.4)
+ $(add_kdebase_dep kdebase-kioslaves)
+ >=media-libs/taglib-1.7[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ sys-libs/zlib
+ >=virtual/mysql-5.1[embedded?]
+ >=dev-qt/qtcore-4.8:4
+ >=dev-qt/qtdbus-4.8:4
+ >=dev-qt/qtscript-4.8:4
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ $(add_kdebase_dep libkcddb)
+ $(add_kdebase_dep libkcompactdisc)
+ $(add_kdebase_dep audiocd-kio)
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-1.0.3 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ >=dev-qt/qtcore-4.8.4:4[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ nepomuk? ( >=kde-base/nepomuk-core-4.9.0 )
+ ofa? ( >=media-libs/libofa-0.9.0 )
+ opengl? ( virtual/opengl )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ virtual/pkgconfig
+ test? ( dev-cpp/gmock )
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ $(add_kdebase_dep phonon-kde)
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gmock-1.7.patch"
+ "${FILESDIR}/${P}-mysqld-rpath.patch"
+)
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+
+ local mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ -DWITH_SPECTRUM_ANALYZER=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_with ofa LibOFA)
+ $(cmake-utils_use_with utils UTILITIES)
+ )
+
+ # Add libmysqld location for rpath patch; bug 508824
+ use embedded && mycmakeargs+=(-DMYSQLD_DIR="${EPREFIX}/usr/$(get_libdir)/mysql")
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ # bug 481592
+ pax-mark m "${ED}"/usr/bin/amarok
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "virtual/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch b/media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch
new file mode 100644
index 000000000000..80dc93dc6b14
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.0-mysqld-rpath.patch
@@ -0,0 +1,12 @@
+--- src/core-impl/collections/db/sql/mysqlecollection/CMakeLists.txt.orig 2014-06-15 18:31:07.362415065 -0400
++++ src/core-impl/collections/db/sql/mysqlecollection/CMakeLists.txt 2014-06-15 18:33:19.612419882 -0400
+@@ -28,6 +28,9 @@
+ ${ZLIB_LIBRARIES}
+ )
+
++SET_TARGET_PROPERTIES(amarok_collection-mysqlecollection PROPERTIES BUILD_WITH_INSTALL_RPATH TRUE)
++SET_TARGET_PROPERTIES(amarok_collection-mysqlecollection PROPERTIES INSTALL_RPATH "${MYSQLD_DIR}")
++
+ if(NOT WIN32 AND NOT APPLE)
+ target_link_libraries( amarok_collection-mysqlecollection crypt pthread )
+ endif(NOT WIN32 AND NOT APPLE)