summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-22 01:15:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-22 01:15:01 +0000
commitf622a24cb1208a346443384a84e2ca4e2e988ecc (patch)
treef32864650b1235ce62b6dc1efd3c66b9c026aab7 /media-sound
parentremove gnome from metadata (diff)
downloadgentoo-2-f622a24cb1208a346443384a84e2ca4e2e988ecc.tar.gz
gentoo-2-f622a24cb1208a346443384a84e2ca4e2e988ecc.tar.bz2
gentoo-2-f622a24cb1208a346443384a84e2ca4e2e988ecc.zip
Add patch to fix build on PPC systems.
(Portage version: 2.1_pre1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog6
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild3
-rw-r--r--media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch40
3 files changed, 47 insertions, 2 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index aac4e97e99a3..c44e220d5ba2 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.176 2005/12/21 15:48:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.177 2005/12/22 01:15:01 flameeyes Exp $
+
+ 22 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/alsa-driver-1.0.11_rc1-ppc.patch, alsa-driver-1.0.11_rc1.ebuild:
+ Add patch to fix build on PPC systems.
*alsa-driver-1.0.11_rc1 (21 Dec 2005)
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild
index f579dc27caf1..7afcff50987b 100644
--- a/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild,v 1.1 2005/12/21 15:48:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.11_rc1.ebuild,v 1.2 2005/12/22 01:15:01 flameeyes Exp $
inherit linux-mod flag-o-matic eutils
@@ -71,6 +71,7 @@ src_unpack() {
cd ${S}
epatch "${FILESDIR}"/${PN}-1.0.10_rc1-include.patch
+ epatch "${FILESDIR}/${P}-ppc.patch"
convert_to_m ${S}/Makefile
sed -i -e 's:\(.*depmod\):#\1:' ${S}/Makefile
diff --git a/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch b/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch
new file mode 100644
index 000000000000..f33f9b1325dc
--- /dev/null
+++ b/media-sound/alsa-driver/files/alsa-driver-1.0.11_rc1-ppc.patch
@@ -0,0 +1,40 @@
+Index: alsa-driver-1.0.11rc1/ppc/tumbler.patch
+===================================================================
+--- alsa-driver-1.0.11rc1.orig/ppc/tumbler.patch
++++ alsa-driver-1.0.11rc1/ppc/tumbler.patch
+@@ -15,21 +15,21 @@
+ static struct work_struct device_change;
+ +#endif
+
+- static void
+- device_change_handler(void *self)
+-@@ -895,7 +900,11 @@
+-
+- /* finally we need to schedule an update of the mixer values
+- (master and DRC are enough for now) -ReneR */
++ static void device_change_handler(void *self)
++ {
++@@ -1009,7 +1014,11 @@
++ mix = chip->mixer_data;
++ snd_assert(mix, return);
++ mix->auto_mute_notify = do_notify;
+ +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
+ + schedule_task(&device_change);
+ +#else
+ schedule_work(&device_change);
+ +#endif
+-
+ }
+ }
+-@@ -1156,7 +1165,11 @@
++ #endif /* PMAC_SUPPORT_AUTOMUTE */
++@@ -1416,7 +1425,11 @@
+ chip->resume = tumbler_resume;
+ #endif
+
+@@ -40,4 +40,4 @@
+ +#endif
+
+ #ifdef PMAC_SUPPORT_AUTOMUTE
+- if (mix->headphone_irq >=0 && (err = snd_pmac_add_automute(chip)) < 0)
++ if ((mix->headphone_irq >=0 || mix->lineout_irq >= 0)