summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-15 19:46:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-15 19:46:08 +0000
commit1eb43bb7ab597881c3931246d7b00d7cf9c32f69 (patch)
tree7a1655179aec9d3251230f92c5863ce884f3c9bd /media-video/isight-firmware-tools
parentBump to 0.6.6-r2. Fix compilation on 2.6.28, closes #254564. (diff)
downloadgentoo-2-1eb43bb7ab597881c3931246d7b00d7cf9c32f69.tar.gz
gentoo-2-1eb43bb7ab597881c3931246d7b00d7cf9c32f69.tar.bz2
gentoo-2-1eb43bb7ab597881c3931246d7b00d7cf9c32f69.zip
Bump to 1.4.1. Add more hash for firmware extraction.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-video/isight-firmware-tools')
-rw-r--r--media-video/isight-firmware-tools/ChangeLog9
-rw-r--r--media-video/isight-firmware-tools/isight-firmware-tools-1.2.ebuild39
-rw-r--r--media-video/isight-firmware-tools/isight-firmware-tools-1.4.1.ebuild (renamed from media-video/isight-firmware-tools/isight-firmware-tools-1.4.ebuild)7
3 files changed, 12 insertions, 43 deletions
diff --git a/media-video/isight-firmware-tools/ChangeLog b/media-video/isight-firmware-tools/ChangeLog
index ad02561cd249..7f35b487e982 100644
--- a/media-video/isight-firmware-tools/ChangeLog
+++ b/media-video/isight-firmware-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/isight-firmware-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/isight-firmware-tools/ChangeLog,v 1.7 2009/02/15 19:11:03 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/isight-firmware-tools/ChangeLog,v 1.8 2009/02/15 19:46:08 eva Exp $
+
+*isight-firmware-tools-1.4.1 (15 Feb 2009)
+
+ 15 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -isight-firmware-tools-1.2.ebuild, -isight-firmware-tools-1.4.ebuild,
+ +isight-firmware-tools-1.4.1.ebuild:
+ Bump to 1.4.1. Add more hash for firmware extraction.
*isight-firmware-tools-1.4 (15 Feb 2009)
diff --git a/media-video/isight-firmware-tools/isight-firmware-tools-1.2.ebuild b/media-video/isight-firmware-tools/isight-firmware-tools-1.2.ebuild
deleted file mode 100644
index 026b94cc6414..000000000000
--- a/media-video/isight-firmware-tools/isight-firmware-tools-1.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/isight-firmware-tools/isight-firmware-tools-1.2.ebuild,v 1.2 2008/08/03 19:39:47 eva Exp $
-
-inherit eutils
-
-DESCRIPTION="Extract, load or export firmware for the iSight webcams"
-HOMEPAGE="http://bersace03.free.fr/ift/"
-SRC_URI="http://launchpad.net/${PN}/main/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="dev-libs/glib
- dev-libs/libusb
- dev-libs/libgcrypt"
-# >=sys-apps/hal-0.5.9"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35.5
- sys-apps/texinfo"
-
-src_compile() {
- # https://bugs.launchpad.net/isight-firmware-tools/+bug/243255
- econf --enable-udev --disable-hal || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}
-
-pkg_postinst() {
- elog "You need to extract your firmware prior to being able to loading it"
- elog "ift-extract --apple-driver /macos/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport"
- elog "If you do not have OSX you can get AppleUSBVideoSupport from"
- elog "http://www.mediafire.com/?81xtkqyttjt"
-}
diff --git a/media-video/isight-firmware-tools/isight-firmware-tools-1.4.ebuild b/media-video/isight-firmware-tools/isight-firmware-tools-1.4.1.ebuild
index 4febb5606051..048adebfd512 100644
--- a/media-video/isight-firmware-tools/isight-firmware-tools-1.4.ebuild
+++ b/media-video/isight-firmware-tools/isight-firmware-tools-1.4.1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/isight-firmware-tools/isight-firmware-tools-1.4.ebuild,v 1.1 2009/02/15 19:11:03 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/isight-firmware-tools/isight-firmware-tools-1.4.1.ebuild,v 1.1 2009/02/15 19:46:08 eva Exp $
-inherit autotools eutils multilib
+inherit autotools eutils multilib versionator
+MY_MAJORV=$(get_version_component_range 1-2)
DESCRIPTION="Extract, load or export firmware for the iSight webcams"
HOMEPAGE="http://bersace03.free.fr/ift/"
-SRC_URI="http://launchpad.net/${PN}/main/${PV}/+download/${P}.tar.gz"
+SRC_URI="http://launchpad.net/${PN}/main/${MY_MAJORV}/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"