summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-05-21 05:09:24 +0000
committerSteve Dibb <beandog@gentoo.org>2008-05-21 05:09:24 +0000
commit1af409097ebe85101dc4b0348e4510c3c6f5753b (patch)
treeb716934ad93c0025489e06af548e7a1e52718938 /media-video/mplayer/files
parentremove old (diff)
downloadgentoo-2-1af409097ebe85101dc4b0348e4510c3c6f5753b.tar.gz
gentoo-2-1af409097ebe85101dc4b0348e4510c3c6f5753b.tar.bz2
gentoo-2-1af409097ebe85101dc4b0348e4510c3c6f5753b.zip
Fix compilation on sparc, x86; remove strip restrction; move cpu opts out of custom-cflags check
(Portage version: 2.1.5)
Diffstat (limited to 'media-video/mplayer/files')
-rw-r--r--media-video/mplayer/files/configure-altivec.patch16
-rw-r--r--media-video/mplayer/files/libswscale-sparc.patch21
2 files changed, 37 insertions, 0 deletions
diff --git a/media-video/mplayer/files/configure-altivec.patch b/media-video/mplayer/files/configure-altivec.patch
new file mode 100644
index 000000000000..7a1cfa5c4473
--- /dev/null
+++ b/media-video/mplayer/files/configure-altivec.patch
@@ -0,0 +1,16 @@
+--- configure.orig 2008-05-20 22:18:27.000000000 -0600
++++ configure 2008-05-20 22:21:21.000000000 -0600
+@@ -2418,10 +2418,9 @@
+ cat > $TMPC << EOF
+ int main(void) { return 0; }
+ EOF
+- cc_check -maltivec -mabi=altivec \
+- && _altivec_gcc_flags="-maltivec -mabi=altivec" \
+- || cc_check -faltivec && _altivec_gcc_flags=-faltivec \
+- || _altivec=no
++ cc_check -maltivec -mabi=altivec && _altivec_gcc_flags="-maltivec -mabi=altivec"
++ test "x$_altivec_gcc_flags" = "x" && cc_check -faltivec && _altivec_gcc_flags=-faltivec
++ test "x$_altivec_gcc_flags" = "x" && _altivec=no
+ echores "$_altivec_gcc_flags"
+
+ # check if <altivec.h> should be included
diff --git a/media-video/mplayer/files/libswscale-sparc.patch b/media-video/mplayer/files/libswscale-sparc.patch
new file mode 100644
index 000000000000..f36b59eccfc8
--- /dev/null
+++ b/media-video/mplayer/files/libswscale-sparc.patch
@@ -0,0 +1,21 @@
+--- libswscale/Makefile- 2008-05-17 19:28:46.000000000 +0000
++++ libswscale/Makefile 2008-05-17 19:29:16.000000000 +0000
+@@ -9,7 +9,7 @@
+ OBJS-$(CONFIG_GPL) += yuv2rgb.o
+ OBJS-$(CONFIG_MLIB) += yuv2rgb_mlib.c
+ OBJS-$(HAVE_ALTIVEC) += yuv2rgb_altivec.o
+-OBJS-$(HAVE_VIS) += yuv2rgb_vis.c
++OBJS-$(HAVE_VIS) += yuv2rgb_vis.o
+
+ ASM_OBJS-$(ARCH_BFIN) += internal_bfin.o
+
+--- libswscale/yuv2rgb_vis.c- 2008-05-17 19:28:59.000000000 +0000
++++ libswscale/yuv2rgb_vis.c 2008-05-17 19:30:01.000000000 +0000
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+
+ #include "swscale.h"
++#include "swscale_internal.h"
+
+ #define YUV2RGB_INIT \
+ "wr %%g0, 0x10, %%gsr \n\t" \