summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-03-08 09:46:07 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-03-08 09:46:07 +0000
commite2abb3b99f279e63c63f90a260414ae6b4e0cd90 (patch)
treeef935e98690595512afef1d3e12932918bf75fba /media-video/spca5xx
parentadd load path correctly, fixes bug 169588, reported by Ulrich Mueller <ulm@kp... (diff)
downloadgentoo-2-e2abb3b99f279e63c63f90a260414ae6b4e0cd90.tar.gz
gentoo-2-e2abb3b99f279e63c63f90a260414ae6b4e0cd90.tar.bz2
gentoo-2-e2abb3b99f279e63c63f90a260414ae6b4e0cd90.zip
Do not use pkg_setup vars before pkg_setup, bug 168051
(Portage version: 2.1.2-r12)
Diffstat (limited to 'media-video/spca5xx')
-rw-r--r--media-video/spca5xx/ChangeLog8
-rw-r--r--media-video/spca5xx/files/digest-spca5xx-200602023
-rw-r--r--media-video/spca5xx/spca5xx-20060202.ebuild30
-rw-r--r--media-video/spca5xx/spca5xx-20060301.ebuild10
-rw-r--r--media-video/spca5xx/spca5xx-20060402.ebuild10
5 files changed, 20 insertions, 41 deletions
diff --git a/media-video/spca5xx/ChangeLog b/media-video/spca5xx/ChangeLog
index 202f8a72f860..410c7fd30f21 100644
--- a/media-video/spca5xx/ChangeLog
+++ b/media-video/spca5xx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/spca5xx
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/ChangeLog,v 1.26 2006/11/17 12:03:26 zzam Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/ChangeLog,v 1.27 2007/03/08 09:46:07 genstef Exp $
+
+ 08 Mar 2007; <genstef@gentoo.org> -spca5xx-20060202.ebuild,
+ spca5xx-20060301.ebuild, spca5xx-20060402.ebuild:
+ Do not use pkg_setup vars before pkg_setup, bug 168051
*spca5xx-20060501-r2 (17 Nov 2006)
diff --git a/media-video/spca5xx/files/digest-spca5xx-20060202 b/media-video/spca5xx/files/digest-spca5xx-20060202
deleted file mode 100644
index 0d2dc7ff89f0..000000000000
--- a/media-video/spca5xx/files/digest-spca5xx-20060202
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 5cd947396b2a0ce40e51c6edb205cc39 spca5xx-20060202.tar.gz 193391
-RMD160 c39344edd063bc8159737279c773d9e5daca243d spca5xx-20060202.tar.gz 193391
-SHA256 514a8c57240b0c7767ba359d85b7980b7eaae6021f3117ae26fa562c2c562724 spca5xx-20060202.tar.gz 193391
diff --git a/media-video/spca5xx/spca5xx-20060202.ebuild b/media-video/spca5xx/spca5xx-20060202.ebuild
deleted file mode 100644
index e943190a8dd0..000000000000
--- a/media-video/spca5xx/spca5xx-20060202.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060202.ebuild,v 1.1 2006/02/14 16:28:33 puggy Exp $
-
-inherit linux-mod
-
-DESCRIPTION="spca5xx driver for webcams."
-HOMEPAGE="http://mxhaard.free.fr/spca5xx.html"
-SRC_URI="http://mxhaard.free.fr/spca50x/Download/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-RESTRICT=""
-DEPEND=""
-RDEPEND=""
-
-MODULE_NAMES="spca5xx(usb/video:)"
-BUILD_PARAMS="KERNELDIR=${KV_DIR}"
-BUILD_TARGETS="default"
-
-src_unpack() {
- unpack ${A}
- convert_to_m ${S}/Makefile
-}
-
-src_install() {
- dodoc CHANGELOG INSTALL README
- linux-mod_src_install
-}
diff --git a/media-video/spca5xx/spca5xx-20060301.ebuild b/media-video/spca5xx/spca5xx-20060301.ebuild
index 3ea206d8253c..853124fb0d02 100644
--- a/media-video/spca5xx/spca5xx-20060301.ebuild
+++ b/media-video/spca5xx/spca5xx-20060301.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060301.ebuild,v 1.2 2006/04/14 15:54:11 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060301.ebuild,v 1.3 2007/03/08 09:46:07 genstef Exp $
inherit linux-mod
@@ -16,9 +16,13 @@ DEPEND=""
RDEPEND=""
MODULE_NAMES="spca5xx(usb/video:)"
-BUILD_PARAMS="KERNELDIR=${KV_DIR}"
BUILD_TARGETS="default"
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
src_unpack() {
unpack ${A}
convert_to_m ${S}/Makefile
diff --git a/media-video/spca5xx/spca5xx-20060402.ebuild b/media-video/spca5xx/spca5xx-20060402.ebuild
index 8322482e7543..8f18be0ad20a 100644
--- a/media-video/spca5xx/spca5xx-20060402.ebuild
+++ b/media-video/spca5xx/spca5xx-20060402.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060402.ebuild,v 1.1 2006/04/14 15:54:11 kingtaco Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060402.ebuild,v 1.2 2007/03/08 09:46:07 genstef Exp $
inherit linux-mod
@@ -16,9 +16,13 @@ DEPEND=""
RDEPEND=""
MODULE_NAMES="spca5xx(usb/video:)"
-BUILD_PARAMS="KERNELDIR=${KV_DIR}"
BUILD_TARGETS="default"
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
src_unpack() {
unpack ${A}
convert_to_m ${S}/Makefile